Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Lenovo X1 Carbon imaging via DS 7.1 (Ghost)

Created: 14 Nov 2012 | 17 comments

Has anyone had any luck with deploying images to the Lenovo X1 Carbon ultrabook?  I can get it into PXE and have network support and can see the SSD, but once Ghost starts it tries to run TRIM on the SSD, and then I get an error stating that bad blocks have been encountered and an unknown software exception.  I hit OK and Ghost closes.

We're trying to get a few of these deployed to executives (naturally), so any help you guys can provide would be awesome.

We're running DS 7.1 SP2 (not MP1).

 

Thanks in advance!

Comments 17 CommentsJump to latest comment

BBC's picture

Are you using the USB to Ethernet adapter or do you use WLAN to PXE boot? If I'm not wrong, the TRIM part is to securely wipe the drive, so why not use DiskPart as an alternative?

etk1131's picture

I'm using the USB to Ethernet adapter to PXE boot to my site server.  TRIM automatically runs when Ghost is invoked, and I have yet to find a way to prevent it.  Once it fails, I could potentially use diskpart, but that doesn't get me anywhere when I want to lay the Ghost image down onto the drive, unfortunately.

Anders Thuresson's picture

Can anyone be so helpful and direct me to the nic drivers for winpe 2.1 for the X1 Carbon. Have tried with different drivers but the usb adapter wont pick it up. The computer does pxe boot but will not get any IP when entering winpe.

Our enviroment is DS 7.1

Thank you.

 

etk1131's picture

Hi Anders,

I cheated.  There are no Vista drivers (that worked for me) for the Lenovo USB Ethernet adapter.  I had to include the USB3 drivers and then added the USB 3.0 port replicator to my WinPE 2.1 installation, since those drivers are recognized in that environment.  Once I had those in there, I could boot using the Lenovo Adapter, and once in PXE Automation, I switch the cable to the USB 3.0 port replicator, where it gets the IP.

I'm still not able to image it using Ghost, however, and am working with Support to figure it out.

Hope this helps!

 

Jerome_C_75's picture

Hi All,

I try to capture X1 Carbon on DS 6.9 using USB ethernet dongle that supports PXE booting (PN 0A36322) but it's doesn't work when entering on WinPE.

You can see error in screenshot....

No signal appears on USB Dongle

I've downloaded differents versions of Asys AX88772B drivers for Vista and integrated it in PE but i'm not able to enable ethernet dongle.

Anders, have you same problem as me ? Have you find any solution ?

I will continue testing tomorrow and I'll update this post if I find any solution

Also, I hope someone can help me. Bye

Anders Thuresson's picture

Yes, I finally got it to pick up an IP. See attachment.

I had to download the Vista x86 drivers from Asix website and then manually change the .inf file with the hardware ID for the dongle as recognized in Windows. In DS 6.9 you might still be using older winpe than 2.1 that is based on Windows XP. Than you will need to modify those drivers hopefully with the same hardware ID. You can test this by installing it on Windows XP machine, with the drivers from Lenovo of course. 

from VID_0B95&PID_772B -> VID_17EF&PID_7203

I made the change under "Controlflag" and "USB.NTx86.6.0".

You can test the driver by putting it on a USB and use "drvload Ax88772b.inf" command in winpe. This should fire up your dongle in a couple of seconds and give you an IP.  

If I remember correctly the dongle only works on the left USB port, since this is 2.0.

But now I have the same problem as others with the TRIM command and if I use the -NOTRIM switch by manually starting ghost from server via commands, it wont deploy the image. The error it gives me is something about not being able to open the image.

So my next move is to try with an older ghost version that do not have the TRIM switch.

AttachmentSize
Lenovo_usb_winpe_2.1.zip 1.06 MB
Jrr's picture

Anders - Thank you for this it was really helpful !!! 

Jerome_C_75's picture

Hi Anders,

 

Thank you for your response



Also, this morning, I downloaded from Asix website drivers for AX88772 instead AX88772B (Vista 32 bits Drivers)

Zip File  AX88772A_760_772_Vista_32bit_Driver_v3.8.3.23_WHQL.zip can be donwloaded from http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=86;71;101&PLine=71

I've updated my WinPE2 with theses drivers and now, USB Dongle Adapter works fine.

Actually, I'm capturing X1 Carbon factory image (with Rdeploy).... in progress... and i'll try to deploy disk image on another X1 to do a test. If I find information about TRIM, I'll update this post.

After, i'll create my own master about this model.

Thanks for all

etk1131's picture

Anders,

Great work on the .inf file.  I had used the Win7 one for the Lenovo and tried a similar method to trick it for Vista, but yours is a better solution.

Unfortunately I'm at the same spot as you with Ghost.  From what Support has said, there's a possible issue with the ghconfig not being able to read the bcd file properly, and that could be causing the issues we're seeing.  I'll post more if and when I have info.

 

etk1131's picture

I got my Ghost image to work!!

I cloned my production Win7 (64-bit) image deploy task, then went into Advanced properties.  On the Command-line tab in the Command-Line Options field, I simply put in -NOTRIM (which I didn't know existed until your post, Anders).  I saved it and was able to deploy it to my X1. 

So, now I have a way to PXE without having to use the USB 3.0 dock, and a working image.  I suppose I could add the -NOTRIM command to my production job since we don't have too many SSDs out there to image as well, and so I don't have to add another Initial Deployment option for my techs.

Either way, this is all very encouraging.  I will report my findings to Support, and hopefully they'll be able to fix the issues in a future release...

Anders Thuresson's picture

Nice, it worked for me too. First I tried with an older ghost from DS 6.9, I think it was version 11.5.1. It doesn't have trim support and I was able to deploy the image, and then I saw your post and tried it out editing the deploy task and it worked like a charm.

Now we can finally start testing the device for real, so our executives can start using them. Maybe I get one for myself :). I like the ultrabook feeling of it.

 

PerryWillis's picture

Can't thank everyone who posted here enough. Had an X1 Carbon dropped in my lap yesterday and started banging my head against a wall looking for WinPE drivers. Am using Rdeploy and will hopefully not have to worry about the TRIM command or I will look for an equivalent. 

Thanks again to everyone. 

PerryWillis's picture

Spoke too soon. Can't get that driver to add to my list in WinPE configuration. Choose "Have Disk", choose the .inf, looks like it gets added and refreshes. Does not show up in the list. I checked Bootwiz\platforms\Winpe2\x86\Drivers\CUSTOM\Drivers\Ax88772b and the folder is there with the contents.

I tried adding it using both Anders zipped file for x86 and downloaded/modified per Jerome, and neither showed up on the driver list.  

I've tried looking for the description, the vendor, the device, etc, and it just does not show up. Any suggestions?

 

Running Altiris 6.9 SP 4

etk1131's picture

Did you recreate your preboot environment after adding the driver?

Also, I had to delete the Ax88772b folder under the CUSTOM directory and re-add the driver that Anders provided in order for it to work properly.  So basically I had to add it twice.

If it's still not working, make sure you plug the USB Ethernet adapter into a USB 2.0 slot (on the left on my X1), and not the USB3 ones, unless you've added USB3 drivers (maybe this should be the first thing to check :)).

 

escholte's picture

Just to addd my two cents..

I had a Lenovo T430 that would not boot into automation with using its network. It turned out to bee something very funny. Let me sum up what happened:

  • The network drivers were not loaded
  • Tried to add them -> No go

Found out (with the help of Symantec support that the driver in my case is already in the pack of drivers that DS 7.1 preboot already is equipped with.  (Furthermore, the driver turned out to be axactly the same with one minor difference: there was no "Lenovo" listed for the network chipnumer within the original inf file. What happens then is:

  • You supply DS 7.1 with an extra driver, all of that works fine, because you can see the files been put on the server.
  • When you rebuild the Preboot environment it processes the drivers you added, but finds them in its own repository as well
  • At that point your driver is skipped, assuming that the original driver is best.

What we (Symantec support and myself) did, was:

  1. Move the folder containing the original driver.
  2. Add our own driver
  3. Rebuild the preboot environment.

That works for us. If you like to use the X64 preboot, then you need to do this in the X64 environment.

Douglas Hindle's picture

Purchased an X1 Carbon and PXE dongle 0a36322 / 04w6947. Just cannot find Vista 32 bit drivers for my Winpe.

 

Unfortunately, the link Lenovo_usb_winpe_2.1.zip does not work for my device. Anyone else have drivers for either of the following HW ID's?

 

Hardware ID's:

USB\VID_17EF&PID_7203&REV_0001

USB\VID_17EF&PID_7203

 

 

Douglas Hindle
Helpdesk Support Engineer

7 Campus Blvd.
Newtown S

BBC's picture

What you have to do is change the classes in the original driver from the driver supplier to the below. The file name you may want to download is this "AX88772B_Vista_64bit_Driver_v5.10.2.0_WHQL.zip" which you can grab from many locations by doing a Google search or try to grab the ZIP archive attached, which I have working in my WinPE 2.1. The password for the archive is

12345678

Class entries:

LenLan.Ndi,USB\VID_17EF&PID_7203

AX88772B.Ndi,USB\VID_0B95&PID_772B

Hope this helps,

-BBC

AttachmentSize
Modified_X1_Carbon_ForWinPE_2.1.ZIP 1.42 MB