Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Lenovo X230 Intel Boot Agent 1.5.xx hangs during PXE

Created: 08 Oct 2013 • Updated: 21 Oct 2013 | 9 comments
This issue has been solved. See solution.
Altiris Deployment 6.9 SP5 MR3
 
PXE imaging works flawless with our existing Lenovo X230 notebooks running Intel Boot Agent GE v1.3.xx.  Our latest batch of Lenovo X230 notebooks shippied with Intel Boot Agent GE v1.5.36.  All of the new X230 notebooks hang during PXE, just prior to the selection menu.  The last lines displayed on client's screen are:
 
Altiris, inc. X86PC PreBoot, PXE-2.x Enhanced
Build ID=402
 
I've enabled PXE logging within the Altiris PXE Configuration Utility.  The following snip from PxeLog_DSTraffic.Txt seems relevant, containing one of the problematic X230's MAC.  It indicates a reply packet with menu options is created... but the menu does not appear on the client end.  Subsequent lines in the log show working clients communicting with PXE as expected.
 
(2528)***>>---------------------------------
I [10:53:01.761 10/08] (2528): Enter: BStrapOpts: Options(...)
(2528)BStrapOpts: Recheck fmtUU: [38] {5A676C81-52A5-11CB-B488-970FE5D91DFD}
(2528)BStrapOpts:   Recheck MAC: [12] 3C970EC34E5E
(2528)BStrapOpts:   Recheck cID: [08] 
I [10:53:01.761 10/08] (2528): Enter: ClientLookUp( ... )
(2528)GetPXEClientRecord: success  (id=2A1D5C8)(key=3C970EC34E5E)(type=1)(dsmask=0x07)
(2528)GetPXEClientRecord: success  (id=2A1D5C8)(key={5A676C81-52A5-11CB-B488-970FE5D91DFD})(type=2)(dsmask=0x07)
(2528)GetPXEClientRecord: Lookup: failed. (key=*)(mask=0x10)
(2528)GetPXEClientRecord: Lookup: failed. (key=*)(mask=0x10)
(2528)ClientLookUp: Mask Info: (scanmask=0x03)(matchmask=0x03)(dsmask=0x07)(nodsmask=0x00)(datamask=0x07)
(2528)ClientLookUp:   Results: Using Record ID: [2A1D5C8]   code map: [M12U12SAPCm12u12pdhw12x2f12c2c+v1]
I [10:53:01.761 10/08] (2528): BStrapOpts: ArchType: 0, ArchPath: X86PC
I [10:53:01.761 10/08] (2528): BStrapOpts: NicType: 1, NicPath: UNDI
I [10:53:01.761 10/08] (2528): Enter: HasExceededReboot( 2A1D5C8 )
I [10:53:01.761 10/08] (2528): Enter: MenuFixup( 2A1D5C8 )
I [10:53:01.761 10/08] (2528): Automation Only check - ok to service this client: true
I [10:53:01.761 10/08] (2528): Client: 3C970EC34E5E Default PXE boot to (0,Next Device (BIOS/EFI))
I [10:53:01.761 10/08] (2528): Original MenuOption: 1
I [10:53:01.761 10/08] (2528): Redirected MenuOption: 1
(2528)BStrapOpts: Timeout: 1, SendReply: yes 
(2528)BStrapOpts: Add PXE Menu option type to reply packet.
(2528)BStrapOpts: Add Menu Prompt to reply packet.
(2528)BStrapOpts: Added 6 menu items to reply packet.
(2528)    ParseMenu() -> item: 000  type: 000  name: Next Device (BIOS/EFI)
(2528)    ParseMenu() -> item: 001  type: 131  name: WinPE
(2528)    ParseMenu() -> item: 002  type: 130  name: Linux
(2528)    ParseMenu() -> item: 003  type: 161  name: WinPE UltraVNC x86
(2528)    ParseMenu() -> item: 004  type: 129  name: FreeDOS
(2528)    ParseMenu() -> item: 005  type: 160  name: MemTest86+
 
Any ideas?  We're going to open a support request with Lenovo as well.
Operating Systems:

Comments 9 CommentsJump to latest comment

BBC's picture

Is it possible that these X230s' come with Windows 8 pre-installed? If so, I have seen similar issues and the only solution is to wipe the dribve (in our case using a WinPE booting off a USB device) and using diskpart to clean the drive. Otherwise the drive information will not be wiped and so it remains inaccessible for us to image.

I hope this is of help?

-BBC

jscott.fcsd's picture

Thanks for your reply.

The problematic X230s shipped with Windows 7 pre-installed as did our older Levenos.  As part of our initial deployment, new clients PXE boot, they never boot from the local drive until after we've deployed our image.

To eliminate the local drive as an issue, I removed it and tested again -- the client hangs at the same point during PXE.

BBC's picture

OK, 2 more ideas on this...

Have you checked the BIOS on the X230 especially the UEFI section that it is set to legacy only mode and also (probably a stupid one) restart the PXE services?

-BBC

jscott.fcsd's picture

I have tested with the UEFI/Legacy set to "Legacy Only", the results were exactly the same.

I have restarted the PXE services, it did not resolve the problem. Other non-1.5.x clients are able to PXE boot successfully.

To be clear, the PXE boot process initializes on the X230s with Boot Agent 1.5.x, but then hangs just before displaying the Alritis boot selections.  I took an affected device to a network using SCCM/PXE and it PXE boots without issue.  This definitely seems a conflict with Altiris PXE and Intel Boot Agent 1.5.x

jscott.fcsd's picture

Lenovo support had us downgrade the X230 to BIOS version 2.54, which contains Intel Boot Agent GE 1.3.81 -- this resolved the PXE freezing issue.  They indicated a newer BIOS version (greater than 2.56) would be released to address the PXE issue in the near future.

Support indicated you can only downgrade one release level at a time, so we had to go 2.56 --> 2.55 --> 2.54.

X230 2.54 BIOS: http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/g2uj12us.exe

X230 2.55 BIOS: http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/g2uj13us.exe

SOLUTION
smfisher63@gmail.com's picture

I have tried all the suggestions posted here. i am having this issues with T430s right out of the box and with T430s that have already been imaged. I have pulled the SSD to verify that was not defective, I have even upgraded the BIOS ver to 2.57 I have wiped the SSD's with the procedure recommended by the drives manufacture. nothing seems to works

Image issue_10-10-13.jpg
jscott.fcsd's picture

Please note that _upgrading_ the BIOS did not work for us.  We had to _downgrade_ the BIOS to a revision which contained a 1.3.x version of the Intel Boot Agent. Downgrades can only be stepped one level at a time, so you would want to test going 2.57 --> 2.56 --> 2.55 --> 2.54 until you find a BIOS with Intel Boot Agent 1.3.x.

donaldsee's picture

How can you downgrade your X230 BIOS? even I downloaded the 2.55 BIOS execute file, it said the BIOS image does not match the system, and reject the action.

donaldsee's picture

We have newest X230 that have Intel Boot Agent 1.5.xx also facing this problem, We contact Lenovo Service support and get the reply that the latest BIOS version 2.56 can't downgrade to existing version due to security issue and confirm Intel Boot Agent 1.5.xx support normal PXE deployment and it's not a bug, and finally asking me to contact the system developer of Altiris system....what the hell...