Video Screencast Help

Licensing count and actual behavior

Created: 08 Feb 2012 | 11 comments

Hi everyone,

I would like to know how the Altiris handling the licensing count, if it is over the license?

I have installed 50 Monitor Pack license. But I have deployed 53 agents. From our local engineer tell me. The Altiris will only maintain the licensed agents, which means only get the agent status for 50 devices.

From the webpart "How is my current computer inventory?" The chart show the below figures.

Basic Hardware (53 up-to-date, 45 not report)

Hardware (50 up-to-date)

Software (50 up-to-date)

User (50 up-to-date)

If keep deploy agent, the "Basic hardware"figures will keep growth. In my computer list, i have total 115 computer.

My question is how do I know all the deployed agents are under monitor and return the latest status to the Notification Server? If my engineer explanation is correct, how do I know which 50 licensed devices will report the status?

Thanks for anyone in advise for providing any feedback for me.

Thanks and regards,

Carmel Lee

Comments 11 CommentsJump to latest comment

mclemson's picture

You should uninstall the Monitor Solution Plug-in until the total installed count is at or below what you own. This is the only reliable method of confirming that the installed base will have a license.

Does this answer your question?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Joseph_Carson's picture

Just a note, Mike is correct.

The Alerts and Metrics will still work, you just will not be able to update or change the configuration or policies until the license count is back in compliance.

Kind Regards,

Carmelcw's picture

Hi,

Thanks for the advise and I do remove some agents to match the license purchased.

I have remove the agents through the "Push Symantec Management Agent" page, then select the server and click the uninstall. The status show remove success.

After 24 hours, I still see the licesne count did not change, also when I view the "Computer" list, the server still show agents icon (i.e. still on installed agent list).

Could anyone tell me how to update the license count to reflect the true counting?

Thanks and regards,

Carmel Lee

mclemson's picture

Have you confirmed on any of the targeted computers that Altiris was actually removed?  Uninstallation may require a reboot.  Were they rebooted?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Carmelcw's picture

Hi,

The targeted computer has success removed. I have checked the icon did not show on the tray and did not have any task / services running.

I have rebooted the Notification Server, but not the target server.

Do you mean I need to reboot all target server that uninstalled agent?

Thanks and regards.

Saeed's picture

Rebooting the notification serve will not help here. If the changes are on the target server you need to reboot the targeted server..

Howevery as per my knowledge reboot is not required after uninstalling the agent.  What i would suggest that just make sure you dont have any automated policy to re-install the altiris agent. Also check the Monitor solution plugin policy.. check the filter is it danamic or static.. In your case i think you will need to clone the policy add the computer one by one till it is 50..

 

Let me know if you need more details on it.

Hope this help..

If a forum post solves your problem, please flag it as a solution. If you like an article, blog post or download vote it up.
 

Joseph_Carson's picture

Hi Carmelcw,

make sure you unistalled the Plug-ins before removing the SMA agent.  And ensure that Inventory was sent after removing the plug-in, this will ensure when the next schedules run on the SMP server that it will reflect the correct license count. 

Someother options is to right click on the server and mark it as retired or delete if  no longer needed.

Br,

Jsmith73's picture

we also had an issue with our licence count not dropping after "removing" assets from NS. After some troubleshooting from Advanced Support guys we found that machines that existed in the OOB AMT table were being re-imported but a task called NS.Resource.Synchronization

We have disabled the task to prevent deleted machines being reimported into NS.

Carmelcw's picture

Hi,

Could you let me know where is the task located?

Regards,

Carmel Lee

Carmelcw's picture

Hi Joseph,

I just uninstall the agent via the console, I have checked the targeted server did not have any agent running and the task manager did not have any process that start with AeX. So I assume the targeted server no more agent installed.

But on the Altiris Console, when view the Computer, the target server still show agent installed. I cannot retried or delete the server, as I still need the server on list. The reason to remove the agent is because the license count reach the purchase limit. So that make some of the server did not report the correct status.

The only way to make the Altiris have the latest server status, I need to remove the over license agent.

Is there any way to clean up or tell the Notification server to update the agent status correctly?

Thanks and regards,

Carmel Lee

mclemson's picture

If you need 100 computers reporting in data, you need 100 licenses - not 50.  So maybe you need to purchase more licenses.

If you need historical data, but not current data, from the systems you're mentioning--the ones where the agent was uninstalled--then you should retire the systems.  Retiring a computer will free up its licenses, while still keeping it on the server with its historical inventory and event data.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com