Video Screencast Help

Limitations on item retrieval whilst EV in backup mode

Created: 19 Sep 2012 • Updated: 19 Sep 2012 | 6 comments
DeadEyedJacks's picture
This issue has been solved. See solution.

Hi All,

Would appreciate some clarification on an issue I've recently encountered with an EV9 installation.

Two storage / index servers within a site / vault store group with SIS Share within the group.

It would appear that whilst any element of the EV system is being backed up there are limitations on normal operations.

Specifically and most annoyingly, users cannot restore items for EV search page. 

What is the scope of the restriction on retrieval tasks running? 

And how can a medium size installation such as this be designed to minimise such restrictions?

Thanks in advance

D

Comments 6 CommentsJump to latest comment

LCT's picture

Hi DEJ,

I have just tried restoring and retrieving using Outlook and IE (Search) and I can restore without any issues WHILST EV is in backup mode. EV9.0.3.

As far as I know EV is designed to funtion as per normal (other than archiving) when EV is in backup mode, restoring and retrieving should not be affected.

You got any errors etc.?

DeadEyedJacks's picture

Hi,

This is restoring items from baskets created on the EV search page rather than retrieval via the Outlook add-ins.

Event log contains repeated event id 2270 warnings

Source:  Enterprise Vault   Category:  Retrieval Task 

A queued operation exceeded the retry count and has been discarded

Exchange Mailbox archiving task for XXX (Retrieval)

Baskets for restore from journal archive nor for mailbox restores didn't progress whilst a backup of a vault store partition were on-going. 

Authorised Symantec Consultant on Archiving and eDiscovery ASC, STS, SCS, SSE+

Microsoft, NetApp and VMware certified professional MCTS, MCSE, MCSA, NCDA, NCIE-BR, VCP, VTSP

LCT's picture

Hi,

I tested your issue with Outlook and Internet Explorer using the Search page on the client side and it is working OK...However, I am testing it on the server side i.e. Search page using Internet Explorer on the EV server and I am getting the same results.

I believe there is a restrictions with the VSA account permissions if you are on the EV server. Try restore on a client machine login as anyone. I think the restrictions was applied in EV8 SP4 onwards. 

LCT's picture

Try looking at the Shopping location on the EV server and give it VSA account full permissions see if it make any differences. I will test it abit later and let you know if that is the case.

DeadEyedJacks's picture

Hi LCT,

Yes, It was a problem for a requested journal restore by VSA account on EV server,

but also for several end user restores initiated from client systems.

Effective permissions for VSA account are Full control for all volumes on both EV servers.

I will check permissions over the archives and mailboxes involved as the journal restore was redirected to a shared mailbox and the end users were restoring from / to shared mailboxes.  Perhaps EV being in backup mode was coincidental?

going back to the other half of my query, whilst the journal store is in backup mode journal task processing ceases. 

What techniques can be used to minimise the backlog which builds up?

More journal mailboxes, journal tasks, storage servers or partitions presumably make no difference, only having multiple journal vault stores?

Is having the Vault Store Group sharing boundary at the site level a factor in the extended lock out and pausing of journalling whilst backups are on-going?

Authorised Symantec Consultant on Archiving and eDiscovery ASC, STS, SCS, SSE+

Microsoft, NetApp and VMware certified professional MCTS, MCSE, MCSA, NCDA, NCIE-BR, VCP, VTSP

LCT's picture

Hi DEJ,

I think EV in Backup Mode was a conincident as I tried to perform a restore using the VSA on the EV server via Internet Explorer Search and I get the same issue regardless of EV in backup mode or not. However, doing the same thing on the client machine works fine. Like you said check the archives and mailbox permissions. As I mentioned there was a restrictions on the VSA when you logged on to the EV server from EV8 SP4 onwards so I don't think this issue is related to EV being in backup mode. May need to dtrace the process and see what is happening between different users.

Your other half of the query: unfortunately with journal archiving there isn't much you can do to minimise the backlog (or the journal mailbox building up if you like) when EV is in backup mode.

SOLUTION