Video Screencast Help

List all files in an NDMP backup

Created: 10 Jan 2013 • Updated: 12 Jan 2013 | 10 comments
This issue has been solved. See solution.

Hi Folks,

I want to be able to list all the files contained within an NDMP backup. I have been attempting to use the bplist command. However I am receiving the below error everytime. I can see that successful backups have been preformed for this NDMP client and I can see all the files in the BAR utility. Any ideas on why I cannot see the files or directory being backed up?

EXIT STATUS 227: no entity was found

Thanks for any help in advance!

Comments 10 CommentsJump to latest comment

Will Restore's picture

specify type 19 for NDMP backups (default is 0 for standard type)

 

bplist -t 19

 

 

Will Restore -- where there is a Will there is a way

Nagalla's picture

coudl you let us know what is the command/options that you are using in bplist?

Andy Welburn's picture

Just as confirmation of Wills post:

 

DOCUMENTATION: A listing of policy types and how they are used with bplist and other VERITAS NetBackup (tm) commands.
http://www.symantec.com/business/support/index?pag...

 

If you still get the 227 when specifying the policy type, then we really need to see the options you're using as stated by Nagalla.

manmountain's picture

 

This is the client. It is an NDMP backup. There are more backup images just putting up a sample here.
 
$ bpimmedia -client atns120dm2cge0 -U 
--------------------------------------------------------------------------------
Backup-ID:            atns120dm2cge0_1357862891
 Policy:              NDMP_backup_atns120dm2cge0
 Schedule Type:       FULL
 Retention Level      2
 Number of Files:     2659
 Compression:         N
 Encryption:          N
 Image Type:          Regular
 Primary Copy:        1
 Expires:             00:08 04/14/2013
 
  Copy Number:        1
  Fragment Number:    IDX
  Fragment Size (KB): 367
  Media Type:         Disk
  Density:            -
  File Number:        -
  Offset:             -
  Host:               attembak5
  Device Written On:  -
  MPX:                -
  Expires:            -
  Retention Level:    -
  MediaID:            @aaaax
 
Have tried a number of 
 
$ ./bplist -t 19 /PM_Data
bash: ./bplist: No such file or directory
 
$ ./bplist -C atns120dm2cge0 -s 10/10/2012 00:00:00 -e 01/10/2013 17:00:00 -t 19 /
bash: ./bplist: No such file or directory

 

manmountain's picture

 

Should of been... wasn't running command from correct dir
$ ./bplist -C atns120dm2cge0 -s 10/10/2012 00:00:00 -e 01/10/2013 17:00:00 -t 19 /
EXIT STATUS 227: no entity was found
 
$ ./bplist -t 19 /
EXIT STATUS 227: no entity was found

 

bills's picture

For what it's worth, I've noticed several times in the past that both bplist and bpflist require specifying seemingly redundant information, so you might try specifying every option you can, painful as it may be. 

Also don't forget to specify -R, and "/" as the filename, otherwise the results, while they eventually make sense once you figure it out, is not what you necessarily first expect (again, in my experience).

If you could post the command you're using, it would be helpful.

Bill

SOLUTION
Nagalla's picture

hi ,

use the below command, and let us know how it goes.

bplist -t 19 -C atns120dm2cge0 -l -b -R /

manmountain's picture

Ok it's working now... not sure why. This command worked. Initially I selected the -A option for showing archive. It didn't work. I took out the -A option and ran the exact same command and it worked. So this is the command I used.

$ ./bplist -C atns120dm2cge0 -s 10/10/2012 00:00:00 -e 01/10/2013 17:00:00 -t 19 -R /PM_Data

Thanks for all the replies!!

bills's picture

-A will only match archive jobs, not backup jobs (-B, which is the default).  Glad it's working!

Bill

CRZ's picture

As bills said earlier in the thread, you were missing the -R switch, which meant you were only looking at the single "root" node and not traversing the file system.  Since I think you were backing up /PM_Data and not /, nothing would be found if you were ONLY looking for "/" without the recursion, thus, status 227.

I'd suggest marking the solution on bills' reply.


bit.ly/76LBN | APPLBN | 75LBN