Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

LiveUpdate downloading issues

Created: 12 Dec 2007 • Updated: 21 May 2010 | 3 comments
My virus definitions and other content are not updating on my SEPM server.  I can't get LiveUpdate to download successfully.  I keep getting a "Liveupdate encourntered one or more errors.  Return code = 4."  When I look at my firewall logs, nothing shows up that would appear that it is getting blocked.  I temporarily opened things wide for a quick test and still no luck. 
 
Does anyone know what 'Return code = 4" is?  I haven't been able to find anything on this.
 
I also tried doing the uninstall/reinstall of LiveUpdate that was recommended in a posting by another user, but I can't seem to do that either.  When I go to Add/Remove Programs and try to remove it, I get a error saying "LuComServer is currently running.  Please wait until it completes and run Setup again."  Is there a service that I need to stop in order to uninstall LiveUpdate?

Comments 3 CommentsJump to latest comment

knightstorm's picture

return code 4 seems to indicate an proxy server authentication error.  Check your settings in control panel liveupdate and/or in SEPM proxy server settings

Jason Grusnick's picture
I was never able to figure out the error, but I was able to uninstall and reinstall LiveUpdate, but I had to go into Safe Mode in order to do it.  Since the reinstallation, I have been receiving updates just fine.
Jan van Setten's picture
We had the same problem ................ it indicates corrupted virus defs (in my case the 32bit defs)
 
I have solved this problem by removing all files from subdirectory "sesmvirdef32" and re-run liveupdate
 
Regards
Jan