Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Liveupdate.log Error: Could not connect to client

Created: 01 Aug 2014 | 5 comments

Hello, Iam in need of some assistance. When I install Symantec Endpoint Protection 12.1.4 it will install correctly however it does not update the security definitions. When I click LiveUpdate Now it will launch a "Check for Updates" window, however the "Update Now" button is greyed out. I went and inspected the liveupdate.log and found that this is what is generating in them:

Thu Jul 31 15:49:20 2014: Daemon Launched

Thu Jul 31 15:49:20 2014: Daemon version: LiveUpdate 6.2.2f1, © 2014 Symantec Corporation, All Rights Reserved.
Thu Jul 31 15:49:20 2014: LiveUpdate Error: Could not connect to client.
Thu Jul 31 15:49:50 2014: LUCLIENT:handleTimeOut

Thu Jul 31 15:52:20 2014: Daemon Idle: Quitting

Thu Jul 31 15:52:20 2014: did fire IDLE
Thu Jul 31 15:52:20 2014: Cleaning up
Thu Jul 31 15:52:20 2014: DAEMON Exiting

Thu Jul 31 15:52:20 2014: Daemon Quitting

 

Now the majority of the Macs in our environment are able to install the definitions perfectly fine, however I did notice a difference in the liveupdate.log between the two during the intial install. When it comes to the Macs that are not working they generate what I posted above in the logs, on the other hand, for the Macs that are working fine, the first thing that they  generate in the liveupdate.log during the initial install is this:

Daemon Launched

Daemon version: LiveUpdate 6.2.2f1, © 2014 Symantec Corporation, All Rights Reserved.

*** Adding Command

**** Command Key/Value (RegistryPath//Library/Application Support/Symantec/LiveUpdate/ActiveRegistry)

**** Command Key/Value (VolumeRoot//)

**** Command Key/Value (PlugInPath//Library/Application Support/Symantec/LiveUpdate/PlugIns)

 

After that shows in the log it begins to connect and starts to download and install the definitions fine. Why is it that the Macs that cannot do LiveUpdates do not show this in the log? Is there an issue during the install? I have already uninstalled and reinstalled but still the same issue occurs. Any ideas anyone?

Operating Systems:

Comments 5 CommentsJump to latest comment

James007's picture

Symantec is investigating and will updated this article as new information becomes available.

Workarounds/Solutions:

  • Fix name resolution for liveupdate.symantec.com.
     
  • Rely on a scheduled LiveUpdate -- it doesn't check liveupdate.symantec.com unless it's in the server list and if it doesn't resolve then LU tries the next one in the list.
     
  • Use the command line LUTool for manual LiveUpdate sessions -- see How to run Macintosh LiveUpdate 6.x from the Command Line

 

Symantec Endpoint Protection for Macintosh: LiveUpdate fails when run manually through client interface

Article:TECH212506  | Created: 2013-11-14  | Updated: 2013-12-17  | Article URL http://www.symantec.com/docs/TECH212506
.Brian's picture

Have you tried again recently?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

cpreasbeck's picture

Yes I have and the issue is still occuring. Any ideas?

Rafeeq's picture

where did you download this installer from?

whats the MAC version here?

cpreasbeck's picture

Mac version is 10.9.4 and got installer directly from Symantec