Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Load error: no DPMI memory

Created: 17 Oct 2007 • Updated: 02 Mar 2009 | 11 comments

I've just created TCP/IP Network Ghost Client boot image - Ver 11.0.1.1533

Set up 3Com PXE boot.

Boots into the PXE image ok and then fails with below error.

Load error: no DPMI memory

Any Solutions?

Thanks

Vik

Discussion Filed Under:

Comments 11 CommentsJump to latest comment

James DJ Lee's picture
Hi Vik,
 
which dos version are you using? pc dos or ms dos?
I believe if you are using ms dos with latest himem.sys, it should not have this error.
also, if you can run mem program, it will show how much memory your machine can utilize.
even though you have a large physical memory, memory manager(himem.sys) might not handle correctly.
other thing you can try is get a hold of freedos himem.exe and replace it with current himem.sys
thanks.
 
regards,
James Lee
atozet 2's picture

Hi James,

 

I have the same kind of problem using pxe server and gdisk. I  run mem.exe and out of 640 kb I have 442 free. that's that best settings I can do on the config.sys. I think config.sys controls the base memory of DOS.  Is there any thing else I can manipulate to allow more memory for gdisk?

 

Thanks for your help.

 

Alfonso

Christian B's picture

i had the exact same error. i followed this guide and this solved my issue. (even thought it's related to an older ghost version)

 

http://service1.symantec.com/SUPPORT/on-technology.nsf/docid/2004031011432125

 

 

Romeyn's picture

That article liiks like it would work, but who the heck has floppy drives anymore?!? 

I'm going with the WinPE-based image instead and hope it works.

atozet 2's picture

Christian,

 

Thanks for your response, I am using Intel's PXE boot program pxe20-pdk. I tried to follow the instruction on creating the image using 3com's image editor, however Intel's program cannot read it. I don't know if Intel has a program to minimize its image.

 

Thanks,

 

Alfonso

K.C. Kennedy's picture

Updating the BIOS on the machine resolved this issue for me (HP EliteBook 6930p laptop/applied F.0E 12/15/08/using Ghost 8.0).

Eugene Manko's picture

This (or similar) issue has been identified and fixed recently in GSS 2.5 (Live update 2 - build 2141) but only for something that we have control over - RIS PXE boot. It came down to BIOS not fully supporting necessary memory APIs (interrupts) required by older himem.sys and DOS programs. Fix included supporting all possible memory APIs in our RIS PXE boot loader.

 

I can suggest few things that can be done for 3COM PXE boot:

 

1. Upgrade to GSS 2.5 (ghost 11.5) and use Winpe boot option via 3COM PXE.

2. Use newer MSDOS himem.sys.

 

Hope this helps.

szubriski@healthadvocate.com's picture

I have had this same issues multiple times most of the time it is because the computer has 4gb of memory or more for a quick fix i will just removed the memory down to 2gb and then run the ghost and just put the memory back in after the image is done. Doesn't make much sense as to go threw all these other steps ppl have suggested when you can just take out the memory then it will work fine.

Jonathan L's picture

Yes, removing one of the 2 gigs fixed this for me too. Just take it out before you do the image, and replace it after the image.

Adam Heaton's picture

I am trying to image a new Toshiba Satellite Pro L300. We got them with 1GB already in them, then we ordered an extra 1GB. I put the extra memory in, and had the issue everyone is talking about. No DPMI Memory. I took the 1GB i put in, and still no look. Any advice that i can do rather then looking through tutorials. Busy man :)

Regards

Adam Heaton

Regards

Adam Heaton

mah88d's picture

Load Error: No DPMI Memory". When using Symantec Ghost 11
i have  hp compaq dx2000  i use anothe pc just like dell optiplex 330 it's okay just this model