Video Screencast Help

Location awarness: does the hear beat impact on discovering interval?

Created: 04 Dec 2012 • Updated: 04 Dec 2012 | 9 comments
diabolicus23's picture
This issue has been solved. See solution.

I've set up a group (with the communication setting as pull mode with a heart beat of 1 hour) with two locations:

  • Location 1: the client could ping a certain IP address
  • Location 2 (the default one): no conditions

I've left the default setting "The location will be checked every: 4 seconds".

Well, if I connect the pc with the target IP, apparently nothing happens. If I select "Update policy" on my test client, it correctly moves in the Location 1.
Same way, if I disconnect the pc with the target IP, nothing happens until I select "Update policy", then the test client correcly moves in the Location 2.

The question is: does the client check the location conditions only at his heart beat interval, regardless of the location check interval settings?

 

If so, is there a way in order to mantain the pull mode but to let the client check "often" the location conditions?

 

Thanks!

 

PS Sorry, probably I've double sent this post, also in EE section :-(

Comments 9 CommentsJump to latest comment

Ashish-Sharma's picture

HI,

Yes it's depend heart beat checking

More about Location Awareness in Symantec Endpoint Protection (SEP)

http://www.symantec.com/business/support/index?page=content&id=TECH97369

Best Practices for Symantec Endpoint Protection Location Awareness

http://www.symantec.com/business/support/index?page=content&id=TECH98211

Check this thread also

https://www-secure.symantec.com/connect/forums/location-awareness-not-working

Thanks In Advance

Ashish Sharma

 

 

diabolicus23's picture

I really, really, really hope you're wrong...

Nothing personal smiley but if that's true, how can I implement an effective mechanism of turning off WiFi connection when LAN connected in a large environment (where pull mode is the setting used)?

I could not permit that the client remains with both connections active for, let me say, 4 hours...

.Brian's picture

These are two separate settings.

The client only checks in on heartbeat and receives updated policy, uploads logs etc..

In this case, the client will check its location every 4 seconds and will change to the new location if it determines that a condition has changed, it shouldn't be dependant on heartbeat.

What version are you running?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

diabolicus23's picture

I'm on 12.1 RU2

But even if I've set 4 seconds for the location check, the client does not switch after that interval (and neither after 10 seconds, 1 minute or 5 minutes and so on).

Apparently, only the "Update Policy" seems to perform that check.

.Brian's picture

Have you waited for the heartbeat check in to verify of it switches or not? Enable the location change notification as well...

I've never seen it work like this. The heartbeat should have no affect on it and would be surprised if that were the case..

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

SOLUTION
diabolicus23's picture

Good call.

I've set push mode and the switch was made in the interval window.

Then I've re-set pull mode and the switch, now, follow that window and not the heartbeat.
Don't know the reason of that strange behaviour...

So the correct answer is yours smiley The location interval check time is not affected by the heart beat setting.

 

Thanks!

greg12's picture

It should be possible to adjust the ping interval  with the setting ICMP request loop, which you can find under Client > [Group] > Policies > Manage Locations. That's arguably independent from the heartbeat.

Ian_C.'s picture

We've had the same problem using different criteria for the location.

We used to check for connectivity to the SEPM. That connectivity check only happened during the heartbeat & thus our location would only change once the heartbeat had occurred.

Strange that changing to Push mode first and then back to Pull mode has resolved this issue for you.

 

Could I ask a favour of you? I know that it seems to be working now, but could you do another change to your location & the detection rules. Does this new update take affect immediately (as it currently is for you)? Or are you back to your original problem where it only changes during the heartbeat? I believe that would be an interesting and worthwhile exercise.

Please mark the post that best solves your problem as the answer to this thread.
diabolicus23's picture

Ian_C, if I change the location and/or the rules detection, the changes will take effect accordingly to the heartbeat because that is a sort of "policy change" so this is managed by the heartbeat itself.