Video Screencast Help

Login Banner Configuration

Created: 13 Mar 2014 • Updated: 27 Mar 2014 | 20 comments
This issue has been solved. See solution.
Hi All,
 
I am not able set the "Login Banner Configuration" for master server.
Not giving any error, just return with blank window once I click on apply in Host Properties of master.
 
Master server : windows 2008
NBU Version : 7.5.0.6
 
Please assist if anyone of you face such issue before.
Operating Systems:

Comments 20 CommentsJump to latest comment

Amol Nair's picture

Just run the windows admin console "As an administrator" and then setup your login baner in Netbackuo Host properties and click "Apply" and "Ok".

You should see the baner next time you open the Netbackup Console.

Vickie's picture
I did the same but that's not working even.
 
Once I apply the setting the content from banner text box got cleaned. Not sure why :-(

 

Stumpr2's picture

Maybe you are using a non supported font

VERITAS ain't it the truth?

William Jansen van Nieuwenhuizen's picture

Best is to just copy and paste from notepad.

 

Also ensure that before you open the Admin console, that you right click and select "As an administrator" like Amol Nair said.

 

Can you perhaps send us a screenshot of what you're trying to do? Maybe you're hitting some chacter limitation, have you tried setting a test message?

Vickie's picture
Hi William,
 
I typed the content by myself.....for testing purpose. But it does not work.
 
I opened the NBU console with Run As Admin, but no luck.
 
Screen shot attached.
AttachmentSize
I mentioned below and click on apply.docx 60.14 KB
Mark_Solutions's picture

I get exactly the same on 7.5.0.5 - there should be a LoginBanner.conf in netbackup\var\ but i cannot find out what values should be set in there!

Sounds like a bug to me - worth raising a call if you need this feature

I will keep digging  - sure there is a workaround!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark_Solutions's picture

Just tested this on a 7.6 install and it works..

The LoginBanner.conf file gets created and populated like this:

LOGIN.BANNER.ISCHKBOXREQ=1
LOGIN.BANNER.HEADING=your heading
LOGIN.BANNER.TEXT=your text

But even when i make this file on my 7.5 it doesn't work - i will take a look to see if there is a registry change to enable it too

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Amol Nair's picture

I was just about to put this method to create the file, but Mark beat me.

Since he mentioned that it did not work on 7.5.0.5, I thought of testing it on a few versions.

 

I have tested this on both 7.6.0.1, 7.5.0.7 as well as 7.5.0.5 and it works pretty fine. Tested on both windows as well as unix machines.

 

Here are the contents of the LoginBanner.conf file for your referrence.

=============================================================================
C:\Users\Administrator>more "\Program Files\Veritas\NetBackup\var\LoginBanner.conf"
LOGIN_BANNER.ISCHKBOXREQ=0
LOGIN_BANNER.HEADING=This is the Banner Heading...
LOGIN_BANNER.TEXT=
this is the baner contents...
=============================================================================

 

If you are running the Netbackup Console from any other server other than the master server, then just ensure that you create the file on the master server and not on the machine that you are running the console from.

 

Location:

Windows: - "<install_path>\NetBackup\var\LoginBanner.conf"

Unix: - "/usr/openv/var/LoginBanner.conf"

I have also attached the LoginBanner.conf file from my machine if you would like to try.

 

Hope this helps.

AttachmentSize
LoginBanner.conf_.txt 132 bytes
Vickie's picture

Yeah, thanks Mark/Amol,

I tried this earlier, but it doesn't work. The contents of conf file was given as below, but as you know no luck.
The first line value 1 I set because I need confirmation check box to appear as well.

LOGIN_BANNER.ISCHKBOXREQ=1      
LOGIN_BANNER.HEADING=WARNING
LOGIN_BANNER.TEXT= WARNING

I checked registry deeply, and not able to find any key for Login banner.

As you said, it Seems to be a Bug. 

But it is working on Windows2003 server not on Windows2008. So most likely the issue is with window2k8 platform

Mark_Solutions's picture

Apologies - should have been underscores (LOGIN_BANNER)

Still doesn't work though!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark_Solutions's picture

Mine is on Windows 7 Pro 64 bit for your info (my laptop used for demo's)

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Amol Nair's picture

Mark i guess u just mentioned that ur machine is windows 7 pro..

As i stated earlier.. Are u creating the file on the windows 7 machine or the master serve.?

Could you guys also try downloading the file I attached and moving it on your master server.

Just wana know if it helps coz I tried moving it on multiple machines and it worked everywhere...

The file was tested and created on windows 2008 machines and in red hat..

Another thing I can suggest is try installing Java Console on the windows machine and then try setting up the Banner.... Lets see if that helps.

Please ensure that you run the Java console setup with "Run as admin"

Amol Nair's picture

Vickie and Mark could you guys please give me the exact nbu version on the master server and also details about which version of windows 2008 you are using...

Let me see if I can find a machine with identical config and test the issue..

Mark_Solutions's picture

My machine is a Win 7 Pro SP1 64 bit laptop - it is a Master / Media Server with advanced disk, VTL and MSDP - I know what you are thinking but it is for my reference, testing and demonstrations only and comes in pretty handy!!!

No UAC or firewalls or anything on it either.

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Vickie's picture

Amol,

That's the same content I tried ealrier for the Banner in Windows2k8 server under install_dir\netbackup\var. But that doestn't work.
NetBackup is 7.5.0.6.
Configuration of server is given below.

OS Name:                   Microsoft Windows Server 2008 R2 Enterprise
OS Version:                6.1.7601 Service Pack 1 Build 7601
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Member Server
OS Build Type:             Multiprocessor Free
System Manufacturer:       HP
System Type:               x64-based PC
Processor(s):              2 Processor(s) Installed.
Windows Directory:         C:\windows
System Directory:          C:\windows\system32
Network Card(s):           5 NIC(s) Installed.

Amol Nair's picture

Didn't really know master on windows 7 is stable for testing.. Great to know that..

I will try the same with a windows 7 box n let you"l know..

Did you guys try installing Java console and then setting up the login banner..??

Mark the java logs shows that the LoginBanner.conf file is created.. Its a good way to verify if its working..Haven't checked the windows console logs so not sure about it...

Vickie let me see the exact version of windows i tested on..
And I would like you to actually download the file I had attached and move it on your master not just the contents.. Also let me know if java console works for u or no..

SOLUTION
Vickie's picture

Amol,

I downloaded the file, and put it there. Rename it and remove _.txt from the name. But still no luck.

I will go to install the JAVA console and will try it there.

But this is working with netbackup nbconsole on windows2003 and other server, not sure what is wrong with win2k8 server.

Vickie's picture

Amol,

Thats great, It worked with Java console. But again, the concern still there as why its not working with NBCONSOLE. Even though, on some server it worked.
If you have any idea about, why this worked with Java console ? Please share.