Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Lost BEX 2010 database

Created: 08 Nov 2010 • Updated: 04 Jan 2013 | 10 comments
This issue has been solved. See solution.

Hi,

I recently reinstalled my BEX 2010 server.
Old was a Win 2008 x86 and the new one is a Win 2008 X64, same hardware and same BEX software.

I followed this article: TECH67768 and when that did not work i tried TECH129826 but that gave me no improvement.

 

The short story:

I copied Catalogs and data folder, reinstalled the server, installed BEX 2010, copied the files to the installation folder.

Then all tapes and backuppolicies are gone.

Tried to recover the databease from the copied files using beutility.exe, that faild because the copied folder don't contains any database?

 

Any Ideas on how to recover the database or any TECH artichle that i can use?

Thank you!

 

/Magnus G

Comments 10 CommentsJump to latest comment

RahulG's picture

When you take a backup of you data folder the backup exec services should be stop... In the new data folder do you the see the database file for your backup exec database i.e .mdf and .ldf.....

Incase if you have .bak in the datafolder you can also get the database back from that .bak file . You need to perform the following steps. Using BEutility go to recover database and then select the option to reload the database from backup . Make sure you have the .bak in the data folder which is active and is been used by backup exec.

MagnusG's picture

Thank you for the quick reply.

I think i missed some things in the description.

After the copy of my files I messed things up a bit by accidently removing a partition where I stored the files.

Then i Restored it from the newest backup tape.

Probably thats why i dont got the mdf file...?

I tried to do a restore from the bak file but it did not work... i'll try it again.

 

/Magnus G

MagnusG's picture

Hi,

I tried to do the database recovery again but i get this result:

Performing database recovery for BEDB database.
Starting Services
Starting services for server:PIPPI.
Server:PIPPI, Service:BackupExecDeviceMediaService started successfully.
Server:PIPPI, Service:BackupExecRPCService failed to start.
Server:PIPPI, Service:BackupExecJobEngine failed to start.
Error: (1068) - The dependency service or group failed to start.

Server:PIPPI, Service:BackupExecAgentBrowser failed to start.
Error: (1068) - The dependency service or group failed to start.

Starting services for server PIPPI completed.
Database recovery for server PIPPI ended with errors.

Any ideas what to do or what im doing wrong?

/Magnus G

AmolB's picture

Try copy database  http://www.symantec.com/docs/TECH49757

MagnusG's picture

AmolZeroCool

I installed the new bex on the same harware as the old one and i have lost the db file because of a software created a new partition on the disk containing my files.

 

All I got is the files from the backup tapes, (Symantec folder, and SQL folder)

Thank You

/Magnus G

RahulG's picture

Is the backup exec version same as before or you have a different backup exec version ?

refer the following document

http://www.symantec.com/business/support/index?page=content&id=TECH67296

http://www.symantec.com/business/support/index?page=content&id=TECH50537 you can refer this document to get the database back and just ignore the steps to update the server name if your server name is the same.

You can only get the backup exec database back if you have the backup of the mdf and ldf files ....

CraigV's picture

BE has AFE...Active File Exclusion. You would have got a backup of your SQL DB IF you stopped your SQL services before doing the backup, or you had the SQL agent installed.

If BEUtility isn't importing your bedb.bak file, chances are it is corrupt. In this case, you're looking at recreating your jobs and media sets etc. But will get your catalog information as this would have been backed up, as you have already stated.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

MagnusG's picture

CraigV

"But will get your catalog information as this would have been backed up, as you have already stated."

What information is stored in the catalog?

I lost jobs, tapes, all history...  if i choose restore i can se the old backup jobs and create a restore job but i don't know if it works.

 

Thank you for the reply.

/Magnus G

CraigV's picture

Your catalog information on your tapes.

There is only 1 way to check if your restore works, and that is to restore a single file to a B2D...if it works, chances are good the rest works.

But if you don't have a working backup of your SQL DB, your data is gone...you can get hold of some expensive software that MIGHT recover your files, but that is no guarantee!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

MagnusG's picture

Hi,

 

Thank you for all help.

I finally found a tape with the database on and the backup is now up and running.

 

Thank you all!!!

 

 

/Magnus G

SOLUTION