Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Lotus Notes 8.5.1 vs SEP 12.1 RU1 MP1 nlnhook.exe

Created: 22 Aug 2012 | 20 comments

Dear all,

 

i want to inform all outside, we´ve yesterday solved/get a workaround to the known issue/problem with nlnhook.exe in combination SEP 12.1 RU1 MP1 und Lotus Notes 8.x

(only for Windows 7 Client, could also work on Windwos XP)

 

removing the notes.ini file from  c:\programdata\lotus\notes\data folder and restarting the machine. (can done via gpo)

You will no longer get the app crash error.

 

it´s working fine for us, and Lotus Notes works without issues

 

hope also working for anyone other outside

 

nice day

 

br

 

 

Comments 20 CommentsJump to latest comment

pete_4u2002's picture

yep thats the workaround. in the coming release it should be taken care.

Mithun Sanghavi's picture

Hello,

Thank you for informing everybody on this workaorund.

Yes, this issue would be resolved in the upcoming Release of SEP 12.1 RU2.

Check this Article: http://www.symantec.com/docs/TECH179128

and

check these Threads:

https://www-secure.symantec.com/connect/forums/sep-121-ru1-causing-lotus-notes-crash

https://www-secure.symantec.com/connect/forums/lotus-notes-851-vs-sep-121-nlnhooknotesininsfhooksnvlnvpextmgraddinsnlnvpdll

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SameerU's picture

Please do the following:

Added the Drive which has the application related data to the "centralized exception" in the client side.

1) Open Symantec endpoint Protection Client on the server

2)Go to Change settings -> Centralized exception "option"

3)Click on Add -> Security Risk Scan -> Folder

4) Browse the specific folder and add that one

 

Regards

 

ajhay.siingh's picture

 

Hi All,

Very simple and easiest way to solve this issue permanently till fixed by Symantec, because this is product issue and I posted earlier for which Mithun given reference also in his post above.

After migration to 11.0.7000 or  SEP 12.1  if error in user profile while booting error shows NLM_hook.exe type and lotus not is not running, solution is to delete only .dll extension from NSF_HOOKS=NLNVP.DLL , which resides in user profile /local setting/ application data/ lotus /notes/data inside nots.ini file . to find is just type .dll and it will prompt to NSF_HOOKS=NLNVP.DLL location. Just delete .dll and then try to log in lotus notes

I am sure lutus note will be running and able to logging in succesfully. Please do not reinstall Louts notes to solve this problem. Although if you dont find NSF_HOOKS=NLNVP.DLL inside notes.ini file then little bit more configuration tast just to deleta Data folder from usr profile /local setting/ application data/ lotus /notes/data.  Please do not forget to save names.nsf file which has stored mail address to restore later after deleting the Data folder.

 

Regards,

Ajay Kumar Singh

ajay.singh@jalindia.co.in

 

Regards,

Ajay Kumar Singh (Consultant- Information Security)

 

 

yck23's picture

Hi Kumar,

your Solution works only if no roaming profiles (Lotus Notes) are used, if roaming profiles used the notes.ini (in Userprofile) will be overwirtten each time the system would be restartet

 

br

Harri

djjos70's picture

the problem with this is because the NLNVP.DLL in not registering when notes starts up if you replace the dll in the SEP folder and in the Lotus notes folder with an earlier version eg from 11.0.6100 it will work.

you do NOT have to remove NSF_HOOKS=NLNVP.DLL from notes.ini 

The new RU2 version will fix this when it is released the registering for this file has been broken for awhile now

Kunagon.M's picture

I also have this problem on my clients. This problem has been found  since RU7 MP2 and Symantec Support team told me to wait for a new upgrade, RU7 MP3. Now, using RU7 MP3, problem remains.

I tried many solutions that Support team told me but it did not work at all. The only way to workaround on this case is to delete Lotus Notes account folder on the machine and re-sync with the Domino server again, everything looks well.

But I have more than 2,000+ users which located on different branches. I did open the case to Symantec Support but they gave me the same solutions that I tried on RU7 MP2. So, if you have any idea better than fix it one by one i would appreciate.

 

Regards

The Communication Solution Company Limited

 

 

SebastianZ's picture

The issue is still currently being investigated - fix to come in future release. If you need further investigation at this point please do contact the symantec support team.

Ambesh_444's picture

 

Hi,

Agreed with mithun above comments,

I hope this issue will be resolved in the upcoming release of Symantec endpoint protection 12.1 RU2.

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

SameerU's picture

Hi

Please upgrade to SEP 12.1 RU2

Regards

 

SameerU's picture

Hi Mithun

We have upgraded to SEP 12.1.2 but still the issue persists.

Regards

 

Kunagon.M's picture

I have a plan to test upgrading to 12.1 RU2 until I saw above comment.

Solution from "ajhay.siingh" is great, every machines work fine, but can we do it via SEPM not manually ?

Any update from this case ?

 

Regards,

 

The Communication Solution Company Limited

 

 

SameerU's picture

Hi Ajay

As per your suggestion we have done but after restarting the system the issue persist

Regards

 

ben_simon's picture

Hi All

I also have the same issue - but with RU2

https://www-secure.symantec.com/connect/forums/issues-sep121-ru2-and-lotus-notes-85#comment-8421521

One solution i did find was to deploy SEP without the Lotus Notes Scanner feature. Yes, i know this decreases the security of the endpoint but does fix the issue I am having.

In saying that, I am pushing support (yes i have logged a case!) to have this fixed as I do not want to remove any capability of SEP.

Just as an interesting point. The line I have an issue with in the notes.ini is ExtMgr_Addins=NLNVP.DLL (rather than the NSF_HOOKS)

Looking forward to see this fixed!

smiller-dri's picture

It looks like this was fixed in 12.1 RU2 (12.1.2015.2015), but re-appeared in 12.1 RU2 MP1 (12.1.2100.2093)

I added a new SEM server just recently, and used the April release info.  I had been running 12.1.2015.2015 prior to this without any problems.  Installed this on ten PCs, and suddenly each one is having the NLNVP.DLL issue.  Why did this problem return in a later release? 

SameerU's picture

Hi

After contacting Support we came to know that the said issue is fixed in SEP 12.1 RU3

Regards

 

smiller-dri's picture

Very interesting.  I received a reply to my posting on May 6th that they had no record of any issue, and asked me to open a case #.  I opened a case number May 9th, and just got done sending them log information yesterday, May 13th.

At the time I was on the phone with them on May 9th (one day before your reply) they said they were totally unaware of any issues.  

As of yesterday, talking with support, they still hadn't notified me that they were aware of a fix for this.  Thanks for letting me know.

Kunagon.M's picture

Any update for version 11 RU7 MP3 instead of upgrade to version 12.1 RU2 ?

The Communication Solution Company Limited