Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Low format of media tape

Created: 06 Sep 2012 | 12 comments

Dear All,

 

i have a VTL Library connected to master server (7.1.0.4) Windows 2008 R2 EE.

Format the media tape was no take a longtime, but now every media tape take around an hour.

 

Comments 12 CommentsJump to latest comment

mph999's picture

What command are you using ?

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
muhanad.daher's picture

Dear Martin,

this command that what is used

bpexpdate.exe -d 0 -force -m ####

Regards,

Muhanad Daher

Senior Data Center Engineer

Mark_Solutions's picture

That is a catalog issue and nothing to do with the VTL as it is never touched during the operation

The command you are running will expire every image that is on that tape and also all images from other tapes that have any fragments on that tape.

If you use a very high multiplexing level on your VTL then, depending on the size of your tape, there could be a large number of images affected by running that command

You need to assess the above to see exactly what your command will do and then check the performance of your master server and its catalog disk to see if you have performance issues somewhere

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mph999's picture

Mark beat me to the answer, or explanation.

OK, if you run this :

bpimagelist -backupid test_1346912684

How long does it take to return saying no entity found

This backupid (I hope) does not exist, so it is a method to see how quickly your catalog can be searched.

Is the time this takes, similar to the time the bpexpdate takes ?

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
muhanad.daher's picture

Sorry to late of answer,

 

Martin, i tried the image list command, and it's work great very quick, but i run the bpexpire take a longtime.

is there any suggestion plz?
 

Regards,

Muhanad Daher

Senior Data Center Engineer

Marianne's picture

Why do you need to expire media?
It is normal for bpexpdate to take a long time since entire image database has to be searched for all images linked to media-id.

Retention level on images is a Business requirement and needs to be honoured in order to perform restores up and until the date of normal expiration.

'Low level format' of a tape can be done with 'quick format' or 'label' on tapes where all images have expired.

You can bulk-select tapes in the GUI, right-click, Label.

PS: This is not a NBU requirement, but some VTLs require tapes to be 're-initialized' in order to release/reclaim the space on disk.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mph999's picture

I think I will agree with Marianne (and Mark).

Even though bpimagelist completes ok, bpexpdate has a lot more work to do, and testing this on my server shows this, bpexpdate tapes a lot longer than bpimagelist.

I'm thining my bpimagelist command was not the best suggestion for a test in this case.

As a matter of interest, how big is the catalog, and about how long does a bpexpdate take.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
muhanad.daher's picture

Dear All,

Really thanx for your answer, i need a limit of number of media tape on VTL, and sometimes need to expire the tapes to have more space to next backup.

it was work normally, but i don't why it take a longtime now.

 

Any new suggestion?

Regards,

Muhanad Daher

Senior Data Center Engineer

Marianne's picture

Did you see Martin's question?

As a matter of interest, how big is the catalog, and about how long does a bpexpdate take.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mph999's picture

"it was work normally, but i don't why it take a longtime now."

What changed ?

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
muhanad.daher's picture

Dear Martin,

 

May you remember about the case that related to upgrade to 7.5 but the system rollback everytime.

the changed, only try to upgrdae to 7.5 that's it.

Anyway i have case open it today morning. case # (420-050-154).

 

Regards,

Muhanad Daher

Senior Data Center Engineer

muhanad.daher's picture

Dears,

 

Finally, Symantec success to upgrade netbackup to 7.5 and the expire of tapes now work normally as past.

May was there a problem in Database and upgrade solve the problem.

 

thanks all for helping, really great team :)

Regards,

Muhanad Daher

Senior Data Center Engineer