Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Low transfer rate/slow backup

Created: 14 Mar 2013 | 22 comments

A colleague of mine asked me to create a post for him.  He is using BE 2010 and his one backup job is running at only 228 mbs/min.  The job is set to medium prioity, he switched it to highest and it didn't help.  He is backing up to tape, which is connected directly to the server.  The server is also acting as it's media server.  Is there anything that can be suggested to speed up this job?  

Operating Systems:

Comments 22 CommentsJump to latest comment

pkh's picture

1)  If he is backing up a lot of small files, then the job will be inherently slow

2) defrag the disk which the data resides.

3) tune the tape drive.  See my article below

Larry Fine's picture

Job "Priority" affects scheduling, not performance.

What type of tape drive?

Did it used to be faster?

If you find this is a solution for the thread, please mark it as such.

OP's picture

Do you have more information regarding the environment ?

What kind of data is backup up?

Local data or remote ?

prs246191's picture

I know that he is backing up local data.  It is an engineering firm so he is backing up alot of data from autocad and similar types of data.  I know that he said that the site is a branch office and that another brach office with an almost identical set up runs much quicker...  I can not answer if it use to be faster, nor can he since he has just taken over the network admin position.  I will find out what type of type he is using and what type of drive.

CraigV's picture

1 other thing to check out is whether or not any AV on the affected server is scanning the BE services...if so, put in exclusions for them.


Alternative ways to access Backup Exec Technical Support:

prs246191's picture

rapes are hp ultrium lto 4 tapes 800gb/1.6 tapes.  And he is using a hp 1/8 g2 autoloader ultrium 4 1760 scsi.  Other than what he told me...I know nothing about tapes 

CraigV's picture

Upgrade the firmware on the library through the drive vendor's diagnostic utility.

Alternative ways to access Backup Exec Technical Support:

Sym-cr@zy's picture


Troubleshooting such issues are more about finding the cause of the performance dip first and then patch that area.

Find out if the issue is with the device where the backups are targeted- (Try the same job on a disk storage and check the speed).

However, if other jobs are running faster to the same tape drive and similar tapes, it might not be a device related issue.

Try running the same job at a different time (ideally Non-Production Hours) to check if any other application is hampering the speed.

To find out if the same backups were running faster earlier, you can look for the previous job logs (if available)in the BE console.

Also, if you are backing up multiple resourses (System State, C:\, D:\) in the concerned job then you can check the job log properly to find out which resource takes longer time to get backed up. Splitting the resources to create seperate backup jobs for a testing purpose will also not be a bad idea.

List of backup or restore Performance TechNotes (troubleshooting slow throughput backups and restores) for Backup Exec Products
                          Appreciate every help you get, to help yourself better
                      Please mark 'SOLUTION' for the post which resolved your issue.
prs246191's picture

Just to let you guys know he ran the job to a hard drive... 400 mbs/min still very low

CraigV's picture

...and there are no failed/failing drives in that server?

Is the firmware on the server up-to-date too?


Alternative ways to access Backup Exec Technical Support:

adamg0418's picture

Hi guys,

Thanks for your responses on this. I am the collegue of prs's that is having the issue. I decided to g ahead and make an account so this would be easier. I am still having the same issues with no resolution as of yet. I am new to Backup Exec so bare with me here...
Here is the setup here now: I am using BE 2012 not 2010 as prs mentioned in the original post. I am attempting to back up the local server so there is nothing backing up across the network or anything. The server is a VM (I dont know if this could make the difference). We do have another office with the identical same setup and the average backup speed there is normal at around 3,500 MB/Minute. We are using a HP 1/8 G2 Ultrium 1760 LTO4 autoloader with LTO4 tapes. Firmware and drivers are all up to date. I tried a backup to disk and the speed did improve a little at around 450MB/Min but still nowhere near what it should be. File copy between volumes is fast and I also did a NT backup with Windows Server Backup that backed up very quickly, so to me this is looking like a BE issue. I have spent a few hours on the phone with support and so far still nothing from them. I am still waiting to hear back from them but they are about an hour and half late. They did do a repair of BE and this did not help. I also defragged thed drives.

Any thoughts on this? I appreciate the help.Thanks!

CraigV's picture

Your media server is a VM? It's an unsupported configuration.

Is the firmware on the SCSI card up-to-date? VMware tools etc?

Alternative ways to access Backup Exec Technical Support:

adamg0418's picture

Yes the media server is a vm. I did read that this is an unsupported configuration but what i can't understand is the fact that we have another office with the exact same equipment and configuration and the backups run fine. I did check that the SCSI card, VMware tools, and all drivers are up to date. Thanks.

Larry Fine's picture

The fact that it works so differently for some people is probably a key reason it is unsupported.  I betcha that somewhere, somehow, there is something that is different between your environments.

If you find this is a solution for the thread, please mark it as such.

CraigV's picture

Same speed disk? Same # of disk in your RAID groups? Enough disk space on the datastore?

Alternative ways to access Backup Exec Technical Support:

merlin66's picture

Hi adamg0418,

at first. please don't compare with Windows Server backup because this is block-Level-backup and BE-Agent-Backup is file-Level-backup.

Take a look at your job-protocoll, as Sym-cr said you can see at what part of backup it si slow.
For cecking the Speed of the Library, you can make a Job where you backup only one Directory with large files -this schould be fast (also Monitor RAM and CPU during this test.

what virus-engine are you using? some products like Sym.endpointProtection have the possibility to mark backup Tasks so no scanning will be done. Otherwise you can set your scanner to scan only writes and executes - so while backup opens a file it is not scanned.
Please also exclude the BE-Programm Directory from AV.

Sym-cr@zy's picture

Hi Adamg,

The difference in the job rate between two setups of yours might be because of the unsupported environment. However, have a look at the below document:

Backup performance in Backup Exec 2012 can be slower than previous versions
                          Appreciate every help you get, to help yourself better
                      Please mark 'SOLUTION' for the post which resolved your issue.
lmosla's picture

Hi Adamg,

Do you have anything running during the backup that might be causing conflicts? Look in your windows event log at the time the slow backup runs for errors.

adamg0418's picture

Yes I do agree that there is probably something different somewhere, but I just cannot figure out what it is. I am getting slightly faster speeds on a backup to disk but not nearly where it should be, around 350Mb/Min. Space is not an issue here. I also just simply tried creating different jobs and only single directorys and I'm getting the same result.

No spikes in RAM and CPU. No antivirus running on this sever at the moment.
@Imosla - I did read this somewhere earlier and unchecked the option to enable checkpioint restart, still same result.

I did spend a couple more hours on the phone with Symantec, they escalated the issue. After troubleshooting with them they had me try and disable some driver registry entries, rebooted the server after work today and did not resolve. Going to be working with them again on this and will see if we can get anywhere.

Btw, They did inform me that this is not an unsupported configuration, just not recommended due to the same type of issues that I am having. I'll post when I have more updates.

Thanks again,

Meindert's picture

I have noticed slow backups with BE20110sp3 combined with (backups of) servers with databases (SQL, Exchange) and/or Active Directory, usually in combination with deduplication. After a long analysis, logging and such, I noticed that the BE server had rather long wait periods, in which it would wait for responses from the client. Some further googling led me to the culprit: Microsoft Forefront Endpoint Protection. You would expect them to know how to get the exclusions right on their own anti virus software, but forget it. The on-access scan engine slows backups to a crawl. 

The following article finally put me on the right path:


Add the following exclusions to your antivirus. I found that it works for FEP, but it might well also work for Sophos, NOD32, Norman, Panda, F-Secure, Kaspersky, Symantec and others. 

Add Low Risk Processes policies and exclusions for Backup Exec.

Step 1 - Add exclusions to AV on your Backup Exec Server

  1. Open your antivirus scanner and go to the Exclusions part of the settings.
  2. Add exclusions for the following processes:

    C:\Program Files\Symantec\Backup Exec\beremote.exe 
    C:\Program Files\Symantec\Backup Exec\beserver.exe 
    C:\Program Files\Symantec\Backup Exec\bengine.exe 
    C:\Program Files\Symantec\Backup Exec\benetns.exe  
    C:\Program Files\Symantec\Backup Exec\pvlsvr.exe 
    C:\Program Files\Symantec\Backup Exec\BkUpexec.exe

    NOTE: Change the path as appropriate, depending on which root volume the Media Server or Remote Agent has been installed to.

Step 2 - Exclude Backup Exec paths from scanning

  1. Open your antivirus scanner and add the following path to the Exclusions (including subfolders):

    C:\Program Files\Symantec\Backup Exec\
    C:\Program Files (x86)\Symantec\Backup Exec\

When configuring your settings, keep your eye open for other settings that could complement the exclusions. For example, McAfee has an option to ignore files that are opened for backup.

Step 3 - Add exclusions based on the used product

Active Directory, Exchange, SQL - they all have their own required exclusions. Configure these exclusions using the following articles:

Once you've set these, there's a good chance things will improve drastically.

Symantec, you would do well to make a dedicated article explaining what exclusions to add - not just for your own products, but also other products that BackupExec has to work with. 

CraigV's picture

...well, technically they have:

...I've had these issues with other AV to be honest, although I have seen this work for some other AVs.

However, how many AVs are out there? The basics would remain the same, the services remain the same. Just exclude them from your AV scan...

Alternative ways to access Backup Exec Technical Support:

Meindert's picture

True, but unfortunately that article has the reach of a flagellum. The McAfee article is much more detailed. Also, it touches on the fact that not doing Best Practice exclusions for other products - say, AD, SQL, and/or Exchange - can also combine to give BackupExec a bad day.

I ran into the problem with Forefront combined with AD Federation Services; and Forefront uses a combination of AV engines. I'm not sure whether or not FEP uses McAfee, but even if it doesn't, the exclusions are a good idea and the McAfee article is comfortably specific.