Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

LUA Download task has failed to complete ?

Created: 14 Apr 2013 • Updated: 05 May 2013 | 17 comments
This issue has been solved. See solution.

Hi People,

I have set the LUA to use the connection through my proxy server and tested them successfully, however when I do the manual download or scheduled the download task it always failed with the progress less than 24% no matter how big the definition files is?

Task 1:

 

Total size of files in request: 1779 MB.
Percentage Complete: 22%.

Elapsed: 0 hour(s),42 minute(s) 29 seconds.
Started: 15/04/13 12:00:06 AM
Ended: 15/04/13 12:42:36 AM

Further detail on the failures is provided below.

Server Location: Symantec LiveUpdate.
Failed file transfers: 1
Successful file transfers: 4
Reason for failure: Connection failure.

 

Task2:

 

Total size of files in request: 12963 MB.
Percentage Complete: 21%.

Elapsed: 5 hour(s),15 minute(s) 13 seconds.
Started: 15/04/13 3:01:41 AM
Ended: 15/04/13 8:16:54 AM

Further detail on the failures is provided below.

Server Location: Symantec LiveUpdate.
Failed file transfers: 154
Successful file transfers: 374
Reason for failure: Connection failure.

Any idea of how this could be happening ?

Operating Systems:

Comments 17 CommentsJump to latest comment

SebastianZ's picture

Try upping the timeout and retry interval as per below article, make sure you are using latest LUA 2.3.2:

https://www-secure.symantec.com/connect/articles/l...

John Santana's picture

Yes I have changed the time out in the files to be as follows:

 

#download.tempfolder.delete=false
download.retry.corruptFile=3
download.resume.corruptFile.retry=10
download.retry.corruptFile.sleep.msec=20000
download.http.header.acceptRanges=bytes
 
but I don't know how come the download still failed ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Ambesh_444's picture

Hi,

I would tell u to use latest version of LUA. and please check with a restart.

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

John Santana's picture

Yes already, I have changed the server.xml (C:\Program Files\Symantec\LiveUpdate Administrator\tomcat\conf\server.xml) as follows:

 

<Connector port="7070" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               connectionTimeout="100000" disableUploadTimeout="true" address="0.0.0.0" />
 
but then it still failed as it never goes pass 24% downloading the live update content.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Mick2009's picture

Hi John,

Could you post the exported EventAuditLog.csv and Luadebuginfo.zip to this thread?  Those should provide additional information on what is happening under the hood. 

Gathering logs and troubleshooting data from LiveUpdate Administrator 2.x
http://www.symantec.com/docs/TECH92654 
 

Many thanks,

Mick

With thanks and best regards,

Mick

John Santana's picture

Hi Mick, Unfortunately I cannot attach the ZIP file here publicly as it contains sensitive information regarding the proxy and its account.

I have uninstall the LUA and reinstall LUA v232 but it is still the same issue of not getting able to pass 26% completed this time.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

here's the event audit.csv renamed as .txt

the event is quite small as I have reinstalled the LUA v232 after importing the same configuration as previous setup.

AttachmentSize
EventAuditLog.txt 2 KB

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Mick2009's picture

Thanks John.

Was this working successfully in the past?  If so, were there any changes to the proxy config?

You are correct- there's not much in that present log other than an indication that a SAVFL def file failed to download:

4/16/2013 12:53:51 EST Download CRITICAL admin Failed to download file "1363356593jtun_sav10enn03m25.lin" while processing request id "1".
4/16/2013 13:53:46 EST Download CRITICAL admin Download job from source server "Symantec LiveUpdate" has failed. There were "1" updates that failed to download.
4/16/2013 13:53:49 EST Download CRITICAL admin Download request  "1" started by "admin" has failed.

I recommend contacting Tech Support and opening a case with them, if other evidence cannot be shared publically.  Feel free to PM me the case number, once created, and I will have a look at the logs attached securely/confidentially to that case.

With thanks and best regards,

Mick

 

With thanks and best regards,

Mick

John Santana's picture

Sure will do it Mick, thanks for your kindness in helping us here.

Hopefully we can fix this issue together and then share it here on the forum for the benefits of everyone.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

AjinBabu's picture

 

Hi, 

Change the timeout session values of the LUA and use the latest live update.

If you are using any proxy server check any QOS is been settled there.

Regards

Ajin

SameerU's picture

Hi

What is the version of LUA ?

Regards

 

John Santana's picture

Sameer, this is happening on LUA v2.3.2

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

AjinBabu's picture

 

HI 

Have you checked the from Proxy side? Is it blocking any connections?

Regards

Ajin

SameerU's picture

Hi

Can you please check whether there is any content filtering policy in firewall

Regards

 

Mick2009's picture

Hi John,

Just checking to see if the LUA server's download tasks are succeeding at present.  Any tips, experiences, etc that you may wish to share would be of beneift to future admins in the same situation.

With thanks and best regards,

Mick

With thanks and best regards,

Mick

John Santana's picture

Hi All,

It is progressing, but I'm still not be able to completely goes beyond 26% complete in downloading "just" the SAVFL 1.0.5 content, there is no other definition update content in the download task, the approximate size is 1.9 GB per task, I'm not sure why it is always failed.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

OK, the issue was resolved:

 

LUA 2.3.x no Longer downloads new content as different symptoms when using bluecoat proxy server.

http://www.symantec.com/docs/TECH202685

This was due to my proxy is using BlueCoat appliance as it is described in the KB Article, bypassing the proxy solve the issue or performing the workaround regularly to clear out the Proxy cache.

Hope this helps.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

SOLUTION