Video Screencast Help

MAC 10.6.6 will not boot after PGP Desktop 10.0.3 install and previous Mac security update

Created: 16 Feb 2011 • Updated: 16 Feb 2011 | 3 comments

I'm running MAC 10.6.6 and pgp 10.0.1 with WDE. I had an issue where I could not boot after a MAC OSX security update. I would get a "o" with a "/" through it and get no further.

I could not boot the recovery CD but was able to via firewire and another macbook using the other mac books.

To recover:

1. Once booted I mounted the pgp disk using:

# '/Library/Application Support/PGP/PGP Engine.app/Contents/Resources/pgpwde' --auth --disk 0 --passphrase "passphrase"

2. I moved off the boot.efi from /Volumes/Macintosh HD/System/Library/CoreServices to another directory

3. copied pgpboot.efi to boot.efi

4. Reboot normally and was fine. 

At this point I wanted to upgrade PGP Desktop because I could not run the PGP.app GUI. I had to re-install or upgrade. I could not do either until I decrypted the WDE disk.

I did the following to upgrade:

1. I decrypted the disk using CLI and reboot and was still ok.

2. Once I reboot followed the CLI uninstall instructions. 

3. Reboot again and was still ok at this point.

4. Installed PGP Desktop 10.0.3 for MAC(no wde) and reboot.

5. Problem re-occurs again. I'm back at the ""o" with a "/" through it" message and cannot get into my desktop. There is no WDE running. This seems to be an issue with the boot.efi file or something else in the startup environment. 

I tried to run the WDE recovery CD and it will not boot. I can boot using the other macbook and firewire cable and tried to use the boot.efi from the recovery CD by copying it to /Volumes/Macintosh HD/System/Library/CoreServices dir. 

Any recovery suggestions to reverse the issue cleanly? Anyway to uninstall PGP while booted from another disk image? 

 

 

Comments 3 CommentsJump to latest comment

mallardduck's picture

10.6.6 and PGP versions prior to 10.1.1 have problems with corrupting the boot.efi.  I'd suggest upgrading, but the transition to Symantec has resulted in a complete inability to access our entitled software upgrades (see the other thread).

I think you'll need to decrypt, uninstall, uninstrument the disk, install 10.1.1, then encrypt.

A faster way (but a bit more touchy) is too boot from a different disk, clone the impacted drive to an unencrypted target (make sure to exclude the /PGPWDE01 and /PGPWDE02 files), test the clone!!!, repartition (not just erase) the problem drive, clone back, uninstall 10.0.3, install 10.1.1, encrypt.

SDTSymantec's picture

For recovery options after the 10.6.5 update please see the following article.

http://www.symantec.com/docs/TECH149998

Vladimir Velichkin's picture

The files mentioned in "Recommended Recovery Process" section of the article are not available for download anywhere. Is there any way to get ahold of them?