Video Screencast Help

Mac OS 10.6.6 bootstap-osx install error

Created: 24 Mar 2011 • Updated: 24 Mar 2011 | 2 comments

Hi All,

New to Altiris - hoping someone can lend me a hand with this?

We having just rolled over to CMS 7 SP4 and are about to come out of test and go live over our University Campus.

I have had a great success deploying the Agent 7.0.7416 this way via Apple Remote Desktop:

I have packaged up these files:

Unix file "aex-bootstrap-macosx" stored in the root of Macintosh HD

Shell script called Altiris.sh also stored in the root of Macintosh HD with the following in it:

sudo /aex-bootstrap-macosx http://our.new.server (obviously NOT the actual server address)

A post install command to run Altiris.sh

I know this is probably a long winded process to achieve the same result, but it works!

 

I have had huge success deploying the agent to a variety of machines all over campus (10.6 and 10.5) but it has started to fail on a few machines and I can't see why. The machines are on the same basic MOE as the rest of campus. They are showing this info in the error:

Verifying archive integrity... All good.
Uncompressing Altiris Agent Installer 7.0.7416
Removing already existing file './AltirisAgentInstaller'
Removing already existing file './AltirisAgentInstaller.data/AltirisAgentInstaller-bin'
Removing already existing file './AltirisAgentInstaller.data/gcc/libgcc_s.1.dylib'
Removing already existing file './AltirisAgentInstaller.data/gcc/libstdc++.6.dylib'
x ./AltirisAgentInstaller
x ./AltirisAgentInstaller.data/
x ./AltirisAgentInstaller.data/AltirisAgentInstaller-bin
x ./AltirisAgentInstaller.data/gcc/
x ./AltirisAgentInstaller.data/gcc/libgcc_s.1.dylib
x ./AltirisAgentInstaller.data/gcc/libstdc++.6.dylib

INFO: NS Name specified in both config file and command line. Using file, NS used will be: our.new.server
INFO: Getting Package: http://our.new.server/Altiris/NS/NSCap/Bin/Unix/Ag... into temp dir: /opt/altiris/notification/nsagent/.tmp_inst
INFO: Success getting Package.
INFO: Installing package...
Altiris Agent for UNIX, Linux and Mac 7.0 will be installed to /opt/altiris/notification/nsagent

=============================================================================
Fri Mar 25 12:01:56 EST 2011
Performing installation of Altiris Agent for UNIX, Linux and Mac 7.0.7416 SP4
=============================================================================

Uncompressing AltirisAgent.pkg.tar.gz...
Installing Altiris Agent for UNIX, Linux and Mac 7.0 on the system.
Discovered installation of the 7.0.7416 package.
You have already installed Altiris Agent for UNIX, Linux and Mac package version 7.0.7416
Installing additional components...

=================================================================================
Fri Mar 25 12:01:58 EST 2011
Performing installation of Altiris Client Task Agent for UNIX and Linux 7.0.7416
=================================================================================

rollout-ctagent.sh: line 129: aex-helper: command not found
Failed to find the Altiris Agent installation root dir.
Failed to find the target installation root dir.

 

When I try to launch the Altiris Agent from the Utilities folder it fails to launch and says that the agent is not installed properly.

I have deleted the hidden files created in /tmp (including the xml file created by the bootstrap file) and also removed the /opt folder from the Machintosh HD which is substantially empty when compared to a funtioning install.

I've also tried copying the /opt folder from a Mac that is working - this launches the agent but it gets the same unique Altiris machine name and does not come up in the CMS on the server.

Can anyone out there shed some light on this?

Comments 2 CommentsJump to latest comment

KSchroeder's picture

...but in the past few weeks, Altiris 7.1 was released, and there is in addition SP5 for the SMP 7.0 as well!  You can check the release notes for SP5 here. There are quite a few references to fixes for the ULM (Unix/Linux/Mac) Agent and some Mac-specific notes.  Since you're not yet in full rollout, you may want to consider the upgrade.  Unfortunately 7.1 requires a Server 2008 R2 (64 bit only) server, but you can migrate your configuration settings.

Your log file also shows that the installer for the Task Agent couldn't find the root install directory.  There is a KB here (TECH42135) that references this issue and has some suggestions; seems to be due to some permissions? 

We don't run NS7 or any MAC anything, so I can't give you too many specifics...but I hope that helps!

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

jenwa's picture

Thanks KSchroeder,

I'll leave the upgrade to our admins - more focussed on getting the current version active and running.

I managed to fix my error after reading through the upgrade unix file from the KB article you supplied.

I ran this via ARD:

rm -R /Library/StartupItems/AltirisAgent
rm -R /Library/Logs/Altiris/
rm -R /opt/
rm -R "/Applications/Utilities/Altiris Agent.app"
pkgutil --forget com.altiris.AltirisAgent

Then re-ran my Altiris.sh script and it all came up golden. Machines reporting to the CMS properly and all things are happy now.