Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Mac OS X Agent stalling during backup

Created: 18 Apr 2013 • Updated: 23 Apr 2013 | 5 comments
This issue has been solved. See solution.

 

When attempting to backup files from our Mac OS X 10.6.8 file server, we are encountering a problem where the backup will stall if it encounters a file containing non-standard characters.
 
For example, attempting to backup a file with 'ä', 'Ä' or '–' characters (pretty much any non-standard character) in the name results in the backup process stalling. The file or folder isn't skipped - the backup simply gets stuck.
 
Users can see the file fine in Finder (MEETING NOTES – Test.doc) but if we do an ls in Terminal the file looks like MEETING NOTES ??? Test.doc with the hyphen character represented as \342\200\223 if you try and perform a move operation.
 
We've tried setting the Encoder option (Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\RALUS\Encoder) to LATIN-1 and UTF-8 but the problem still occurs.
 
If we copy the file across to a Windows server we can complete the backup successfully.
 
It is vital for us to be able to back up our file server (on Mac OS X) so I'm hoping someone on the forums here might have a solution or some suggestions.

Comments 5 CommentsJump to latest comment

Colin Weaver's picture

Please log a formal support case so that a full investigation can be performed.

stenorman2001's picture

Hi Colin,

We did this but unfortunately found that the person assigned to the case seemed more interested in getting the case of his desk than assisting us.

We were however able to solve the problem ourselves so I'll post the solution below in case other users encounter the error in the future.

stenorman2001's picture

Problem

When you start the Backup Exec Remote Agent for Mac (RAMS) from an SSH session, backups may stall when encountering files or folders with non-ASCII characters in their names.

Cause

When you remotely access Mac OS X over SSH, the locale environment variables are not set, resulting in the session using C-language encoding.

If the Backup Exec Remote Agent for Mac is started over SSH, it inherits the encoding of the session, resulting in backups stalling when encountering file and folder names that do not match the C-language encoding.

Solution

OPTION 1

Start the Remote Agent from a Terminal session by connecting to the server using Apple Remote Desktop or VNC.

OPTION 2

Before starting the Remote Agent, execute the following commands in the SSH session:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

This will set the session's language to English (US) with UTF-8 encoding.

SOLUTION
pkh's picture

Are you quoting for a Symantec document?  If so, do post the link to this document.

stenorman2001's picture

Hi pkh,

No Symantec don't appear to have a document on this. This is something we prepared and sent back to support as it might be useful to have a tech note so people can avoid the problem in the future.