Video Screencast Help

Mail Items Stuck in Archive Pending State

Created: 05 Aug 2013 | 11 comments

Hi,

I have some users who have some mail items that are in in an archive pending state which don't apear to archive or they don't appear to be changed back to normal mail items.

I added the the cancel operation (which was not enabled before) for them but they are unable to revert the items. I have tried out the steps as per article below but that has not made a difference.

http://www.symantec.com/business/support/index?page=content&id=TECH35618&profileURL=https%3A%2F%2Fsymaccount-profile.symantec.com%2FSSO%2Findex.jsp%3FssoID%3D1375690013536pZn3XpwPUV9A2X5wXchb9N3kq17S1pMdLkXCO

It only appears to be affecting 3 users at the moment but not sure as to why this is. The scheduled archive task appears to processes the affected mailboxes fine, it just when the users try manually vault items.

The environment is EV 9.0.1 with Exchange 2007 servers.

Thanks.

Operating Systems:

Comments 11 CommentsJump to latest comment

Advisor's picture

Do they get any error while cancelling the pending archive items? You might get more information in client trace logs on affected users client machine.

You can try using Solution 2 from the technote which you referred, Pending Shortcut time out. Modify the associated policy for those users and synchronize them from task propeties. Once done, run the archiving task in report mode for selected mailboxes and select affected users mailboxes.

Once done, monitor the users mailbox, check if the pending items changes to either normal or archived items (shortcut icon).

EV_Ajay's picture

Hi,

When user click on manual archiving and those item goes into the pending state that might be th Vault Store associated for those user have setting "Remove safety copies : After Backup". Hence till the time the DVS file of archived item is backed up and it remove the "A" attribute the item will not convert into Archived Item.

Please Refer following article :

Why items may get 'stuck' in a Pending State - Enterprise Vault (EV) Basic Archive Process.
http://www.symantec.com/docs/TECH66202

 

Thanks,

Ajay

AlanJ's picture

@Advisor, I have tried option 2 to no avail. The client trace did reveal an entry "Unable to add/remove Outlook ForceFormReload registry key fix for Outlook: 0x80070005"

I did some searching and found http://www.symantec.com/business/support/index?page=content&id=TECH54029 that describes the symptom but a user has confirmed that the DCOM settings are enabled on his machine.

@EV_Ajay, all the users use the same vault store. Saftey copies are removed after archive and the MSMQ clears during the weekend run.

Pradeep_Papnai's picture

Hi Alan,

Can you supply client trace + dtrace (on AgentClientBroker, W3WP, ArchivingTask) while you reproduce the issue?

Regards
EV-C

GabeV's picture

Since this issue is only affecting three users, I'd suggest the following:

1. Remove and recreate the Outlook profile.

2. Have the users logging in another computer to rule-out any issues related to the Windows OS/Outlook client.

3. If you know for sure that the archiving task is working properly for these three mailboxes, then you don't need to follow these steps. Just in case, I'd try the following:

  1. Zap all three mailboxes and re-enable it for archiving (http://www.symantec.com/docs/TECH35614).
  2. Perform a Run Now in the archiving task to archive these three mailboxes.

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

EV_Ajay's picture

Hi,

Have you capture the Client Trace for affected users. It will be useful for troubleshooting.

Thanks,

Ajay

A_J's picture

Hi,

 

You can use the DocMessageClass utility mentioned in following article to manuallly cancel the items in pending status.

http://www.symantec.com/docs/TECH49295

 

 

 

Ben Watts's picture

You say it is when the users try to manually archive items only, have you reproduced this time and time again?

How are they 'manually archiving the items'?

Is it via the toolbar button or are they dragging them into Virtual Vault or something similar?

 

I would say at this point that DocMessageClass wouldnt help if no matter how many items you manually archive none of them go to fully archived.

Have you got any mails sitting in the MSMQs at all? (Probably the A2 queue if these are related to Manual Archive requests)

A_J's picture

Can you ask the user whether the behavior is same for every items they archive ??

If yes please provide the client trace + dtrace (on AgentClientBroker, W3WP, ArchivingTask) while you reproduce the issue?

Following article might help you to enable client trace and dtrace...

How to run Dtrace to help diagnose issues with Enterprise Vault

 
How to perform a client trace for Enterprise Vault (EV) within Outlook
AlanJ's picture

The Outlook profile recreate has helped the user to cancel the operation successfully, however when he tries archive those particular mails, he still gets them in an archive pending state.

I have got a client trace from him but haven't run a DTrace as yet. I'll do that once I am bable to contact the user.

I gather that other items work fine, just not from a specific time period. 

 
Ben Watts's picture

Hi Alan,

Are these items normal IPM.Note items or something different?

Personally I would get them into a PendingArchive state and then Dtrace a Shortcut Processing run against that 1 users mailbox (makes the Dtrace easier to look through) and search for the Subject of the email within that Dtrace.

Dtrace ArchiveTask process, this should give you enough to go on to find out why EV isn't fully archiving them.

Have you checked in the MSMQs to see if we are seeing stuck items in there too that relate to these items in the mailbox?

 

Just a quick question, do you have 'Shortcut Pending Timeout' set at all within the Exchange Mailbox Policy? I'm not saying that this will help in this situation, as it wont if we are unable to fully archive the items, but I was wondering if that was doing its job correctly and returning these items to normal items or if that was having problems manipulating these items too when we get to the Timeout period.