Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrade.
Please accept our apologies in advance for any inconvenience this might cause.

This mailbox has duplicate entries.... Error 3333 events

Created: 10 Feb 2010 • Updated: 22 May 2010 | 8 comments
This issue has been solved. See solution.

Hi,

We are nearing the end of our migrations from one AD to another. We have SynchInMigrationMode set to 1 (on).   (not SyncInMigrationMode without the H as I first typed)

For 99% of mailboxes this has worked fine.

Some users have just the one Exchange Vault item, some have 2 but no complaints... but some (say 200 people) have the following error appearing in the EV log:

---------------------------
Event Number 3333
Severity Error
Application or service EV 
Typical message
This mailbox has duplicate entries in the directory and cannot be processed. LegacyDN: %1 DefaultVaultID: %2
---------------------------

There is no info on this in the Rossetta so wondering if anyone has any ideas what I can look at and try?

Many thanks for your time

James

Comments 8 CommentsJump to latest comment

TonySterling's picture

There is this technote:
http://seer.entsupport.symantec.com/docs/296190.htm

Just curious, could those mailboxes have been migrated before your set the SynchInMigrationMode registry key?

Do they MbxArchivingState = 3? 

You can run the following sql against the EV Directory DB:

Select * from ExchangeMailboxEntry where MbxArchivingState = 3

James Slack's picture

Thanks for the quick reply Tony!

I am 100% sure that I set the Sync mode before starting the migrations... whether someone else took it off for a bit I can't be sure, but seeing how it is pretty much me alone doing both Vault and the migrations I am fairly sure this is not the case.

I ran the command above (was missing a N from exchaNge should anyone else stumble across this post one day) and got 108 results back - they are in deed the people that were having the issue (I must have double counted to get the 200 number).

Is this something that will go away once we get rid of our old Exchange / AD?

When I finally finish migrations (we are now down to under 10 users out of 4000 so nearly there!) can I just turn the SyncInMigrationMode off and will that fix this issue for these people or would it make it worse?

Thanks again

James

James Slack's picture

I just noticed...

All the mailboxes that appear in the list have only one "Exchange Mailbox" in Vault... all the rest of the people who are not erroring have a 2 or 3 items showing in "Exchange Mailbox".

This is probably expected behaviour, but I don't really understand.

Cheers

James

TonySterling's picture

Sorry about the typo in the sql, i fixed that in the post.  :)

One quick question, is your registry entry SynchInMigrationMode or SyncInMigrationMode?

James Slack's picture

HKLM\Software\KVS\Enterprise Vault\Agents    SynchInMigrationMode = 1

Synch with the H.

I believe this is the correct way and I was just saying it wrong in my posts, which I will edit out now. :)

James Slack's picture

Has anyone seen this before?

I guess it;s time to log a call with Symantec if not, now I have a couple of days to look at Vault.

Cheers

James

James Slack's picture

OK Basically, we need to delete any Vault SQL entries that have a MbxArchivingState of 1 for a user that is having the issues and then the enable works.

Only do this for the users that you can't enable post migration.

This is the SQL used:


To find details of the user you are having issues enabling:
 
select *
from Exchangemailboxentry
where firstname = 'james' AND lastname = 'slack'

(Change the names!)

To delete the ones that have a state of 1 for those affected users:

delete from dbo.ExchangeMailboxEntry
Where MbxIdentity = '12345'

(Change the numbers!)

Here is some background info
Event 3333 - http://seer.entsupport.symantec.com/docs/296190.htm
SynchInMigrationMode - http://seer.entsupport.symantec.com/docs/294339.htm

Hope this helps.

SOLUTION