Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

MAPI connection issues

Created: 23 Apr 2013 • Updated: 30 May 2013 | 11 comments
This issue has been solved. See solution.

Hi,

I have an environment that is experiencing issues with connecting to Exchange 2010 servers over a WAN link from an EV 9 server. The problem appears to be intermittent which has occured over the last 24 hours or so.

The environment consists of 3 clustered Exchange servers with the active nodes in the production site and the passive nodes in DR. The issue appeared to have started when the Exchange servers were failed over. So I stopped services, cleared out the queues, restarted server and all was fine until earlier today where it started up again.

I found that I was not able to open up any of the EV realated accounts in Outlook (got the username/password screen), but a server restart did the trick for about an hour or so when the issue reappeared. It hanged around for close to an hour before it disappeared again, but before it did I ran an DTrace on the ArchiveTask and found that it logged:

Event ID: 3422 An Enterprise Vault task is not correctly configured.The task account's mailbox must have an appropriate Exchange Server 2010 throttling policy applied.

I have since checked the Event Viewer and confirmed that those errors are being logged there too.

Now the strange thing is that the throttling policy has been checked and found to be set correctly in Exchange. To compound things a little bit, what has also been noticed is that archiving does run at a very slow rate which may be due to the fact that the WAN link is also heavly utilized.

I'm looking for some explananation to give back to the client and I'm thinking that it these issues be possible due to bandwidth constraints in the environment.

Would that be possible at all or could there be other factors that are at play here?

Thanks.

Operating Systems:

Comments 11 CommentsJump to latest comment

Rob.Wilcox's picture

Have you got the output of the checks that you made regarding the throttling policy? It might be worth checking the throttling policy from the EV 10 media - if I recall correctly there is a slight change in the way that the policy is amended for the Vault Service Account.

MMcCr's picture

If things are OK with your throttling, then check your connectivity from the EV server to exchange using Outlook, you can see the latency and connectivity speed through 'Connection Status..' (cntrl + right click Outlook icon near the time on your tool bar).

This will help give a real time idea of the Outlook connectivity, and MAPI over the WAN.

Rob.Wilcox's picture

Do you still need some help with this issue?

AlanJ's picture

The issue still appears to exist although it is rather intermittent. Things have generally been fine but in the last couple of days we have been experiencing MAPI related issues again.

Response times appear to be good and I have checked the connectivity and see that there are a number of failed requests quite often so I guess that may point to a WAN issue.

There are plans to increase the size of the link so hopefully that can make a difference.

JesusWept3's picture

Are you absolutely sure you're not breaching the throttling policy though? You may wanna look through the application event logs and see if your CAS servers are closing the connection cos of throttling policy breaches

It will mention the evadmin itself so you can do a quick of the event logs

AlanJ's picture

I'll get the Exhange Team to check that although there are currently network issues in the environment that are impacting several technologies and this is causing the tasks to fail as they cannot connect to Exchange.

Do the mailboxes used for the respective tasks also need to have an amended throttling policy or is it only the EV admin account that needs this?

JesusWept3's picture

The evadmin itself because it controls how much time a particular user can spend querying the AD or CAS etc

AlanJ's picture

Checked the CAS server and don't find any throttling breach events. The networkis now a bit more stable than it was recently but we are now experiencing the following on a regular basis - not sure if it could be potentially related.

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          5/23/2013 12:54:19 PM
Event ID:      3419
Task Category: Retrieval Task
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:     
Description:
There was a problem accessing an Exchange 2010 or later server.  The dispenser will re-queue the current item and sleep for 1 minute(s).

Task: Exchange Mailbox Archiving Task for (Retrieval)

We get this for both archive and retrieval tasks and it happens almost every minute.

Something we have tried is to include a CAS NLB entry in the hosts file specifiying one of the CAS IPs as load balancing is done by hardware, but this doesn't seem to have helped.

Rob.Wilcox's picture

Well, after you have made the changes on the network, have you since gone back and done basic checks with regards to connectivity from EV to the various system mailboxes?  And to the Vault Service Account mailbox also?

SOLUTION
AlanJ's picture

Everything was checked and was fine for a while, but subsequent checks have found dropped packets to the Exchange servers.

Issue definitely appears to be realted to ongoing network problems in the environment.

Rob.Wilcox's picture

Alan, I'd suggest marking one of the posts as the solution then, as the issues are well outside of Enterprise Vault.

Hopefully the networking issues will be resolved, and as you can see from your last couple of updates, Enterprise Vault does try hard to cope with issues like this (by requeueing work)