Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Mapping "mountvol" ID to specific volume

Created: 22 Oct 2013 • Updated: 23 Oct 2013 | 2 comments
This issue has been solved. See solution.

If I run "mountvol", it will show me the volumes that I can map to a drive letter or to a path.  But it only gives me a windows drive ID.

How do I map this ID to a specific running volume?  I can't give the storage foundation path to the volume, it just whines when I try.  But I need to programmatically mount the correct volume. 

Thanks!

(mountvol output:)

Possible values for VolumeName along with current mount points are:

    \\?\Volume{3b9a0744-7199-11e0-a472-806e6f6e6963}\
        C:\

    \\?\Volume{3b9a0745-7199-11e0-a472-806e6f6e6963}\
        D:\

    \\?\Volume{5965b149-0fea-46da-a0e5-0deeef166486}\
        *** NO MOUNT POINTS ***

    \\?\Volume{84e9b221-41ab-4685-be03-7e0abef75ae8}\
        *** NO MOUNT POINTS ***

Operating Systems:

Comments 2 CommentsJump to latest comment

mikebounds's picture

You should use "vxassist assign" rathert than mountvol and then you specify diskgroup and volume:

vxassist -g dg_name assign vol_name DriveLetter={A|B .. Z}

If you want to map GUID to volume name, then use "vxprint -l" and this gives you the volu

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
Darren Dunham's picture

Righto!  My Windows-fu is limited.  Thank you for that!

I had been looking for the mapping in vxprint, but the volumes themselves don't have anything like a GUID.  There is one on the plex, but I'm not going to mount that.