Video Screencast Help

Max Rows in SQL scan

Created: 13 Nov 2012 | 5 comments
Joe Saland's picture

I'm trying to configure SQL scans to limit the number of rows that are retrieved for each table.  The online help and admin guide suggest that this is the correct syntax:


But I get failure to connect to "database_name,1000" as an error message.  When I try without the the rows:


It works just fine,  but it's taking forever since it's a large DB.  That's why I was trying to limit the # of rows that are scanned for each table.

This is using DLP 11.6 against an MSSQL2008.

Is there something wrong with the synatx above?



Comments 5 CommentsJump to latest comment

Joe Saland's picture

Just adding the fact that I'm using jtds-1.2.5 in case it's relevant.

Joe Saland's picture

So what I found was this.  If you are adding a new data source and you have that large text box to enter in multiple datasources, one per line,  it works if you also add the instance name.


If you have already created the datasource and then are going back to add in a max row count,  there is a separate box down at the bottom of the edit window for that datasource where you enter in the max row number.

One question I still have is that max rows total for that datasource, or per table within the datasource.  It makes much more sense for it to be per table,  but short of inspecting the traffic it's hard to know what it's really doing.  It definitely decreases the scan time on large databases.


rmnetops's picture

Here is what I got working, so it only pulls 10 rows (the scan object is configured to use an Active Directory credential using <username> format and not <domain\username> format):


I also confirmed the max rows setting is per/table

kishorilal1986's picture
Hi Joe,
For SQL Database scanning , Vontu can be throttled based on maximum rows processed per minute as well as max bytes processed per minute. This can be done from the Advanced tab of the Discover target: