Video Screencast Help

MBR & GPT Imaging Problems

Created: 16 Jul 2014 | 6 comments

Hey guys,

I have a bit of a problem and I am hoping someone here can help clear some things up. This is kind of long so here we go...

I am working for an university in their IT department and we recently recieved a lot of new computers to replace the older ones. The new ones we got in are the HP z230's. The ones we replaced are HP z220's. I learned that the z230's require WinPE4 to clone and the ghost console cannot send tasks to these machines, they can only be cloned by manually booting each one to a ghostcast server. It took a while to pull the z230 image and we were getting some random errors so we decided to use a z220 image and push it onto the z230 machines to see if that would work. While going through the ghost cast prompts it asked question(1873): "The source is MBR and was captured on a BIOS system. The destination system appears to be UEFI, convert destination disk to GPT?" Since the z230's were already GPT I didn't understand why it was prompting us to convert to GPT but we clicked Yes and the second question(51932): "If image don't have system reserved partition, then use CESP(Create EFI System Partition) switch. Do want to continue?" We also answered Yes to this one as well. The clone went through and everything seemed to work (except for the resolution was a little messed up but overnight the machines auto adjusted and in the morning they were fine). Some of the drivers however were missing, mainly the graphics card so I believe it resorted to the integrated one. So we cloned the whole lab (around 24 machines) and it seemed to be working fine. However, I still thought we should use a z230 image on the z230 machines so we redid the image and got it working and pulled it. When we went to clone it prompted us with the same 2 questions, which I found strange since the image machine is GPT and the target machines are still GPT (we checked through diskpart). Now, everytime we try to clone a z230 with the new image, it gives us a BSOD after completion. My question is, are these machines now unable to receive an image that is not from the z220 image, or is there a way to get these machines back to normal and use a z230 to clone? We've tried completely wiping the drives, using disk part to clean and convert to GPT but everytime the same result. I am not sure what needs to be done at this point but everything we have tried has failed. Another strange thing is that when we try to clone the z230 the main partition is the E drive for ~450gb and the C drive is a system partition for 100mb.

We are trying to clone machines running Windows 7x64 Pro

We have GSS 2.5

Thank you,


Operating Systems:

Comments 6 CommentsJump to latest comment

EdT's picture

If you have maintenance on your GSS 2.5 then speak to support about an update to the Ghost binaries which will help with UEFI issues as 2.5 does not support UEFI so you need to turn it off in the bios.

I believe you should be able to image these machines with WInPE3, as this is the version based on Windows 7, and to my knowledge, no manufacturer has yet discontinued Win 7 drivers for hardware as this is pretty much the de-facto desktop windows version most people are running, especially in corporate environments.

Look for a couple of articles by Terry Bu which describe how to get WinPE 3 working within the Ghost 2.5 environment.

There is also a long thread with 150+ postings near the top of the recent postings which discusses when the next major release of Ghost will appear. The current PM has indicated that the first set of updates has just been released, and is looking at ways to make these available to long time users who stopped paying for maintenance when nothing was updated for several years.  You may find that the newer version may help you also.

Regarding your hardware, if the hard disks are not bigger than 2Tb then there is really no need to go to GPT partitioning. You need GPT only if you want to have a partition greater than 2Tb.

Finally, windows 7 consists of two partitions, a hidden partition of 100Mb at the beginning of the drive, then the next partition (often the remainder of the drive) is the main system volume. If you are getting the C: drive as a 100Mb volume then clearly it is not hidden so you need to review how you are preparing the disk before image deployment.  I'm guessing that the D: drive is the optical device.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dephloc's picture

Hey thanks for the response,

I actually spent about 6-7 hours with support last week and asking about updates and talking with him about WinPE4 and how my machines cannot use WinPE3 and how they cannot be sent tasks via the ghost console. The reasons he gave were that the hard drives were GPT and when I asked him if switching it to MBR and using legacy would change anything he kind of just repeated what he just said about them being GPT and how ghost console doesn't play well with GPT. He also told me that the network card was a problem(Intel I217-LM) and that is another reason ghost console can't send tasks because I'd need the vista NIC drivers and that this particular type of NIC the vista drivers are not available. However, that being said I *should* be able to use both WinPE3 or WinPE4. So I booted up one of the machines with our win7 disc and openned a terminal at the beginning of the installation, used disk part to clean and convert the disk to MBR (after opening the BIOS and disabling UEFI) however the installation failed (even after multiple attemps) saying Windows cannot install on your current hardware settings. Which is something I have been trying to fix but haven't been able to figure out what the problem is.

The tech helped me create a WinPE4 boot usb and I've been manually cloning each machine by adding them to a ghostcast server, but when I try to push the z230 image to the z230 machines it fails. Even though we've now changed the z230 to MBR and disabled UEFI and tried pushing a basically blank image. 

I was reading about MBR vs GPT and I agree we want MBR, however the machines came with GPT and somehow they like resorting back to it because several times when I have changed the settings to MBR the next time I check after a failed install it's GPT, not always, but sometimes.

Well I've used Disk Wipe (3 passes) to completely wipe the drive and when I install windows it says the disk is ~465gb unallocated, so I use it and it puts the 100mb as the C: drive everytime and the E: drive as the rest. What should I be doing differently to get this NOT to happen? I can't remember what happens when what is says when cloning over a completely wiped disk (would take a few hours to test) but I know it BSOD's after so it doesn't really matter.

So another question would be, why can't I put windows 7 on these z230's after disabling UEFI and converting the disks to MBR? Shouldn't Windows be able to install perfectly on that setup? Is there some underlining problem that is not allowing Windows to install?



EdT's picture

OK, lets take this a step at a time.

First of all, the I217-LM is known in these forums - just search on it. You are correct that there are no vista drivers for it, but WinPE 3 allows you to use the Win 7 drivers. This has been established by many users and as I mentioned before, there are some things you can do with the console and WinPE 3 as per the articles by Terry Bu - did you search for them?

Secondly, have you tried a manual Win 7 install on one of these machines with UEFI disabled and MBR partitioned disks?  This will almost certainly reveal that you also need to include drivers for the SATA chipset so that the hard disks can be accessed. NIC and SATA drivers are the two almost certain pre-requisites if you want the machine to boot and have network access.

Thirdly, if your 100Mb hidden partition is rocking up as C:\ then there is a fundamental issue with your image. Discard it and start again. The manual install will quickly reveal whether there are any other "issues" with your hardware before you go any further.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dephloc's picture

Yeah I've been looking at a lot of different forums regarding L217-LM and just about Ghost is general. When I came on board they had a working PE that someone had set up a few years ago, now they have all left and with these new machines I'm trying to learn Ghost and how it all works. My ghost training consisted of running a few tasks and that's it. I am looking at these articles by Terry BU but my lack of ghost knowledge is making it difficult to follow along.

We got the manual clones working again, so I think we'll continue using that just to get the machines up and running, and I'll play with WAIK and Terry BU's suggestions and see if I can't get the console to work with these new machines.

Yes I have, I guess the problem was HP decided to have a RAID setup, so changing that to IDE did the trick. 

So the 100mb C: drive I'm seeing on the ghostcast server is because of a bad image? I don't think I understand, our images' C: drive is correct as well as the other drives, there is a hidden 100mb drive but there is no letter attached to it and it's not C. When you say discard and start again, should we use a disk wiping program and wipe everything? Or just use diskpart during the Win7 installation and clean/convert MBR and install Windows on the big unallocated space (assuming it will generate the 100mb NOT as the C: and install Windows on the C: drive)

EdT's picture

I was referring to the images. Are they sysprepped?  Were they recorded as disk or partition images?

Do your new machines have advanced format hard disks?  These are all questions that change the imaging scenario somewhat.

As for the Win 7 disk layout, if you were to examine a manual Win 7 installation with a disk partitioning tool (even diskpart), you would see that there is a 100Mb hidden partition at the beginning of the disk, which does not have a drive letter assigned to it. (no point as it's hidden). The second partition is the main system partition which is the C: drive on a normal install.  

On a vendor machine, there may also be a maintenance and a backup partition - these are again normally hidden and the order of partitions may vary by vendor. Lenovo often have a boot manager partition which is linux-like.  UEFI bioses may have extensions on the hard disk.  In other words, the complexity of modern hardware is ever increasing and this makes the imaging process more challenging.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ryanschoenherr's picture

If you are looking for ways to alleviate imaging headaches, we have the ability to streamline and automate the process.  Novacoast is hosting a webinar about our Universal Imaging that integrates with Altiris.

Check this out if you can make it.  If not, but would like to see a data sheet, or have a conversation about it, shoot me an email.  I'd apprecaite the time and opportunity to share more details.


Registration link to the webinar: