Video Screencast Help

Media id is not assigned to this host in EMM database

Created: 27 Mar 2014 • Updated: 01 Apr 2014 | 11 comments
This issue has been solved. See solution.


I am trying to import a tape from catalog backup &  I get the error message as media id is not assigned to this host in EMM database (95).

This  backup was taken in 2011  &  I could not find the tape entry in database . Need to restore the data from this tape .

When I run below command I  get the  error message as 

nbemcmd -listmedia -mediaid F361L3


The function returned the following failure status:

Volume does not exist in database (35)

Command did not complete sucessfully.

Can anyone help to solve this ??

Operating Systems:

Comments 11 CommentsJump to latest comment

Marianne's picture

volume does not exist in database

This means that NBU has no knowledge of this tape. Use the Media section of NBU GUI to add the media id or if you have a robot, put tape in robot and perform Inventory.

PS: PLEASE upgrade your environment. NBU 6.5 ran out of support in 2012.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Nicolai's picture

WOW - Do you want to restore a catalog backup from 2011 ???

Please explain why !

Any import of tapes need to follow the procedure outlines in the technote below.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

mnolan's picture

I'd like more detail as to what "import a tape from catalog backup" actualy means...

-Update- Marianne is absolutely right. If you do not have this in a robot that is inventoried, then you will receive that exact error code. Tested this in a lab.

cynthiapinto's picture

I have a standalone tape drive & trying to restore the data backup not the catalog. 

I added manually the media ID but still the same errror

sazz.'s picture

To confirm the media ID you created has been written to the tape in the standalone tape drive:

Open the NetBackup Administration Console > Device Monitor and check the column "Recorded Media ID" for the Standalone tape drive.  It should be seen that the media ID (created by one of the above methods) has been written to the tape currently in the standalone tape drive.

To Inventory media that has already been written to in a Standalone tape drive (and to update that volume in the Volume database):

For media that has already been labeled and written to by NetBackup; you can perform a physical inventory on the standalone drive or robot to update the Volume DB:
1. Open a command prompt to the <install_path>\Veritas\volmgr\bin\ directory
2. Run the command: > vmphyinv -u <drive_index>  -h <media_server_name> -verbose
    Example: > vmphyinv -u 0 -h Master1 -verbose
If this media is not written by this NBU please proceed with the phase 1 and phase 2
cynthiapinto's picture

Thanks for the update..

 Now  I could do the Phase 1 import but the Phase 2 import is failing with the below error

INF- Found no images maching the selection cretiria  that were ready for phase 2 import .

When i run bpimmedia -mediaid F361L3 I can see images are present in tape. 

I tried to resore directly from the Backup,Archieve and Restore window but that too fails with error code 5

sazz.'s picture

please look at the image in STEP 3 in this article

Make sure your search dates criteria matches the images date, you can probably put 2010 till 2014 or may be 2000 till 2014 as that will not harm. It shoud be able to find the images depending how old the images are.

mnolan's picture

Do you have the results for the Phase 1? Be sure that phase 1 did not say that it did not recreate the headers due to already having the image in the catalog.

If there is one existing image in the catalog you can not import a second copy.

mph999's picture

mnolan has said what I was going to say.

There are x3 bits to the catalog/

1. Images DB

Because bpimmedia shows the images on the tape, there are already in the catalog.  You cannot import them again.

If Phase one finds additional images (eg. some had expired) then only these would be 'importable' in phase 2.

The usual cause of images not being found for phase 2 import, is because when you search for them, the date range used to search isn;t big enough.

2.  Volume DB - this holds the physical aspect of the tape, eg, which robot it is in, the barcode etc ...

3.  Media DB

This is the important one for this issue.  EMM shows the tape isn't in the DB (though it will be after phase 1, but has a retention of only 1 week (this would change after phase 2 completes)).

To cut the story short, you have a NBCC (catalog consistency issue).  The tape has somehow become expired before the images on the tape, which leaves it at risk of being overwritten.

To correct this I suggest logging a call and running NBCC.  This will be able to 'fix' the issue (providing the tape isn't overwritten).  I recommend this as there may be other tapes in this state, so best to make a check.

Other option is to expire the tape and import.  Make sure you write protect the tape, and you will have to move the tape to a differnt pool than scratch to be able to import.

Regards,  Martin
Setting Logs in NetBackup:
cynthiapinto's picture


I tried the second phase import as  mentioned in the documet but no luck. By any means I am not able to see the files under Catalog tab.

Not able to understand where I am wrong.  I can see the files under restore file(Backup,Archieve and restore) . So tried to restore it directly but  I am getting error code as 5 & restoration failes. The backup was taken in July 2011 & the expire set is 2038. 

Is it EMM data base is corrupted?  Bcz this tape was wriiten in robotic drive & now trying to restore in standalone drive.  I am not able to see the tapes in EMM database which are written robotic drive.  

The EMM database contains only tape details which are wriiten in standalone drive.

Is there any way to recover the data using standalone drive as my robotic drive is down . 

Marianne's picture

I believe your original issue with 'media id is not assigned to this host in EMM database' has been resolved.

Please select a post that has helped to resolve this error message and Mark as solution.

I have moved your issue with import and restore to a new thread: 
Please continue in that thread with the new import/restore issue.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links