Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Media Server Can not Connect to Tape Library

Created: 28 Jun 2011 | 16 comments

Hello Experts,

I am Tien, My system using NBU 7.0:

- Master NBU 7.0 connected to tape library

- Media server 1 connected to tape library

- Media server 2 can not connected to tape library, when I restart service error status 130 in file attach. What shuod I do?

please help me.

Thanks.

Comments 16 CommentsJump to latest comment

PraveenCH's picture

Check for the Master server and media server hostname given correctly and able to resolve correctly.

Check for the permission and user account for the netbackup daemons. It should be Netbackup Administrator.

Also check for Event Viewer logs for any application/system errors.

--Praveen

Marianne's picture

What exactly are you trying to start? Request Service/daemon ONLY runs on a master server.

Please have a look at this TN to verify which services should be running on a windows media server:

http://www.symantec.com/docs/TECH57458

Rather use cmd to start services on a windows media server : 'bpup -v' will start media services in correct order.

Please also give us more info for Media server 2:

Is this a new installation?

Does the master server 'know' about this media server? Check output of 'nbemmcmd -listhosts -verbose'

Can master server connect to media server 2? Check output of 'nbemmcmd -getemmserver'

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

pruvn's picture

Hello Marianne van den Berg,

Thank you for your answer,

Media Server 2 is new server, it is pmssfss12.

On Media Server 2:

- bpup -v

Starting services
> NetBackup Client Service
> NetBackup Client Service -- STARTED
> NetBackup SAN Client Fibre Transport Service
> NetBackup SAN Client Fibre Transport Service -- STARTED
> NetBackup Event Manager
> NetBackup Event Manager -- DISABLED
> NetBackup Volume Manager
> NetBackup Volume Manager -- STARTED
> NetBackup Device Manager
> NetBackup Device Manager -- STARTED
> NetBackup Remote Manager and Monitor Service
> NetBackup Remote Manager and Monitor Service -- STARTED
> postgresql-8.3
> postgresql-8.3 -- NOT STARTED
> NetBackup Deduplication Manager
> NetBackup Deduplication Manager -- NOT STARTED
> NetBackup Deduplication Engine
> NetBackup Deduplication Engine -- NOT STARTED
> NetBackup Compatibility Service
> NetBackup Compatibility Service -- STARTED
> NetBackup Request Daemon
> NetBackup Request Daemon -- NOT STARTED
> NetBackup Job Manager
> NetBackup Job Manager -- DISABLED
> NetBackup Policy Execution Manager
> NetBackup Policy Execution Manager -- DISABLED
> NetBackup Service Layer
> NetBackup Service Layer -- STARTED
> NetBackup Vault Manager
> NetBackup Vault Manager -- STARTED
> NetBackup Storage Lifecycle Manager
> NetBackup Storage Lifecycle Manager -- NOT STARTED
> NetBackup Service Monitor
> NetBackup Service Monitor -- STARTED
> NetBackup Bare Metal Restore Boot Server
> NetBackup Bare Metal Restore Boot Server -- STARTED
Start up of one or more services failed.

- nbemmcmd -getemmserver

C:\Program Files\Veritas\NetBackup\bin\admincmd>nbemmcmd -getemmserver
NBEMMCMD, Version:7.0
These hosts were found in this domain: pmssapp27, pmssdbs04, pmssfss12

Checking with the host "pmssapp27"...
Checking with the host "pmssdbs04"...
Checking with the host "pmssfss12"...

Server Type    Host Version        Host Name                     EMM Server

MASTER         ■       Üèσv        pmssapp27                     pmssapp27

MEDIA          ■       Üèσv        pmssdbs04                     pmssapp27

MEDIA          ■       Üèσv        pmssfss12                     pmssapp27

On Master server:

- nbemmcmd -listhosts -verbose

C:\Program Files\Veritas\NetBackup\bin\admincmd>nbemmcmd -listhosts -verbose
NBEMMCMD, Version:7.0
The following hosts were found:
pmssapp27
        MachineName = "pmssapp27"
        MachineDescription = ""
        MachineNbuType = server (6)
pmssapp27
        ClusterName = ""
        MachineName = "pmssapp27"
        GlobalDriveSeed = "VEND:#.:PROD:#.:IDX"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x7
        MachineNbuType = master (3)
        MachineState = active for tape and disk jobs (14)
        NetBackupVersion = 7.0.0.0 (700000)
        OperatingSystem = windows (11)
        ScanAbility = 5
pmssvms01
        MachineName = "pmssvms01"
        MachineDescription = ""
        MachineNbuType = virtual_machine (10)
smssvms01
        MachineName = "smssvms01"
        MachineDescription = ""
        MachineNbuType = virtual_machine (10)
pmss
        MachineName = "pmss"
        MachineDescription = ""
        MachineNbuType = virtual_machine (10)
pesx04.prudential.com.vn
        MachineName = "pesx04.prudential.com.vn"
        MachineDescription = ""
        MachineNbuType = virtual_machine (10)
pmssdbs04
        ClusterName = ""
        MachineName = "pmssdbs04"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x7
        MachineNbuType = media (1)
        MachineState = active for tape and disk jobs (14)
        MasterServerName = "pmssapp27"
        NetBackupVersion = 7.0.0.0 (700000)
        OperatingSystem = windows (11)
        ScanAbility = 5
pmssfss12
        ClusterName = ""
        MachineName = "pmssfss12"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x5
        MachineNbuType = media (1)
        MachineState = not reachable by master (4)
        MasterServerName = "pmssapp27"
        NetBackupVersion = 7.0.0.0 (700000)
        OperatingSystem = windows (11)
        ScanAbility = 5
Command completed successfully.

Yes, we can, Master server can connect to media server.

Master can connect to tape library.

Media server 1 can connect to tape library.

ram619's picture

Are you able to see the tapedrives and Medium changers in the computer management of Media server2. Check the physical connectivity of the tape library and Media server.

Ram

Veritas Netbackup 7.0.1, with WIN 2K3 platform.

pruvn's picture

Hello Ram,

Yes, in Computer management I see tape driver and medium changers, all driver is OK.

Master server ping Media server ok.

rizwan84tx's picture

As per your ouputs, Netbackup request daemon (bprd) is not starting in the media server and hence master server is unable to connect to media server.

pmssfss12
        ClusterName = ""
        MachineName = "pmssfss12"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x5
        MachineNbuType = media (1)
        MachineState = not reachable by master (4)
        MasterServerName = "pmssapp27"
        NetBackupVersion = 7.0.0.0 (700000)
        OperatingSystem = windows (11)
        ScanAbility = 5

Please try starting the service using local admin account.

Best Regards,

Rizwan

sarsingh's picture

if the new media server is a windows 2008 box, you may need to open command prompt as "Run As Administrator" and then try to bring up the services by "bpup -f -v".

Marianne's picture

GUYS, please -  Request Service /Daemon DOES NOT run on a media server!!

Symantec Private Branch Exchange needs to be running as well as all the services as per TECH57458 listed above .

I do agree with Rizwan - this seems to be causing the problem(s):

MachineState = not reachable by master (4)

The only other time that I've seen this was in your other post when the production media servers were not available at your DR site: https://www-secure.symantec.com/connect/forums/del...

Please check output of the following from master:

bptestbpcd -host pmssfss12 -verbose

Please also confirm that you have all necessarry license keys installed on the media server:

Enterprise Server (or Enterprise Client)
Robotic drive license
SSO (shared storage option - if drives are shared)
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

rizwan84tx's picture

I apologise for the wrong info and appreciate Marianne highlighting it. In our production setup we dont have seperate media server, out of curiosity installed a test media server and found BPRD does not runs in media server.

C:\Program Files\Veritas\NetBackup\bin>bpps
* TSTBKP2
COMMAND           PID      LOAD             TIME   MEM
bpcompatd        2912        0.000%            0.062  9.3M
nbsvcmon         3836        0.000%            0.125   10M
bpinetd             3864        0.000%            0.093  4.4M
vmd                  3980        0.000%            0.187   10M
bpjava-msvc      4040        0.000%            0.031  3.4M
nbsl                 192          0.000%            0.156   17M
nbrmms            4072        0.000%            0.343   19M
bpps                 836         0.000%            0.031  2.1M

Symantec Private Branch Exchange will not be shown in bpps, you have check that in Services console.

As Marriane stated, check on bpcd test. Also you may check if telnet to media server on port 13782 works.

telnet pmssfss12 13782

Best Regards,

Rizwan

PraveenCH's picture

Looks like pmssfss12 is locally dedined as Master server. Check in Registry for the Servers entry and see if the actual master server is listed on the top. if not put the master server on the top of the list.

This might happen if we give server name a media server name pmssfss12 during installation.

I hope Drives and Robot are visible at OS level on pmssfss12 ?

--Praveen

pruvn's picture

Hello Experts,

To day, I am test restore catalog and Installation Media Server, but this is error I saw. Picture Attached

What should I do? Please help me.

Pruvn.

Scan Tape Library failed 1.jpg
Marianne's picture

See the question above that Praveen asked 10 days ago:

"I hope Drives and Robot are visible at OS level on pmssfss12"

Verify the following on the media server. From cmd, run:

<install-path>\veritas\volmgr\bin\scan

Please also let us know which OS is on the media server, 32 or 64-bit, and which tape drivers have been installed.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

pruvn's picture

1. Here scan command

************************************************************
*********************** SDT_TAPE    ************************
*********************** SDT_CHANGER ************************
************************************************************
------------------------------------------------------------
Device Name  : "Tape0"
Passthru Name: "Tape0"
Volume Header: ""
Port: 3; Bus: 0; Target: 6; LUN: 0
Inquiry    : "HP      Ultrium 4-SCSI  H58W"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "H58W"
Serial Number: "HU19376UNR"
WWN          : ""
WWN Id Type  : 0
Device Identifier: ""
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-5
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Changer0"
Passthru Name: "Changer0"
Volume Header: ""
Port: 3; Bus: 0; Target: 6; LUN: 1
Inquiry    : "HP      MSL G3 Series   7.00"
Vendor ID  : "HP      "
Product ID : "MSL G3 Series   "
Product Rev: "7.00"
Serial Number: "MXA941105A_LL0"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      MSL G3 Series   MXA941105A_LL0"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-5
Number of Drives : 1
Number of Slots  : 24
Number of Media Access Ports: 0
Drive 1 Serial Number      : "HU19376UNR"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape1"
Passthru Name: "Tape1"
Volume Header: ""
Port: 3; Bus: 0; Target: 7; LUN: 0
Inquiry    : "HP      Ultrium 4-SCSI  H58W"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "H58W"
Serial Number: "HU19376UND"
WWN          : ""
WWN Id Type  : 0
Device Identifier: ""
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-5
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Changer1"
Passthru Name: "Changer1"
Volume Header: ""
Port: 3; Bus: 0; Target: 7; LUN: 1
Inquiry    : "HP      MSL G3 Series   7.00"
Vendor ID  : "HP      "
Product ID : "MSL G3 Series   "
Product Rev: "7.00"
Serial Number: "MXA941105A_LL1"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      MSL G3 Series   MXA941105A_LL1"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-5
Number of Drives : 1
Number of Slots  : 24
Number of Media Access Ports: 0
Drive 1 Serial Number      : "HU19376UND"
Flags : 0x0
Reason: 0x0

2. Windows Server 2008 Enterprise 64 bit.

3. All driver for device is OK.

Thank you very much.

pruvn

Rajesh_s's picture

Install the windows drives for the tape drive , its better if you have any old drivers please uninstall and reinstall the latest windows drives and then check .

 Rajesh 
pruvn's picture

Hello everyone,

I was fix this issue. The filewall block two port: 1556, 13724.

Thank you very much.

Pruvn.

pruvn's picture

Hello everyone,

I was fix this issue. The filewall block two port: 1556, 13724.

Thank you very much.

Pruvn.