Video Screencast Help

Messages not archiving

Created: 28 Dec 2012 • Updated: 08 Jan 2013 | 7 comments
This issue has been solved. See solution.

I have Exchange 2007 and 2010 co-existing environment. Last weekend I moved 10 mailboxes from Exchange 2007 to 2010. As per documentation I have configured the EV 9.0.4 and Exchange 2010. For some reason the message archiving does not work on moved mailboxes (sitting on 2010 Exchange server). The can manually archive the messages but the schedule archiving does not work.

Thank you.

Comments 7 CommentsJump to latest comment

Rob.Wilcox's picture

What steps (high level) did you follow?

You say manual archiving works, but scheduled doesn't?  Have you tried a run-now in 'report mode'?  How are you determining that it's not working? Is the task going to a failed state?

rsiddiqi's picture


I created a system mailbox for Exchange 2010

The EV service account already has a mailbox. I simply moved it to Exchange 2010

I ran two PowerShell scripts and they were completed successfully

I assigned send as permission to system mailbox (Added EV service account to system mailbox)

I took a snap shot of mailboxes before I moved them to 2010. There is nothing changed (no item archived) ever since they moved to 2010. As per policy any item older than 45 days should archive. I am getting 2007 mailboxes archived which are older than 45 days.

The run in report mode works. Also, there are reports for exchange 2007 in report folder but nothing for exchange 2010.

Rob.Wilcox's picture

So the run in report-mode works?  What does it say is eligible for archiving?  I mean does it say plenty of items are eligble for archiving?

The task itself isn't set to report mode on the properties of the task?

Have you run a DTRACE, of the archiving task, and looked for a message that you think should have been archived, but wasn't?

rsiddiqi's picture

Here is the data from report file... so as per report every thing looks normal. I have verifed that task itself is not in report mode. I did not try DTRACE. Can you tell me how?

AndrewB's picture
How to run Dtrace to help diagnose issues with Enterprise Vault
padding: 1px;padding-bottom: 3px ;font: 12px Arial; text-align: left;color: #666666; background-color:#f2f2f2">Article:TECH38122 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2;"> |  padding: 0px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2;">Created: 2005-01-01 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2"> |  padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2">Updated: 2012-01-19 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2"> |  padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2">

Article URL


Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner |

rsiddiqi's picture

Thank you very much for all your help. It sounds like archiving start working normally. I noticed provision task failed every time I moved mailbox to new server so I manually trigger it.

One thing still puzzle me is that I do not see reports generated for provision and archiving task. As per setting it should created log files in C:\Program Files\Enterprise Vault\Reports\Exchange Provisioning and C:\Program Files\Enterprise Vault\Reports\Exchange Mailbox Archiving folder everything task executed. They set to run twice a day but no log files are generated.

No issues when the mailboxes were on 2007. There are log files for both tasks and were generated every time then run.

ITDAP_COM's picture

You can run a dtrace for the provision task to see what error you have.

This technote explain what the steps are for move users from one Exchange to another one, it might help you to understand the steps to follow:

How to migrate users from one Exchange server to another

If this response answers your concern, please mark it as a "solution"