Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Microsoft Hyper-V Server (not Windows Server) support?

Created: 11 Jul 2014 • Updated: 14 Jul 2014 | 8 comments
This issue has been solved. See solution.

Hi everyone --

I am trying to get the Windows Agent (for Backup Exec 2014) installed on a Microsoft Hyper-V Server 2012 R2 host. Note that this is the free product from Microsoft, and it is not the same as Windows Server 2012 R2 with the Hyper-V role installed. I'm not sure whether this is even possible or not, to use the Windows Agent. That's the big question I have. Am I barking up the wrong tree?

Through several steps I've got the agent installed, but cannot start the services. Here's the list:

  1. Could not use push installation of agent, for whatever reason. So I copied the RAWSx64 folder from my Backup Exec server to the Hyper-V host.
  2. Ran the setupaofox64.cmd script to install. It appears to complete successfully but complained that Microsoft VC 8.0 x86 runtime could not be installed. (And the Backup Exec services could not be started.) The installer log is attached.
  3. I installed vcredist_x86.exe by copying it to the server, the Event Logs indicated it was successfully installed.
  4. Tried to start the Backup Exec Error Recording Service, and Service Manager again comes back immediately with "Error 1053: The service did not respond to the start or control request in a timely fashion". Some time later, the Event Log shows "A timeout was reached (30000 milliseconds) while waiting for the Backup Exec Error Recording Service service to connect."
  5. I have confirmed that Windows Firewall is shut off by using "Get-NetFirewallProfile" and confirming all three profiles (domain, private, public) are not enabled.
  6. I have confirmed that WMI is working as my network monitoring software is successfully using WMI to fetch metrics about the server.

Any suggestions or troubleshooting would be welcome. It would really suck to have bought the V-Ray Edition licensing just to find I can't use the product on my Hyper-V Server. Everything else about my Backup Exec is working great -- it's just this Hyper-V host I want to add just won't fly.

Thanks in advance for any suggestions.

 

Operating Systems:

Comments 8 CommentsJump to latest comment

pkh's picture

Why can't you push the remote agent to this host? What are the error messages?

VJware's picture

Open a cmd and browse to the Backup Exec directory on the host. Run the below command and paste/PM the output.

beremote.exe -console

pkh's picture

The Hyper-V Server is running a Core OS, so there is no GUI.

VJware's picture

If I recall, PS and cmd can be run from core OS's as well.

numindast's picture

VJware: here's what I get... which is to say, nothing :(

C:\Program Files\Symantec\Backup Exec\RAWS>beremote.exe -console

C:\Program Files\Symantec\Backup Exec\RAWS>
numindast's picture

pkh: "could not connect" when trying to do a push install. I knew there were ways to manually run the installer so I did not spend a lot of time troubleshooting.

VJware: Absolutely correct, in fact you must use PowerShell and command prompt stuff to administer the server. There's not much other way to configure things.

 

numindast's picture

Well, I made some progress. I managed to reboot the host early this morning (that's a chore and a half with all its virtual machines) and after tinkering for a while, managed to uninstall the agent with:

c:\temp\rawsx64\Install\Media>msiexec /uninstall "Symantec Backup Exec Remote Agent for Windows Systems.msi"

Then I was able to remote push-install the agent from my Backup Exec server. The reboot must have been the key to the solution. It just sucks to reboot my host due to the guests it has on it.

However, the next problem was that the service "Backup Exec Error Recording Service" had been set to Disabled and hadn't gone away when the uninstall happened. So when the re-install did its thing it could not create this service again. When I tried setting it to Automatic Start from Disabled, Windows threw a message "The service is marked for deletion". With more Google research, it turns out the uninstall wanted another reboot in order for Windows to fully remove the service. I probably should have waited until rebooting a second time before re-installing.

numindast's picture

Update: I re-uninstalled the agent as described in my earlier post. I performed (yet another) reboot and on restart, was able to remote deploy the agent, and now my Backup Exec server is successfully talking to the hyper-V host!

Success. Thanks everyone for the help.

SOLUTION