Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Microsoft Visual C++ Runtime Error! SAV client fails to start

Created: 05 May 2008 • Updated: 21 May 2010 | 20 comments
pcsteam's picture
This issue has been solved. See solution.
Hello,
 
Recently I started to get the following error when starting Symantec Antivirus client ver 10.1 on my laptop.
 
"Microsoft Visual C++ Runtime Library
Runtime Error!
Program: C\Program Files\Symantec AntiVirus\Rtvscan.exe
This application has requested the Runtime to terminate it in an unusual way.
Please conrtact the application's support team for more information."
 
I have uninstalled through Add/Remove programs as well as manually and scan for spyware without any change.  The program starts, the icon shows in the system tray at startup, the error occurs and the AntiVirus service terminates.  No new programs were installed recently.
 
Thanks for your help.

Comments 20 CommentsJump to latest comment

cmartinjr's picture
Didn't find too much on it.  Here's one link:
 
Some of the other things I saw was that issue may have existed in 10.1.5.5000, so I'd try running 10.1.7.7000 on that workstation to see if the error goes away.
Josh Mitchell's picture
We are experiencing the same problem even though I upgraded to 10.1.7.7000.
 
It keeps crashing, and also Auto-Protect will not activate. I need this resolved asap, as client needs to get working! :)
 
I have tried upgrading the Microsoft Visual C++ 2005 SP1 Redistributable, but it made no difference.

Also the operating system is Windows XP Home SP2.
 
Cheers, josh
normank's picture

I wanted to bump this as I am experiencing the SAME problem on one Windows XP workstation in a domain. It may have something to do with Windows firewall (even though I've opened up the correct port and enabled RTVScan); System Center can't install remotely on this workstation when the firewall is up but can when it's down; however, regardless, I get this message after install. Client can't communicate with server either.

 

Did you ever resolve this?

 

Thanks.

 

 

csdann's picture

We're experiencing the same problem here at the University of Central Florida.  It's not an all out rampant issue that's affecting 100's of computers but it is starting to appear on more machines.  As soon as the computer boots into windows the Runtime Error box will come up about 2-3 times and then it's gone.  I have yet to narrow down exactly what is causing it but I will post if we find anything.

Putt's picture

We are gettng the same message on just a couple computers.  We are running ver 10.1.6.  Will try calling their support dept on Monday.  If I find a resolution, I'll post it.

scream[wdk]'s picture

Have not much time, and already spent almost all of it registering here. So I'll be short speaking:

 

delete existing instance of WMI object root\securitycenter:AntivirusProduct using "wbemtest" utility or any  utility you like from "WMI Tools" package. Then reinstall Symantec product and feel happiness.

 

Seems to me, Symantec AV has problems installing into systems, where have already registered "root\securitycenter:AntivirusProduct" instances, that uses "null" values for some properties.

 

Detail by pm

{Personal content removed to prevent spam}

Message Edited by IanSee on 11-26-2008 01:26 PM
DavidAtWork's picture

scram[wdk] you nailed it.  Thank you for helping me fix this problem.  Up until your post I was not aware of wbemtest so it took me awhile to figure out what to do with it.

For the sake of those you may have this problem in the future, here are the steps that corrected my issue:

• Go to a command prompt and run wbemtest
• Click the Connect button
• Replace root\default with root\securitycenter and click Connect
• You will be returned to the original screen, now click the Enum Classes button, leave the Superclass info box that appears as is (empty) and click OK
• On the Query Results screen, highlight AntivirusProduct and choose the Delete button.
• Close the Query windows and exit wbemtest
• Now either reinstall or repair Symantec Antivirus Corporate Edition

Interesting note, in my case when I re-entered the wbemtest after fixing my problem, the AntivirusProduct class no longer existed, even after a reboot. I can only guess this was a remnant of an older Symantec AV product or some other software package placed it there and it was causing a conflict with Symantec AV.

SOLUTION
ronpaar's picture

This worked beautifully for me on a laptop that was infected. After following your steps, I was able to reinstall Symantec AntiVirus 10.1.7.7000 and perform a full scan.

Thank you.

Wylde Tech's picture

Thank You>>>>>> almost imaged the workstation, this happened after removing a nasty peice of Malware with Malwarebytes.

BillWCH's picture

Yes - this is what works - interesting that others mentioned it happened AFTER using malwarebytes to remove an infection - which was the case with one of my workstations.   Perhaps it is that trojan - only of those phoney AV products - that CAUSES the issue because it attempts to disable Symantec.   Also, after the fix & reinstall of Symantec - Windows Security Center no longer recognized Symantec AV as being installed.

conley's picture

DavidAtWork and scram[wdk] you both helped a lot.
Much thanks,
conley

Ajit Jha's picture

I guess this this is a faulty application error. just re-install the pakage

Regard's

Ajit Jha

Technical Consultant

ASC & STS

Frank019's picture

Thank I also had this error but you same me the trouble of formatiting the PC.

Vikram Kumar-SAV to SEP's picture

Marking  Davis's comment as solution so that it will be easier to find this post.

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

jonathan_hebert's picture

I ended up not needing to perform the repair install, which was fortunate because I didn't have the install disks handy.

Thanks!

almenkes's picture

 Thanks to Scream and David for getting this one - worked like a charm, didn't even have to reboot.

Absoblogginlutely's picture

Same issue on v11.0.5 but this only fixes it for about a week. Uninstall/reinstall doesn't help either. Another current thread at https://www-secure.symantec.com/connect/forums/smc... may have additional guidance as this has more active 11.05 client issues.

KSADrew's picture

Was having a problem of event id 7031 on a workstation.  Did a clean install, but kept getting the error.  Followed this solution, and ti worked.  Client is running Endpoint Protect v 11.0.780.1109 (11.0.3001).  Just an FYI.