Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Migrating one EV server in to a new clustered environment - what's the best way?

Created: 20 May 2013 • Updated: 21 Jun 2013 | 11 comments
Sani B's picture
This issue has been solved. See solution.

Hello again,

As the title tells you, I'm planning to have my old EV both upgraded from version 9.0.3 to 10.0.3 version and migrate it to run on new set of 2 nodes clustered servers...  The SQL is already in a separated clustered environment and the archives are stored in centera that will also remain the same location... all servers are already 2008 r2 64bit so there is no need to worry about the migration of the platform from 32bit to 64bit...

In what order should I do this and which directions to follow? Can anyone advice me on this one?

Thanks in advance!

Sani B.

Operating Systems:

Comments 11 CommentsJump to latest comment

TonySterling's picture

You can use the Server Settings Migration Wizard.

Enterprise Vault Server Settings Migration wizard

Enterprise Vault Server Settings Migration wizard
HOWTO42445 | 2013-05-15
How To | CMS-XML

Migrating clustered servers

If you migrate clustered Enterprise Vault servers, you must deploy the target servers in a new cluster. Refer to the Enterprise Vault documentation, which contains the information you need to configure prerequisites and install Enterprise Vault in a cluster.

During the deployment of the new cluster, you can attach to the target servers the data locations that were used by the source servers, with the following exceptions:

  • In both Microsoft Cluster Services and Veritas Cluster Services, you must create a new data location for the MSMQ queues. Do not attempt to use the MSMQ data location that was attached to the source servers.

  • In Veritas Cluster Services, you must create a new data location for the RegRep resource. Do not attempt to use the RegRep data location that was attached to the source servers.

SOLUTION
Advisor's picture

Yes I echo Tony, server settings migration wizard should help.

Sani B's picture

About the MSMQ settings, I now have Cluster service for Enterprise vault set. And I ran the deployment scanner, it's complaining about the msmq queues being in the original C:drive this normal or am I missing some step where I was supposed to do something to move the location?

And how do I get to do the steps:
24- Now, Cluster service for Enterprise vault is set. We can deploy Enterprise Vault Application to two nodes. Before this you should use “prepare my system” and “deployment scanner” for a proper installation.

25- You can find both of these tools from EV Install Launcher as shown below.

deploying the EV to two nodes and use the "prepare my system", did not see that option trying to run the setup.exe istalling the EV server...

Sani B.

Sani B's picture

And another question, when you first install the 1# EV server, is it to the active node or passive node? and when this is done do check the activity to the other node and then install the 2# server or can it be the unactive when the installation is happening? And why would the second installation complain that it could not install the directory and the installation fails..? missing some step there as well?

Sani B.

Sani B's picture

And yet another, in basic one server to another migration the importing migration packade is done right after the EV server has been installed BEFORE you do any configuring etc... Is this the same when I import the package to a primary node where I have "empty" EV server installation as well and does the "make this a cluster server" settings come after importing the migration package?? So that for a brief while the 1# node is just one ev server until I somehow turn it into a clustered one??

 Sani B.

Sani B's picture

Figured out why the second installation did not go through so that's solved but is there anyone who can help me with the migration questions etc... ??

Sani B.

Sani B's picture

From this guide:
https://www-secure.symantec.com/connect/articles/s...

I have completed step 27... now what? Do I just import the migration package to the primary node and after the migration somehow convert it in to a cluster OR is there a section in migration that asks if this is a cluster? OR shoud I do now something to make the ev installation know that it is part of a cluster and is in a node1...??

TonySterling's picture

You are now ready to import the migration package on the primary node.  The SSMW should realize it is a cluster and take care of things.

Sani B's picture

When I do this should the MSMQ in the cluster be online or still off as it stated at one point not to bring it online just yet...?