Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Migration Tool Can't Connect to Directory

Created: 05 Dec 2013 • Updated: 10 Dec 2013 | 9 comments
This issue has been solved. See solution.

I ran through a test migration/upgrade from 9.0.4 to 10.0.2 in my lab today.  Everything seemed to work OK, and all checks and steps passed.  However, now that I'm on my new 10 server, I can't open the admin console, and am getting this event repeatedly logged:

 

Event ID 8623

Cannot connect to the Enterprise Vault Directory service.

Check the Enterprise Vault event log on OLDSERVERNAME.domain.com to find the cause of the problem.

 

I am using an alias, so nothing should be pointing to this name.  My alias DNS entry has been updated, and is pointing to the new server.  Up until about 2 weeks ago, my lab was not using an alias, so I ran through this KB to change it: TECH179428.

Any ideas before I open a support case?

Thanks!

Operating Systems:

Comments 9 CommentsJump to latest comment

TonySterling's picture

Are the EV Services running?

What other events do you have?

When you imported the migration package did it complete successfully?

Are you using a hostfile?

BrianInMD's picture

The services are running.  The only other event is 40975 (attached).  The two events keep repeating themselves constantly.

No errors during the migration package.  I took screenshots so I could refer to them later, and have verified every step said successful.  There was one part of the import process with the migration wizard that has the old server name and could be related to the issue - screenshot attached.

No hostfile.  I tried a hosts entry pointing the old server name to the new IP, but it didn't seem to make any difference.

I opened a case but the first technician didn't have any ideas.  He took a deployment scanner report and is reviewing.

For clarification, STVAULT is old, TESTVAULT is new, and EVServer is the alias.

Thanks!

40975.jpg 8623.jpg migrationwizard.jpg
GabeV's picture

Hi Brian,

It looks like the Enterprise Vault indexing service is trying to get the settings from the old EV server. Since this is an EV 10 environment, could you try stopping all the Enterprise Vault services, then run the following SQL query in the directory database:

UPDATE IndexingServiceEntry SET IVSyncNeeded = 2

and start the services again? That setting should synchronize the index volume metadata. Let us know if that helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

BrianInMD's picture

Gabe,

Thanks for the feedback.  When I ran that, I got:

Msg 207, Level 16, State 1, Line 1
Invalid column name 'IVSyncNeeded'

Regards,

Brian

GabeV's picture

That's odd. In Enterprise Vault 10 installations, you should have a column with that name in that table. Are you sure that the databases were updated correctly? Can you run this query and post the output?

SELECT * FROM IndexingServiceExtry

 

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

TonySterling's picture

Almost sounds as though the EV DB wasn't updated.  Can you share the results of this?

USE EnterpriseVaultDirectory
SELECT SchemaVersion
FROM DirectoryEntry

USE EnterpriseVaultDirectory
SELECT SchemaVersion
FROM VaultStoreEntry

and

from the registry [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install]
"Version"

How to find Enterprise Vault version information

Article:TECH70211  |  Created: 2009-01-03  |  Updated: 2013-10-16  |  Article URL http://www.symantec.com/docs/TECH70211

 

BrianInMD's picture

9.43.3.45

9.16.1.25

10.0.2.1112

So yea, it doesn't look like any of the DB information updated.  This almost makes sense to me though as wouldn't that not happen until the DB is accessed for the first time by the new 10.x server?  Since it hasn't been able to connect yet, would the DB update still be pending?

TonySterling's picture

So after the import of the migration package you should have followed the Upgrading EV steps and started the EV Admin and EV Directory service.  Then the EV Directory DB would have been updated.

You said earlier you added a hostfile entry for the old server to point to the new, is that still there?

Could you verify it is right, stop all the services, and just start EV Admin and EV Directory?

SOLUTION
BrianInMD's picture

Well don't I feel silly.  Between the hardware migration guide, 10.x upgrade guide, readme's, and release notes, I didn't put everything together.  Starting the services in the correct order did the trick, and I'm up and running.  Thank you for once again for your assistance!