Video Screencast Help

Min queue disk bytes free limit reached

Created: 29 Dec 2009 • Updated: 21 May 2010 | 33 comments
571202126's picture
This issue has been solved. See solution.

Brightmail gateway 8.0.3 Vmware.

I am getting the below error. Eventually the server will stop accepting emails. Queue full

Min queue disk bytes free limit reached. queue=inbound free_blocks=124305 limit_blocks=128000
Min queue disk bytes free limit reached. queue=delivery free_blocks=127958 limit_blocks=128000

Discussion Filed Under:

Comments 33 CommentsJump to latest comment

TSE-JDavis's picture

You should give the VM Image more disk space. How much did you allocate when you built it?

571202126's picture

20Gig. it is a scan /incoming only server

TSE-JDavis's picture

Yeah, the recommendation is 60Gb, and the bare minimum is 30Gb, per the Getting Started document attached to this KB:

Title: 'Symantec Brightmail Gateway 8.0.x series support for VMware'
Document ID: 2009032513455554
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/...

You should consider an OSRestore onto an image with at least that much if not more. Once the hard drive fills up MySQL becomes unstable and you can see table corruption.

571202126's picture

I will try that. I think I can backup the image and after restore I can change the size. I am not an expert at VMware.

TSE-JDavis's picture

Here is a copy/paste of the system requirement table in the quick start guide:

571202126's picture

Looks like using the recommend setting fixed the problem. Thank you for your help.

Fred

571202126's picture

I upgrade the storage for the Control server to 100gb. It worked fine for a few days. Started giving problems.

When I tried a reboot the MS-SQL would not start.

Any help

TSE-JDavis's picture

What method did you use to give the control center a larger hard drive?

571202126's picture

In VMWare I backed up the guest the restored it with bigger drive.

TSE-JDavis's picture

Log in as the support user and change directory to the root and then run 'df -a -h' and paste in the output here for me to look at. I'm not sure that the procedure you used works with our appliances.

571202126's picture

How do you login as super use. I can login as admin

571202126's picture

I had to restore from a backup image. Will this command disterb anthing.

TSE-JDavis's picture

You would use the 'set-support' command and assign an appropriate password.

TSE-JDavis's picture

The command to check free space is " df ". You will want to add the -h and -a modifiers to get the most information in a human readable format.

571202126's picture

I understand but still get -rbash.  BMI>df -h -a   ==== -rbash: df:c ommand not found

TSE-JDavis's picture

Did you log in as the support user?

571202126's picture

Yes. Loged is as admin, then I used the set-support command. I asked to set a password.

571202126's picture

Figured it out. Had to log out then log back in as support and new password.

See attached.Untitled-1.jpg

TSE-JDavis's picture

You need to change directory to the root by using the following command: cd /

Then run the df -h -a command

TSE-JDavis's picture

The size totals up to 18.7Gb. You need to do a reinstallation on a new VM with a hard drive size of at least 30Gb, if not the 60Gb we recommend.

You can do a backup of the settings and then import them back in so you will be able to retain everything on the old server.

I checked with a few people and that process you went through would not tell the OS of the new disk size, it would have only known about 20Gb still.

SOLUTION
571202126's picture

if I do a Sys-info it show 100GB.

So If I go into Administration, Version, backup, full backup.(to FTP site) it is ok. Or do you think I should do it another way.

TSE-JDavis's picture

Yeah, if you have an FTP site available you will want to backup there so you can restore it after you do an os restore.

571202126's picture

I have gotten a backup yesterday.

Now I get.
Cannot backup the database on the remote host.
ERROR: There is not enough drive space available to perform the backup. Space Required: 3893640 kb

The FTP site is working, and it have lots of space.

571202126's picture

I was able to get a backup after I cleared all the report data. I am restoring and it is taking now over 15 Minutes.

TSE-JDavis's picture

Yeah, its pretty apparent that the hard drive is still full if it couldn't even make the backup. It has to save the file locally before it can transmit it to the FTP server.

571202126's picture

Looks like the restore worked well. Keeps coming up with the add scanner wizard.

How do I remove that.

One more question.

If I want to redo the scanners can I just reaload the scanner or do I have to remove them from console then reinstall.

TSE-JDavis's picture

You can do a 'clear osconfig' and then set it as scanner only when that question comes up, no need to remove it from the console

John_H's picture

In the event that you find yourself with low disk space you can reference the following document.

Title: 'How to free up disk space on Symantec Brightmail Gateway (SBG) appliance'
Document ID: 2009101317270554
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/...

I noticed that you mentioned that you were also having trouble with the Add Scanner Wizard.  At what point do you see this error?  Is it when you first log into the ConrtrolCenter?  Depending on the issue you may want to remove the scanner from the ControlCenter and re-add it.  Below are two documents with information on upgrading/adding scanners.

Title: 'Reconfiguring a scanner to be used by a new Control Center'
Document ID: 2004123107502763
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/...

Title: 'Best practices for software updates on Symantec Brightmail Gateway Appliances'
Document ID: 2007816671907998
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/...

T