Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Missing Enterprise vault TAB in Outlook 2010

Created: 09 Jan 2013 • Updated: 15 Jan 2013 | 14 comments
This issue has been solved. See solution.

Hi

I am missing the Enterprise vault TAB in outlook.

This is the log file:

09/01/2013 13:41:38.727[5160][H]: Log file created (level 1).

09/01/2013 13:41:38.728[5160][H]: Loaded UI Language Path: c:\program files\enterprise vault\evclient\languages\en

09/01/2013 13:41:38.730[5160][H]: Loaded Help Language Path: c:\program files\enterprise vault\evclient\languages\en

09/01/2013 13:41:38.732[5160][H]: Module path: C:\Program Files\Enterprise Vault\EVClient\Valkyrie.dll

09/01/2013 13:41:38.733[5160][H]: No language resource module was loaded, the default English resources in Valkyrie.dll will be used

09/01/2013 13:41:38.735[5160][H]: RPC over HTTP is not enabled (flags = 0)

09/01/2013 13:41:38.737[5160][H]: A std::exception has been caught: Attempting to use a Non-Exchange message store

09/01/2013 13:41:40.862[5160][H]: FUI: Not loading UI as action map is empty.  Is the user enabled?

09/01/2013 13:41:41.927[5160][H]: IDispatch::GetIDsOfNames("MessageClass") failed, error 80020006

The cause is that we disable the use of Outlook cached exchange mode by the windows policy, setting this key

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Cached Mode

Dword: Enable

Value: 1

We set this key to prevent the creating of an OST file in outlook

Why is it that vault doesn't load up and how can this be changed.

Windows 7 / Outlook 2010 SP1

Enterprise Vault version 10 sp1 client

Jan

Comments 14 CommentsJump to latest comment

JesusWept3's picture

So are you saying it works when you disable the OST?
Normally I've seen this when they put the default delivery location of mail to a PST instead of their regular mailbox and thus EV cannot read the hidden message

Other times i've seen it where the OST itself can't download the Hidden message and you have to use ScanOST (for Outlook 2003/2007) or a repair in Outlook 2010

But i've never seen an issue where Non-Cached Outlook doesn't work but Cached Outlook does, except when they use PST as the default delivery location

Rob.Wilcox's picture

Remember: In Office 2013 you can no longer have PSTs as the default delivery location.  So in order to prepare for the future, if that's what you've got setup, then unset-it-up :)

I think you have the registry key slightly the wrong way around too.

It should surely be:

Enabled = 0, to disable the cached mode?

Have you got a screenshot of the Outlook Profile showing the message stores?  The screen with lots of tabs, starting E-mail, and then list of Email accounts.  Is Microsoft Exchange the first one?  Is it set to default?

SOLUTION
JA ressiv's picture

Yes, only changing the registry key to 0 is enough to get it working.
But that is not what i want, we use vdi with floating desktops and we don't want the OST files on there.

We are currently in a migration to office 2010 and we use the vault client 10.1

We didn't see this behavior in Office 2003 with client version 8

Rob.Wilcox's picture

Still confused.

I have just set the registry key to 0, to disable cached mode... And the Outlook Add-in works fine on Outlook 2010.

So..

a/ please confirm what you're testing

b/ screenshot as previously requested

The registry key doesn't have any effect on EV on Windows 7 SP 1 with Outlook 2010 SP 1

JesusWept3's picture

I am confused as well as the registry you stated, like rob pointed out would enable cache, not disable it and changing it to 0 would give you what you were after all along (no OST)

JA ressiv's picture

When you set the key to 0 is works, but as i mentioned it doesn't work when the key is set to 1 There is only one row in that screen shot, my email account and type Microsoft Exchange (send from this account by default)

1= disable -> no evalut tab

0=enable -> evault tab

1.png 2.png
Rob.Wilcox's picture

Okay, you've still got the things the wrong way round.

'Enable' = 0 means Cached Mode is disabled.

i.e.you are online with Exchange.

You say that this works in that you do have an Enterprise Vault tab?

'Enable' = 1 means Cache Mode is enabled.

i.e. you are going to use an OST file, in cached mode, to talk to Exchange.

You say that this doesn't work in that you do not have an EV tab?

JA ressiv's picture

I have to check some settings, it could be that the are two settings for preventing ost files

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Cached Mode
Dword: Enable
Value: 1

and this one
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\ost
dword: noost
2

Rob.Wilcox's picture

Okay so the NoOst registry key set to 2, disables offline/cached mode.

So..  why are you then setting the 'Enable' key to 1?

I get the same behaviour as you have described if:

Enable = 1

NoOst = 2

I fix it...

Enable = 0

NoOst = 2

So I think you have a few options ..

Enable = 0, no noost key

Enable = 0, NoOst = 2

JA ressiv's picture

There is one way to prevent the creation of OST files.

Do Not allow an OST file to be created

is equivalent to clicking the Disable Offline Use button in the Offline Folder Settings dialog box.

and this one
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\ost
dword: noost
2

And Enable Cached mode for own mailbox

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Cached Mode
Dword: Enable
Value: 1

But you cannot mix those settings, so the last setting must be 0

So that was the solution

Rob.Wilcox's picture

Perhaps one (or more) of the posts here can be marked as the solution, when you have a spare moment?