Video Screencast Help

Missing folders from Archive Explorer

Created: 14 Jan 2013 • Updated: 16 Jan 2013 | 4 comments
This issue has been solved. See solution.

One of my clients is having a strange problem.  Some of her folders are missing from the archive explorer.  From Outlook, we can search and find the emails she is looking for, but the folder information is missing from the search results.  We can access the archived emails but we cannot restore them to her mailbox.  It says "Restoration of the basket by the Shopping Service failed". 

We have tried to look at the database as per and the missing folders are not there.  There is no discrepancy between the database and the treeview.  As if the folders never existed, but Evault still has the archived emails.

Those folders are also missing from her Outlook.  She claims she never deleted any of those.  I don't think that part is Evault related since Evault does not delete folders from Outlook and none of the items are due to expire.

Any suggestion will be appreciated.

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

JesusWept3's picture

Do you use DeleteEmptyFolders registry key per chance? and does the user have Virtual vault or ever used it?

What i can imagine is something like the following

1. DeleteEmptyFolders is in use
2. Moved Items is not enabled in the mailbox policy
3. User archives bunch of email in \Inbox
4. User moves shortcuts from \Inbox to \My Folder
5. User double clicks shortcut in \My Folder\ and the item opens
6. User opens up Archive Explorer and tries to go \My Folder but it doesn't exist
7. If the user was to look in the original location the item existed, then they would see the items that are missing

So theres a couple of things you can do to verify it

1. Open up http://yourEVServer/EnterpriseVault/Search.asp?adv...
2. Enter some criteria to find the item
3. From the search results, you will see the folder that it belongs to in the results pane

Another thing you can do is select the shortcut, if you have the banner saying "This document has been archived. View The original here", right click the Link  and go to Copy HyperLink

The link will look like
http://yourEVServer/EnterpriseVault/ =12BD62B8A28F48A49CE6F8993ED5E811100000yourSite&SavesetId=201212044662079~

Copy out the long string between the last tilde (~) and the &attachmentID to a notepad
i.e. F07CA8A9CC75280018FCE4fCB1AE9681

Convert it to an IdTransaction format that is stored in the database
The format is 8 characters followed by a hyphen, then 4 characters, hyphen, 4 characters, hyphen, four characters, hyphen, 12 characters (i.e. 8-4-4-4-12)
for example F07CA8A9-CC75-2800-18FC-E4fCB1AE9681

Then with this TransactionID run the following query from the users vault store

SELECT A.ArchiveName "Archive Name",
       AF.FolderName "Folder Name",
       AF.FolderPath "Folder Path",
       S.IdTransaction "Transaction ID",
       S.ArchivedDate "Archived Date",
       S.IdDateTime "Sent/Received Date",
       S.ItemSize "Item Size"
FROM   EnterpriseVaultDirectory.dbo.Archive A,
       EnterpriseVaultDirectory.dbo.Root R1,
       EnterpriseVaultDirectory.dbo.Root R2,
       EnterpriseVaultDirectory.dbo.ArchiveFolder AF,
       yourVaultStore.dbo.ArchivePoint AP,
       yourVaultStore.dbo.Vault V,
       yourVaultStore.dbo.Saveset S
WHERE  S.VaultIdentity = V.VaultIdentity
  AND  S.ArchivePointIdentity = AP.ArchivePointIdentity
  AND  AP.ArchivePointIdentity = R1.VaultEntryId
  AND  V.VaultId = R2.VaultEntryId
  AND  R1.RootIdentity = A.RootIdentity
  AND  R2.RootIdentity = AF.RootIdentity
  AND  S.IdTransaction = 'F07CA8A9-CC75-2800-18FC-E4FCB1AE9681'
Gogeta's picture

Thanks for the response.

We don't use DeleteEmptyFolders registry key.  Moved Items is enabled in the mailbox policy.  The scenario you gave was the first thing we checked.  It doesn't seeem to be the case.

When we did a search, the folder info we are supposed to see is blank, nothing.

We have modify your query because there seems to be a type mismatch somewhere.  Anyway, the result shows the Folder Name is "Top of Information Store" and the Folder Path is blank.  So it is one level above "Inbox"?

Any idea how could that be?  Is there a way to recover the folder path?


JesusWept3's picture

Sorry, you're right

It should have been AP.ArchivePointId = R1.ArchivePointId
and NOT AP.ArchivePointIdentity

Anywho, if it shows Top Of Information Store, this is the mailbox root.
So it typically means the items were archived under "Mailbox - your name"
In Outlook this is default to show a home screen, but you can copy items there if you wanted to.
If you wanted to see the contents you'd right click "Mailbox - your name" go to properties then the Home Page tab and uncheck "Show Home Page By Default"

That being said, to see the items in Archive Explorer, open up AE, expand out your mailbox and rather than clicking \Inbox or \sent items, just click the archive name and in the right hand side the items should show up

So its not a case of having it "recreate" the folder, because the folder shouldn't be missing UNLESS you had the looping folder issue and applied the Archive Folder Fix

Gogeta's picture

That exactly what happened.  All the missing items are found in "Mailbox - your name".

Thank you very much for your help.