Video Screencast Help

Missing New > Editable Data Class option

Created: 02 Jul 2014 • Updated: 07 Jul 2014 | 6 comments
Lark's picture
This issue has been solved. See solution.

I'm looking at a SMP that is missing the New > Editable Data Class option in the context menu.

Navigating to "Settings > Resource and Data Class Settings > Data Classes > Inventory > Custom", if I right click on that folder I only see the other usual options in New of : Folder, Item Link, Virtual Data Class and Web Link.    New > Editable Data Class is not visible.

A little more info:

  • I am using an account in the "Symantec Administrators" role.
  • CMS and SMS Suites are installed and running with no major issues
  • There are no errors in the logs when I do this.
  • I'm able to clone existing data classes.
  • I can use the "Manage Custom Data Classes" option to create inventory based data classes.
  • This SMP has been upgraded from 7.1 SP1 all the way to 7.5 SP1 recently but the issue existed on the original 7.1 SP1 install.

Has anyone seen this?  Is there a way to restore this kind of context item?

Operating Systems:

Comments 6 CommentsJump to latest comment

Lark's picture

I think I know the answer to this - CMDB solution is not included in CMS or SMS and this adds this functionality.  I'm not clear why Add Virtual Class would be in CMS/SMS though!

Igor Perevozchikov's picture

Hi,

here something about data class edit http://www.symantec.com/docs/TECH218183

I have upgraded ITMS 7.5 from 7.5 HF6 to 7.5 SP1 and I have this option

EditDataClass.jpg

AFAIR, CMDB should be included in CMS 7.5, but it isn't available as separate installed product on "First Time Setup" portal page.

  • Check location ⇒ C:\Program Files\Altiris\CMDB\

Try to check does all required privileges/permissions are available for Administrator role for "Data Classes"/"Custom" folder.

Thanks,

IP.

iddqd idkfa idclip

Lark's picture

I thought CMDB Solution was included with CMS too but it would seem this is not the case with a CMS 7.5 SP1 clean install.

I installed CMDB solution and the "Editable Data Class" option came back.

I'm still not sure why the "Virtual Data Class" option was already there.  The database was from several versions back and had been through multiple upgrades to get to 7.5 SP1.  Perhaps CMDB had been installed at some point on one of those versions.

Igor Perevozchikov's picture

"New Virtual Data Class" action was available for use, because it relates to "Inventory Solution" product:

Product Name: Inventory Solution
Folder: \Settings\Notification Server\Resource and Data Class Settings\Data Classes\Inventory\Custom

"Editable Data Class" action, seems like requires CMDB installed.

iddqd idkfa idclip

SOLUTION
Lark's picture

Thanks for your input Igor!

Igor Perevozchikov's picture

Seems like I was wrong about "New Virtual Data Class" action, because:

If I'll create New Virtual Data Class via mouse right-click menu on "Custom" folder of Inventory Solution product, then this new created Data Class will has product "Inventory Solution".

If you will create it on another folder of another solution, then this new Data Class will has another product registered as expected.

 

Summary:

"New Virtual Data Class" action relates to "Symantec Management Platform" product, according to context help menu in SMP Console.

Creating a virtual data class

Symantec Management Platform

Virtual data classes let you integrate third-party system data with the Symantec Management Platform CMDB without the need to import the data into the CMDB.

 

"Editable Data Class" action relates to "CMDB" solution product, according to context help menu in SMP Console:

Creating a custom data class

CMDB

To create a custom data class

  1. In the Symantec Management Console, on the Settings menu, click All Settings.

  2. In the left pane, expand Notification Server > Resource and Data Class Settings > Data Classes > CMDB Data Classes, right-click the folder where you want to create a custom data class, and then click New > Editable Data Class.

iddqd idkfa idclip