Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Missing Software Package

Created: 20 Dec 2012 | 7 comments

I imported a software package into ITMS yesterday, and now I can't find it. I know that it showed up at one point under Software Releases in the Manage Software screen of the Management Console, but it no longer shows there. I have also checked under Software Products, Software Updates, Newly Discovered Software, Installed Products, and even in the Software Catalog but cannot find it. I know it hasn't been deleted, because I have it attached to a managed software delivery policy. I also tried re-importing the msi file and was prompted to update an existing title. So I know it's still present, but I can't locate it.

Any suggestions where else this package might be hiding?

Thanks.

Comments 7 CommentsJump to latest comment

AngelD's picture

Can you locate (search) it in Manage > Resource?

sirNARVY's picture

Yes, I found it there. I'm able to open it in Resource Manager from that search. If I select Edit Software Resource from Resource Manager I get to the Software Resource Editor, where the package shows it is a Software Release. So I still don't get why it's no longer showing up under that filter from the Manage Software UI. Any thoughts on how I might make it appear there again?

Thanks!

andykn101's picture

 Right click > Properties from Resources and see where the folder path is. If it's "\Resource Management\Resources\Software Management\Software Resources\Unassigned" then you have the same problem I had.

Create a new Software Release manually and use right-click > Actions > Resolve duplicate software resources. Select "Merge into one software resource and delete the duplicate software resource" Use your missing one as "Duplicate software resource to be merged or associated:" and your new one as "Software resource to be merged to:".

You'll need to remove the original one from the Policy first. You might want to right click > Actions > Detailed export it - I've had merges bomb out with spurious "Access denied" errors having deleted both Software resources to be merged but not created the Merged resource.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

AngelD's picture

Sorry, don't have an answer for you...seen that happen once before.

Remove it (select it in Resource window and then on the left side you have the Delete action) and re-add it again and see if that helps.

sirNARVY's picture

Thanks all for the responses. I ended up deleting and re-importing the package per Angel's suggestion before I saw Andy's idea. I am going to keep that note in my back pocket though, in case this comes up again.

Thanks again all!

sirNARVY's picture

Okay, my second package I imported has now also disappeared. I found it again by searching from Manage\Resource. In Resource Manager I see the Folder path as \Resource Management\Resources\Software Management\Software Resources\Releases, so it hasn't been orphaned into "Unassigned".

I guess I'm still trying to find out why it keeps disappearing from the Software Releases list and how to get it to show up there again.

Thanks.

AngelD's picture

Do you find anything in the altiris log viewer if you search for the Guid of the Software Resource?