Video Screencast Help

Missing_path

Created: 06 Nov 2013 • Updated: 12 Nov 2013 | 15 comments
tarmizi's picture
This issue has been solved. See solution.

Hi all,

One of my customer have this IBM TS3310 tape library with 6 drives where 3 of them showed as down and in drive path showing "MISSING_PATH". My customer reported to the IBM technical support to check but the result show there are no problem related to those drives. For my part, I done reinstalled all device driver, re-Configure Storage Devices including restart both tape library and master/media server but still no go. So my questions are:

1. What might be the cause to the "MISSING_PATH"?

2. If they might have replaced a tape drive long time ago, should be there anything to be done in netbackup?

3. Which log should I refer?

4. Please take a look at this result from scan -changer  and  tpautoconf -report_disk, why do the serial number different?

C:\Documents and Settings\rdpadmin>scan -changer
************************************************************
*********************** SDT_CHANGER ************************
************************************************************
------------------------------------------------------------

Device Name  : ""
Passthru Name: ""
Volume Header: ""
Port: 3; Bus: 0; Target: 1; LUN: 1
Inquiry    : "IBM     3576-MTL        587G"
Vendor ID  : "IBM     "
Product ID : "3576-MTL        "
Product Rev: "587G"
Serial Number: "000001311856_LLA"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     3576-MTL        000001311856_LLA"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-3
Number of Drives : 6
Number of Slots  : 120
Number of Media Access Ports: 6
Drive 1 Serial Number      : "1310177013"
Drive 2 Serial Number      : "1310177029"
Drive 3 Serial Number      : "1310034409"
Drive 4 Serial Number      : "1310212273"
Drive 5 Serial Number      : "1310035164"
Drive 6 Serial Number      : "1310214440"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------

C:\Documents and Settings\rdpadmin>tpautoconf -report_disc
======================= Missing Device (Drive) =======================
 Drive Name = IBM.ULT3580-TD4.000
 Drive Path = MISSING_PATH:{3,0,2,0}:1310035197
 Inquiry = "IBM     ULT3580-TD4     A232"
 Serial Number = 1310035197
 TLD(1) definition Drive = 6
 Hosts configured for this device:
  Host = master
======================= Missing Device (Drive) =======================
 Drive Name = IBM.ULT3580-TD4.002
 Drive Path = MISSING_PATH:{3,0,3,0}:1310034178
 Inquiry = "IBM     ULT3580-TD4     A232"
 Serial Number = 1310034178
 TLD(1) definition Drive = 4
 Hosts configured for this device:
  Host = master
======================= Missing Device (Drive) =======================
 Drive Name = IBM.ULT3580-TD4.003
 Drive Path = MISSING_PATH:{3,0,5,0}:1310177029
 Inquiry = "IBM     ULT3580-TD4     A232"
 Serial Number = 1310177029
 TLD(1) definition Drive = 2
 Hosts configured for this device:
  Host = master
======================= Missing Device (Drive) =======================
 Drive Name = IBM.ULT3580-TD4.007
 Drive Path = MISSING_PATH:{3,0,3,0}:1310214688
 Inquiry = "IBM     ULT3580-TD4     A232"
 Serial Number = 1310214688
 TLD(1) definition Drive = 6
 Hosts configured for this device:
  Host = master

 

Thank you

Operating Systems:

Comments 15 CommentsJump to latest comment

Nagalla's picture

please show us the output of below commands too..

tpconfig -d

vmoprcmd -d

tpautoconf -t

Marianne's picture

MISSING_PATH means that the OS has lost connectivity to the tape drive.

scan -changer output tells us that the robot can see the tape drives through its internal connection to the drives.

You need to confirm that the OS can see the drives through the SAN or direct cable connection to the tape drives. (With this amount of drives, probably SAN.)

First of all, check Device Manager. Delete any tape drives that are currently listed and then perform a rescan.

If drives are not coming back, you need to check zoning.
If drives come back after the scan, use 'scan' (without any options) to ensure that tape drives are responding to scsi commands. If drives with OS paths are seen, you can re-config drives in NBU.

Important that you find out WHY the OS lost connectivity to the drives.
Check Event Viewer System log for device/HBA-related errors.

Use HBA management software (e.g. SanSurfer if Qlogic HBAs) to ensure Persistent Binding is in place.
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
tarmizi's picture

Hello Nagalla,

These are the outputs from the command given.

C:\Documents and Settings\rdpadmin>tpconfig -d
Id  DriveName           Type   Residence
      SCSI coordinates/Path                                            Status
****************************************************************************
0   HP.ULTRIUM2-SCSI.000 hcart  TLD(0)  DRIVE=1
      {2,0,0,1}                                                        DOWN
      {4,0,0,1}                                                        DOWN
1   HP.ULTRIUM2-SCSI.001 hcart  TLD(0)  DRIVE=2
      {2,0,0,2}                                                        DOWN
      {4,0,0,2}                                                        DOWN
2   HP.ULTRIUM2-SCSI.002 hcart  TLD(0)  DRIVE=3
      {2,0,0,3}                                                        DOWN
      {4,0,0,3}                                                        DOWN
3   HP.ULTRIUM2-SCSI.003 hcart  TLD(0)  DRIVE=4
      {2,0,0,4}                                                        DOWN
      {4,0,0,4}                                                        DOWN
4   IBM.ULT3580-TD4.000  hcart  TLD(1)  DRIVE=6
      MISSING_PATH:{3,0,2,0}:1310035197                                DOWN
5   IBM.ULT3580-TD4.001  hcart  TLD(1)  DRIVE=5
      {3,0,1,0}                                                        UP
6   IBM.ULT3580-TD4.002  hcart  TLD(1)  DRIVE=4
      MISSING_PATH:{3,0,3,0}:1310034178                                DOWN
7   IBM.ULT3580-TD4.003  hcart  TLD(1)  DRIVE=2
      MISSING_PATH:{3,0,5,0}:1310177029                                DOWN
8   IBM.ULT3580-TD4.004  hcart  TLD(1)  DRIVE=1
      {3,0,2,0}                                                        UP
9   IBM.ULT3580-TD4.005  hcart  TLD(1)  DRIVE=3
      {3,0,3,0}                                                        UP
10  IBM.ULT3580-TD4.006  hcart  TLD(1)  DRIVE=6
      {3,0,0,0}                                                        DOWN
11  IBM.ULT3580-TD4.007  hcart  TLD(1)  DRIVE=6
      MISSING_PATH:{3,0,3,0}:1310214688                                DOWN
12  HP.ULTRIUM4-SCSI.000 hcart  TLD(2)  DRIVE=1
      {2,0,1,1}                                                        DOWN
13  HP.ULTRIUM4-SCSI.001 hcart  TLD(2)  DRIVE=10
      {2,0,1,10}                                                       DOWN
14  HP.ULTRIUM4-SCSI.002 hcart  TLD(2)  DRIVE=2
      {2,0,1,2}                                                        DOWN
15  HP.ULTRIUM4-SCSI.003 hcart  TLD(2)  DRIVE=3
      {2,0,1,3}                                                        DOWN
16  HP.ULTRIUM4-SCSI.004 hcart  TLD(2)  DRIVE=4
      {2,0,1,4}                                                        DOWN
17  HP.ULTRIUM4-SCSI.005 hcart  TLD(2)  DRIVE=5
      {2,0,1,5}                                                        DOWN
18  HP.ULTRIUM4-SCSI.006 hcart  TLD(2)  DRIVE=6
      {2,0,1,6}                                                        DOWN
19  HP.ULTRIUM4-SCSI.007 hcart  TLD(2)  DRIVE=7
      {2,0,1,7}                                                        DOWN
20  HP.ULTRIUM4-SCSI.008 hcart  TLD(2)  DRIVE=8
      {2,0,1,8}                                                        DOWN
21  HP.ULTRIUM4-SCSI.009 hcart  TLD(2)  DRIVE=9
      {2,0,1,9}                                                        DOWN
22  IBM.ULT3580-TD4.008  hcart  TLD(1)  DRIVE=4
      {3,0,4,0}                                                        DOWN

Currently defined robotics are:
  TLD(0)     SCSI coordinates = {4,0,0,0}
  TLD(1)     SCSI coordinates = {3,0,1,1}
  TLD(2)     SCSI coordinates = {2,0,1,0}

EMM Server = rdp-nb

 

C:\Documents and Settings\rdpadmin>vmoprcmd -d

                                PENDING REQUESTS

                                     <NONE>

                                  DRIVE STATUS

Drv Type   Control  User      Label  RecMID  ExtMID  Ready   Wr.Enbl.  ReqId
  0 hcart  DOWN-TLD             -                     No       -         0
  0 hcart  DOWN-TLD             -                     No       -         0
  1 hcart  DOWN-TLD             -                     No       -         0
  1 hcart  DOWN-TLD             -                     No       -         0
  2 hcart  DOWN-TLD             -                     No       -         0
  2 hcart  DOWN-TLD             -                     No       -         0
  3 hcart  DOWN-TLD             -                     No       -         0
  3 hcart  DOWN-TLD             -                     No       -         0
  4 hcart  DOWN-TLD             -                     No       -         0
  5 hcart    TLD               Yes   0026L4  0026L4   Yes     Yes        0
  6 hcart  DOWN-TLD             -                     No       -         0
  7 hcart  DOWN-TLD             -                     No       -         0
  8 hcart    TLD                -                     No       -         0
  9 hcart    TLD               Yes   0028L4  0028L4   Yes     Yes        0
 10 hcart  DOWN-TLD             -                     No       -         0
 11 hcart  DOWN-TLD             -                     No       -         0
 12 hcart  DOWN-TLD             -                     No       -         0
 13 hcart  DOWN-TLD             -                     No       -         0
 14 hcart  DOWN-TLD             -                     No       -         0
 15 hcart  DOWN-TLD             -                     No       -         0
 16 hcart  DOWN-TLD             -                     No       -         0
 17 hcart  DOWN-TLD             -                     No       -         0
 18 hcart  DOWN-TLD             -                     No       -         0
 19 hcart  DOWN-TLD             -                     No       -         0
 20 hcart  DOWN-TLD             -                     No       -         0
 21 hcart  DOWN-TLD             -                     No       -         0
 22 hcart  DOWN-TLD             -                     No       -         0

                             ADDITIONAL DRIVE STATUS

Drv DriveName            Shared    Assigned        Comment
  0 HP.ULTRIUM2-SCSI.000  No       -
  0 HP.ULTRIUM2-SCSI.000  No       -
  1 HP.ULTRIUM2-SCSI.001  No       -
  1 HP.ULTRIUM2-SCSI.001  No       -
  2 HP.ULTRIUM2-SCSI.002  No       -
  2 HP.ULTRIUM2-SCSI.002  No       -
  3 HP.ULTRIUM2-SCSI.003  No       -
  3 HP.ULTRIUM2-SCSI.003  No       -
  4 IBM.ULT3580-TD4.000   Yes      -
  5 IBM.ULT3580-TD4.001   Yes      rdp-nb
  6 IBM.ULT3580-TD4.002   Yes      -
  7 IBM.ULT3580-TD4.003   Yes      -
  8 IBM.ULT3580-TD4.004   Yes      -
  9 IBM.ULT3580-TD4.005   Yes      rdp-nb
 10 IBM.ULT3580-TD4.006   Yes      -
 11 IBM.ULT3580-TD4.007   No       -
 12 HP.ULTRIUM4-SCSI.000  No       -
 13 HP.ULTRIUM4-SCSI.001  No       -
 14 HP.ULTRIUM4-SCSI.002  No       -
 15 HP.ULTRIUM4-SCSI.003  No       -
 16 HP.ULTRIUM4-SCSI.004  No       -
 17 HP.ULTRIUM4-SCSI.005  No       -
 18 HP.ULTRIUM4-SCSI.006  No       -
 19 HP.ULTRIUM4-SCSI.007  No       -
 20 HP.ULTRIUM4-SCSI.008  No       -
 21 HP.ULTRIUM4-SCSI.009  No       -
 22 IBM.ULT3580-TD4.008   Yes      -

C:\Documents and Settings\rdpadmin>tpautoconf -t
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE01 2 0 0 1 Tape0 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE02 2 0 0 2 Tape1 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE03 2 0 0 3 Tape2 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE04 2 0 0 4 Tape3 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw01 2 0 1 1 Tape4 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw0a 2 0 1 10 Tape13 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw02 2 0 1 2 Tape5 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw03 2 0 1 3 Tape6 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw04 2 0 1 4 Tape7 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw05 2 0 1 5 Tape8 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw06 2 0 1 6 Tape9 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw07 2 0 1 7 Tape10 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw08 2 0 1 8 Tape11 - -
TPAC60 HP      Ultrium 4-SCSI  R500 02mPHLYw09 2 0 1 9 Tape12 - -
TPAC60 IBM     ULT3580-TD4     A232 1310214440 3 0 0 0 Tape18 - -
TPAC60 IBM     ULT3580-TD4     A232 1310177013 3 0 2 0 Tape20 - -
TPAC60 IBM     ULT3580-TD4     A232 1310212273 3 0 4 0 Tape22 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE01 4 0 0 1 Tape14 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE02 4 0 0 2 Tape15 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE03 4 0 0 3 Tape16 - -
TPAC60 HP      Ultrium 2-SCSI  R210 02dZchTE04 4 0 0 4 Tape17 - -

 

 

Nagalla's picture
looks like you are working on Missed path issue now.. and also you have all down drives for other TLD robots which you need to work.
comming to TLD1 robot issue.. 
 
when you did the scan it identified 6 tape drives
Number of Media Access Ports: 6
Drive 1 Serial Number      : "1310177013"
Drive 2 Serial Number      : "1310177029"
Drive 3 Serial Number      : "1310034409"
Drive 4 Serial Number      : "1310212273"
Drive 5 Serial Number      : "1310035164"
Drive 6 Serial Number      : "1310214440"
 
but the tpautoconf is identified 3 only, means OS is able to see 3 tape Drives.. rest is not albe to seen by OS
TPAC60 IBM     ULT3580-TD4     A232 1310214440 3 0 0 0 Tape18 - -
TPAC60 IBM     ULT3580-TD4     A232 1310177013 3 0 2 0 Tape20 - -
TPAC60 IBM     ULT3580-TD4     A232 1310212273 3 0 4 0 Tape22 - -
 

4   IBM.ULT3580-TD4.000  hcart  TLD(1)  DRIVE=6

      MISSING_PATH:{3,0,2,0}:1310035197                                DOWN
5   IBM.ULT3580-TD4.001  hcart  TLD(1)  DRIVE=5
      {3,0,1,0}                                                        UP
6   IBM.ULT3580-TD4.002  hcart  TLD(1)  DRIVE=4
      MISSING_PATH:{3,0,3,0}:1310034178                                DOWN
7   IBM.ULT3580-TD4.003  hcart  TLD(1)  DRIVE=2
      MISSING_PATH:{3,0,5,0}:1310177029                                DOWN
 
 11  IBM.ULT3580-TD4.007  hcart  TLD(1)  DRIVE=6
      MISSING_PATH:{3,0,3,0}:1310214688                                DOWN
 
 
so , start working with SAN team and make sure that the Zoaning is proper for the rest of the Drives
then make sure all these Drives are visiable in Device manager.
make sure all tape drives has upded fireware and media server with latest updated Drivers.
tarmizi's picture

Hi all,

When we speak of Device Manager, this is what I get. The OS detected 6 drives for IBM. What I am going to do next? There are only 6 physical drives but when I ran tpconfig -d, I can see there are 8 of them. I am guessing that my customer had replaced those drives but not updated in EMM (except for 1310177029) . 

 Device Manager.jpg

4   IBM.ULT3580-TD4.000  hcart  TLD(1)  DRIVE=6
      MISSING_PATH:{3,0,2,0}:1310035197                                DOWN
5   IBM.ULT3580-TD4.001  hcart  TLD(1)  DRIVE=5
      {3,0,1,0}                                                        UP
6   IBM.ULT3580-TD4.002  hcart  TLD(1)  DRIVE=4
      MISSING_PATH:{3,0,3,0}:1310034178                                DOWN
7   IBM.ULT3580-TD4.003  hcart  TLD(1)  DRIVE=2
      MISSING_PATH:{3,0,5,0}:1310177029                                DOWN
8   IBM.ULT3580-TD4.004  hcart  TLD(1)  DRIVE=1
      {3,0,2,0}                                                        UP
9   IBM.ULT3580-TD4.005  hcart  TLD(1)  DRIVE=3
      {3,0,3,0}                                                        UP
10  IBM.ULT3580-TD4.006  hcart  TLD(1)  DRIVE=6
      {3,0,0,0}                                                        DOWN
11  IBM.ULT3580-TD4.007  hcart  TLD(1)  DRIVE=6
      MISSING_PATH:{3,0,3,0}:1310214688                                DOWN

 

 

 

Marianne's picture

PLEASE have a look at my post above:

https://www-secure.symantec.com/connect/forums/missingpath#comment-9409421

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

tarmizi's picture

Hi all,

Thank you for the quick respond. For one of the drive with the serial number "310214688", I delete it in " Media and Device Management>Devices>Drives" and look for the drive and delete it. Then it automatically replace it with the drive with serial number "1310214440" then just "UP" the drive. Now I'm trying what Marianne suggested to me.

Thank you 

Marianne's picture

Seems that Persistent Binding is not in place.

First - Ensure that OS picks up ALL the drives after deleting and rescan in Device Manager.

Next, confirm that drives respond to scsi enquiries with 'scan' command (or 'scan -tape').
If not - ask SAN admin to verify zoning.

If all drives are seen, delete all drives in NBU and use the Device Config wizard to re-config.

Use HBA tools to configure Persistent Binding.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

tarmizi's picture

Hi all,

After deleting one of the drive with "MISSING_PATH", I couldn't add it using "Configure Storage Devices". it appeared that the drive grayed and showing "unused element address" even after reinstalling the drive. Now I am trying to install using a new device driver.

 

Unused element address.jpg

 

Marianne's picture

"unused element address" is the robot itself saying that no tape drive is installed in that position in the robot. Robot hardware config should be checked first of all.

Please show us output of 'scan' (with no options).

It is quite possible for tpconfig to show different output to OS:
tpconfig is NBU config. If anything changes happend at OS level and with physical robot config, NBU config does not get updated automatically.
This is why I suggested that you delete all devices in NBU, ensure all devices is seen at OS level, and only then use the Device Config wizard to reconfig NBU.

Previous tpautoconf shows gaps in OS device names - there is no Tape19 or Tape21.
So, good idea to confirm that zoning is done correctly - if any tape drives were replaced, was zoning updated? Can all devices be seen with HBA tools (e.g. SanSurfer for Qlogic)?
When you are 100% sure that zoning is correct and robot sees all drives, delete all devices in Windows Device Manager, scan for changes and see if al expected devices can be seen.

Confirm that all devices respond to scsi commands with 'scan' command.

Only then run NBU Device Config Wizard.
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

tarmizi's picture

Hi Marianne,

I've checked the hba mapping. It seem all is okay including the zonning. But there is something different between one drive and others five. Therefor I've tried to reinstall each driver's driver. However, here is the scan output:

 

************************************************************
*********************** SDT_TAPE    ************************
*********************** SDT_CHANGER ************************
************************************************************
------------------------------------------------------------
Device Name  : ""
Passthru Name: ""
Volume Header: ""
Port: 2; Bus: 0; Target: 0; LUN: 0
Inquiry    : "HP      VLS             1.00"
Vendor ID  : "HP      "
Product ID : "VLS             "
Product Rev: "1.00"
Serial Number: "02dZchTE00"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      VLS             02dZchTE00"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-3
Number of Drives : 4
Number of Slots  : 712
Number of Media Access Ports: 16
Drive 1 Serial Number      : "02dZchTE01"
Drive 2 Serial Number      : "02dZchTE02"
Drive 3 Serial Number      : "02dZchTE03"
Drive 4 Serial Number      : "02dZchTE04"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape0"
Passthru Name: "Tape0"
Volume Header: ""
Port: 2; Bus: 0; Target: 0; LUN: 1
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE01"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE01"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape1"
Passthru Name: "Tape1"
Volume Header: ""
Port: 2; Bus: 0; Target: 0; LUN: 2
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE02"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE02"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape2"
Passthru Name: "Tape2"
Volume Header: ""
Port: 2; Bus: 0; Target: 0; LUN: 3
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE03"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE03"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape3"
Passthru Name: "Tape3"
Volume Header: ""
Port: 2; Bus: 0; Target: 0; LUN: 4
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE04"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE04"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : ""
Passthru Name: ""
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 0
Inquiry    : "HP      ESL E-Series    2.00"
Vendor ID  : "HP      "
Product ID : "ESL E-Series    "
Product Rev: "2.00"
Serial Number: "02mPHLYw00"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      ESL E-Series    02mPHLYw00"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-3
Number of Drives : 10
Number of Slots  : 356
Number of Media Access Ports: 16
Drive 1 Serial Number      : "02mPHLYw01"
Drive 2 Serial Number      : "02mPHLYw02"
Drive 3 Serial Number      : "02mPHLYw03"
Drive 4 Serial Number      : "02mPHLYw04"
Drive 5 Serial Number      : "02mPHLYw05"
Drive 6 Serial Number      : "02mPHLYw06"
Drive 7 Serial Number      : "02mPHLYw07"
Drive 8 Serial Number      : "02mPHLYw08"
Drive 9 Serial Number      : "02mPHLYw09"
Drive 10 Serial Number      : "02mPHLYw0a"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape4"
Passthru Name: "Tape4"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 1
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw01"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw01"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape13"
Passthru Name: "Tape13"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 10
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw0a"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw0a"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape5"
Passthru Name: "Tape5"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 2
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw02"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw02"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape6"
Passthru Name: "Tape6"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 3
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw03"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw03"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape7"
Passthru Name: "Tape7"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 4
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw04"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw04"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape8"
Passthru Name: "Tape8"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 5
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw05"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw05"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape9"
Passthru Name: "Tape9"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 6
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw06"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw06"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape10"
Passthru Name: "Tape10"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 7
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw07"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw07"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape11"
Passthru Name: "Tape11"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 8
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw08"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw08"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape12"
Passthru Name: "Tape12"
Volume Header: ""
Port: 2; Bus: 0; Target: 1; LUN: 9
Inquiry    : "HP      Ultrium 4-SCSI  R500"
Vendor ID  : "HP      "
Product ID : "Ultrium 4-SCSI  "
Product Rev: "R500"
Serial Number: "02mPHLYw09"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 4-SCSI  02mPHLYw09"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape18"
Passthru Name: "Tape18"
Volume Header: ""
Port: 3; Bus: 0; Target: 0; LUN: 0
Inquiry    : "IBM     ULT3580-TD4     A232"
Vendor ID  : "IBM     "
Product ID : "ULT3580-TD4     "
Product Rev: "A232"
Serial Number: "1310214440"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     ULT3580-TD4     1310214440"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape19"
Passthru Name: "Tape19"
Volume Header: ""
Port: 3; Bus: 0; Target: 1; LUN: 0
Inquiry    : "IBM     ULT3580-TD4     A232"
Vendor ID  : "IBM     "
Product ID : "ULT3580-TD4     "
Product Rev: "A232"
Serial Number: "1310177013"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     ULT3580-TD4     1310177013"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape20"
Passthru Name: "Tape20"
Volume Header: ""
Port: 3; Bus: 0; Target: 2; LUN: 0
Inquiry    : "IBM     ULT3580-TD4     A232"
Vendor ID  : "IBM     "
Product ID : "ULT3580-TD4     "
Product Rev: "A232"
Serial Number: "1310034409"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     ULT3580-TD4     1310034409"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape21"
Passthru Name: "Tape21"
Volume Header: ""
Port: 3; Bus: 0; Target: 3; LUN: 0
Inquiry    : "IBM     ULT3580-TD4     A232"
Vendor ID  : "IBM     "
Product ID : "ULT3580-TD4     "
Product Rev: "A232"
Serial Number: "1310035164"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     ULT3580-TD4     1310035164"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : ""
Passthru Name: ""
Volume Header: ""
Port: 3; Bus: 0; Target: 3; LUN: 1
Inquiry    : "IBM     3576-MTL        587G"
Vendor ID  : "IBM     "
Product ID : "3576-MTL        "
Product Rev: "587G"
Serial Number: "000001311856_LLA"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     3576-MTL        000001311856_LLA"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-3
Number of Drives : 6
Number of Slots  : 120
Number of Media Access Ports: 6
Drive 1 Serial Number      : "1310177013"
Drive 2 Serial Number      : "1310177029"
Drive 3 Serial Number      : "1310034409"
Drive 4 Serial Number      : "1310212273"
Drive 5 Serial Number      : "1310035164"
Drive 6 Serial Number      : "1310214440"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape22"
Passthru Name: "Tape22"
Volume Header: ""
Port: 3; Bus: 0; Target: 4; LUN: 0
Inquiry    : "IBM     ULT3580-TD4     A232"
Vendor ID  : "IBM     "
Product ID : "ULT3580-TD4     "
Product Rev: "A232"
Serial Number: "1310212273"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "IBM     ULT3580-TD4     1310212273"
Device Type    : SDT_TAPE
NetBackup Drive Type: 3
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : ""
Passthru Name: ""
Volume Header: ""
Port: 4; Bus: 0; Target: 1; LUN: 0
Inquiry    : "HP      VLS             1.00"
Vendor ID  : "HP      "
Product ID : "VLS             "
Product Rev: "1.00"
Serial Number: "02dZchTE00"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      VLS             02dZchTE00"
Device Type    : SDT_CHANGER
NetBackup Robot Type: 8
Removable      : Yes
Device Supports: SCSI-3
Number of Drives : 4
Number of Slots  : 712
Number of Media Access Ports: 16
Drive 1 Serial Number      : "02dZchTE01"
Drive 2 Serial Number      : "02dZchTE02"
Drive 3 Serial Number      : "02dZchTE03"
Drive 4 Serial Number      : "02dZchTE04"
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape14"
Passthru Name: "Tape14"
Volume Header: ""
Port: 4; Bus: 0; Target: 1; LUN: 1
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE01"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE01"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape15"
Passthru Name: "Tape15"
Volume Header: ""
Port: 4; Bus: 0; Target: 1; LUN: 2
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE02"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE02"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape16"
Passthru Name: "Tape16"
Volume Header: ""
Port: 4; Bus: 0; Target: 1; LUN: 3
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE03"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE03"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
------------------------------------------------------------
Device Name  : "Tape17"
Passthru Name: "Tape17"
Volume Header: ""
Port: 4; Bus: 0; Target: 1; LUN: 4
Inquiry    : "HP      Ultrium 2-SCSI  R210"
Vendor ID  : "HP      "
Product ID : "Ultrium 2-SCSI  "
Product Rev: "R210"
Serial Number: "02dZchTE04"
WWN          : ""
WWN Id Type  : 0
Device Identifier: "HP      Ultrium 2-SCSI  02dZchTE04"
Device Type    : SDT_TAPE
NetBackup Drive Type: 10
Removable      : Yes
Device Supports: SCSI-3
Flags : 0x0
Reason: 0x0
 

Marianne's picture

The OS cannot see this tape drive:

Drive 2 Serial Number      : "1310177029"
 

All other drives in this robot have OS device name:

Device Name  : "Tape19"
Device Identifier: "IBM     ULT3580-TD4     1310177013"

Device Name  : "Tape20"
Device Identifier: "IBM     ULT3580-TD4     1310034409"

Device Name  : "Tape22"
Device Identifier: "IBM     ULT3580-TD4     1310212273"

Device Name  : "Tape21"
Device Identifier: "IBM     ULT3580-TD4     1310035164"

Device Name  : "Tape18"
Device Identifier: "IBM     ULT3580-TD4     1310214440"

 

You need to check physical connectivity of this drive to the SAN as well as zoning.

 

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

tarmizi's picture

Hi all,

The issue solved this morning after I used the Symantec driver. I tried to use IBM driver downloaded from IBM site but no luck but make it even worse where all drives been "Missing_Path". So what I did this mornig was reinstalled all drives using Syamantec driver. Then reboot the master server, then use the scan command to scan the drive then use "Configure Storage Devices" wizard to configure it. Everything is up and running now. 

Thank you for the prompt reply and suggestions. I hope all the steps and suggestion may help the others too. 

 

Marianne's picture

Please bear in mind that Symantec drivers will only work on 32-bit media servers.

On NBU 7.1 and later, only W2003 32-bit is supported as media server.
As from NBU 7.6, only 64-bit media servers are supported.

Symantec recommends to use IBM drivers. There is a special write-up about IBM drivers in the NBU 7 HCL:  http://www.symantec.com/docs/TECH76495 under the topic:

IBM Tape Driver Support

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

tarmizi's picture

Hi Marianne,

Yes, I aware of that matter since my master server's version is 7.0.1