Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Move archive issues

Created: 20 Sep 2012 | 2 comments
SYMAJ's picture

As I move this forward I have uncovered some interesting issues. (in reference to https://www-secure.symantec.com/connect/forums/ev-...)

I am moving archives from the EV9 system to the EV10 system.  The reason we are starting with a 'fresh' EV10 system and not upgrading/migrating is that there were issues following a disk failure and subsequent restore which caused many issues with recall of items which were causing errors as EV stated that duplicates would exist - the system was basically in a mess !  Indexes were failing also due to this issue.

It was decided to setup a new system and move the archives, which as the move process progressed only items which were valid would be extracted/moved and stored/indexed at the target EV site.

This has worked in many cases, however the move is progressing as follows in a number of cases:

1. Archive is copied accross to the target site OK

2. Shortcut processing takes place and some items fail

3. Verification works OK

4. Archive remains open as the move is 'Completed with Errors'.

The errors are within the shortcut processing element of the process.

The results of these moves are as follows:

1. Some archives working fine and going to 'completed' status.  Source archives are marked closed.  All shortcuts are working fine.

2. Some archives are 'completed with errors', source archive stays open, shortcut body is only first 100 characters (as per policy) but when double clicked does not expand into original message.  EV banner at the top stating this item has been archived and to 'click here' to view original message.  However nothing happens when you click in the banner area.

3. In some messages when I hover the mouse over the attachment I see it is still referring to the old EV server, but in some messages the correct path (new EV server) is shown for the attachments.

4. In ALL cases when I view the archive from Archive Explorer or Search Archives ALL content and attachments are good.

This leads me to believe that the issue is purely with the shortcuts.  I have the policy set to delete orphaned shortcuts, so am assuming that when I run the shortccut processing on the new EV10 server that any 'old invalid' shortcuts in the mailboxes will be removed.

I have attached the MOVE ARVIVE output from one example mailbox - and this is the error I am getting with the majority of the moves which dont complete successfully.

What is going on here, and how can  best clean up the shortcuts in these affected mailboxes ?  I am happy that the new archives contents are valid (as Archive Explorer see's everything OK) - I just need to cleanup the shortcuts to remoove old ones and make sure new ones are there.

Any inout appreciated.

AJ 

Comments 2 CommentsJump to latest comment

JesusWept3's picture
SYMAJ's picture

There are no Folders involved so that shouldn't come into play.

Jeff - I did disable the archiving tasks on the old server (still there - not deleted), and ALL mailboxes are provisioned and enabled on the new EV server.  The archives are still present on the old server also, but since the mailboxes were provisioned on the new server approx 1 week ago I have been archiving new mail on that EV system.

The current status is that a number of archives have been 'moved' to the new server, and are archiving there - the other archives remain on the old server with the same users having a new archive on the new server which is archiving new email.  The move of these outstanding archives should add the mail from the old archive into the new archive and create shortcuts, and I was assuming the old shortcuts would be deleted (but you say not).

Once the move has completed successfully the old archive will be closed, although when it completes with errors the archive remains open.  When the archive is still there on the old system the links should work OK as it should route accross to the old system. 

I guess the questions are as follows:

1. Why is the shortcut processing piece of the move failing

2. Why isn't the orphan shortcut processing removing the old shortcuts.  Jeff - you say the new system won't remove the shortcuts created by another system - then how do I remove these ? 

I don't understand the reason for running shortcut processing on the old system.  The archive is still there so the shortcuts are not orphaned.  Also, won't this just get the whole system into a mess ?

I was considering one approach (for individual mailboxes) to be disable the mailbox for archiving, export the archive to a PST, delete the archive, run shortcut processing to remove ALL shortcuts from the mailbox, then enable the mailbox for archiving to create the archive and import the PST to the archive.  This would fall short taking into account that the system would not delete the shortcuts in the mailbox created by another system.

I am mighty confused as to the best way forward here.

AJ