Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Move file Component

Created: 21 Mar 2014 • Updated: 16 Apr 2014 | 9 comments
This issue has been solved. See solution.

I am trying to build a process that will get files from our FTP server and move them to a local folder so I can do more work with them.  I have the FTP Get all files component and it is working good, Then I am adding a for each element in collection (I dont think this is working right either) I will have multiple files I need to work with on the FTP so I want to grab each one and based on what it is will go a different path. 

So First question will the for each work off of the get all I dont think it will if not what would be the best component to use there?

Second problem I am testing the write file component and it is making me want to bang my head against the wall. It keeps giving me access denied errrors to the folder.  I create a folder on my C: called C:\Files, The user that is assinged to my app pool has been giving full control of this folder and it still gives me access deined errors. 

I also tried using just the copy files component to move the files from our FTP to the local and it kept telling me the folder paths didnt exsist. I tried both a mapping and UNC path. The problem with this is the FTP server sits in my DMZ and is not part of my domain so authentication is required to get to it.

Thoughts?

Thanks 

Operating Systems:

Comments 9 CommentsJump to latest comment

David Parks's picture

1. You can certainly use the FTP Get All Files component directly into the For Each. Just keep in mind that the Get All FIles is going to potentially crush your memory usage. 

Instead I would recommend using the FTP List into a for each loop and then the individual FTP Download Component. Pipe that into a write file and you should be golden.

2. When you are testing are you running it through the debugger? The debugger runs under the user who opened workflow and not the app pool. Permissions are always a struggle with workflow. You could make another app pool running as network service or something and just assign this one workflow to it. Sometimes that simplifies the permissions problems I run in to.

3. It probably wants FTP://ftp.yourhost.com The components are not always flexible on this type of stuff.

David Parks

www.novacoast.com

Dkromm's picture

David:

So when loading into the download it wants specific file would you just use the file name it got from the list? I assume?

Thanks 

David Parks's picture

Correct.

There are some weird issues around the FTP components. I added a download to connect at:

https://www-secure.symantec.com/connect/downloads/workflow-ftp-example

It will probably help get the items configured as required.

Good Luck!

David Parks

www.novacoast.com

SOLUTION
Dkromm's picture

David: I am getting a user has restricted access to this page message when i click on your link.

ohzone - CherylPeterson's picture

David's download is available now and you can access it without getting the restricted access message.

Thanks
Cheryl

Endpoint Management,
Endpoint Virtualization
Managing Mobility
Community Manager
www.twitter.com/EMnV_symc
Need Altiris help? IRC chat #Altiris

Dkromm's picture

I got the download and have finally had time to play around with it. When I get to the download component I get the following exception

LogicBase.Components.FTP.FtpDownloadProcessComponent

FTP Download

f5dbcc00-be6c-11e3-9f3a-005056a50013

System.UriFormatException

Invalid URI: The format of the URI could not be determined.

System.UriFormatException: Invalid URI: The format of the URI could not be determined. at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind) at System.Uri..ctor(String uriString) at LogicBase.Components.FTP.FtpDownloadProcessComponent.Run(IData data) at LogicBase.Core.ExecutionEngine.MultiPathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine, TLExecutionContext context) at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.RunComponent(TLExecutionContext context, IData data, IOrchestrationComponent comp)

Dkromm's picture

found it my downloadcomponent had a typo.

David Parks's picture

Did you end up getting this to work the way you needed?

If so mark the thread as solved. It makes it easier to find in the search when someone else is looking for the same answer.

David Parks

www.novacoast.com

Dkromm's picture

David:

 Yep I actually just got it going yesterday, Thanks for all the help.