Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Moving Altiris Recovery Solution to another SQL server

Created: 30 Mar 2014 | 5 comments
GarethNZ's picture

Hi, I know ARS is EoL but we need to keep using it for now. We need to move the Altiris Recovery Solution database to another SQL server, but I can't see any change the database settings in the Recovery Solution settings, I'm looking at Cluster Configuration\Server, general tab shows me and Cluster and Database settings, only option for database is to change password.
Does this page help me? https://www-secure.symantec.com/connect/forums/recovery-solution-70-move-database-sql-server-2005-sql-server-2008-r2, I don't get what "Had to Change the SQL Server Name in the table Inv_Recovery_Cluster_Details and Inv_RS_Servers..." means, can anyone explain it for me?

cheers

Operating Systems:

Comments 5 CommentsJump to latest comment

Mike Pikkov's picture

Hi Gareth,

"Had to Change the SQL Server Name in the table Inv_Recovery_Cluster_Details and Inv_RS_Servers..." means that there will be a need to update corresponding columns within the records of those tables in CMDB SQL database. We are talking about steps 6 and 7 below:

Steps to move the Notification Server / Recovery Solution databases to a different SQL server

Question:
What are the steps to move the Recovery Solution database to a different SQL server?
Answer:
Applies to Recovery Solution version 7.1.

Steps below require operational knowledge of the SQL Enterprise Manager. Before proceeding, make sure that there are no jobs currently running on the Recovery Server and stop both Altiris Recovery Solution Server services. 

1. At the SQL server, use SQL Enterprise Manager to create a default login that is used to access the Recovery Server database

• create a new SQL login ‘AeXRSDatabaseUser’
• set its password to password original account had
• grant this user following server roles: ‘bulkadmin’, ‘dbcreator’ and ‘setupadmin’.

2. Move the Recovery Server database via attach/detach method to a designated SQL server 

• when attaching database, select the ‘AeXRSDatabaseUser’ as the database owner 
• when attaching database, it is possible to specify a different database name in the ‘attach as’ field
• after the database is attached set the RS database as a default for the user AeXRSDatabaseUser

3. Note: if Altiris and Recovery DBs will reside on different SQL servers you should also add ‘Linked server’: 

• Open the SQL Server Enterprise Manager on the Altiris NS (SMP) Server where the NS (SMP) Database is located
• Expand Security
• Expand Linked Servers
• Go to the right pane and do the right-click. Select 'New Linked Server' from the popup menu.
• In 'General' tab - select 'SQL Server'.
• In 'Security' tab check 'Be made using this security context'.
• Enter the db user name ('AeXRSDatabaseUser' by default) and the password ('password').
• Click Ok to close the dialog.

4. At the RS server (where services are still stopped), reconfigure the Recovery Server ODBC settings

• from the Windows Start menu, select Control Panel or Administrative Tools
• open the ‘Data Sources (ODBC)’ applet
• click the ‘System DSN’ tab
• select ‘AeXCRDatabaseDSN’ in the list and then click the ‘Configure’ button
• in the ‘Name’ field, enter ‘AeXRSDatabaseDSN’
• in the ‘Server’ field, enter the name of the SQL server and click ‘Next>’
• make sure the check box labeled ‘Connect to SQL Server to obtain default settings for the additional configuration options’ is checked
• enter the SQL user name for Recovery Solution (AeXRSDatabaseUser) 
• enter the SQL password (default is ‘password’) and click ‘Next>’
• click ‘Change the default database to’, then select the Recovery Server database that was attached in step 4
• click ‘Next>’ and then Finish.
• A confirmation screen appears. Click the ‘Test Data Source’ button to verify that the
ODBC connection is working properly.

5. At the RS server, modify the registry:
HKLM\Software\Altiris\eXpress\Client Recovery\DataStore
”ServerName” should be set to the new SQL server name
(note: on the 64 bit machine the registry will be under HKLM\Software\Wow6432Node\Altiris\eXpress\Client Recovery\DataStore)

6. Update the ‘DbServer’ field in the ‘Inv_Recovery_Cluster_Details’ table of the Altiris database to reflect RS database server change (change the ‘DbName’ field as well in case database name was changed when attached)

7. Update the ‘SQLServerName’ field in the ‘Inv_RS_Servers’ table of the Altiris database to reflect RS database server change (change the ‘DatabaseName’ field as well in case database name was changed when attached)

8. In the SQL Manager verify the AeXRSDatabaseUser properties – User Mapping. Database role membership for the RS database should include ‘db_accessadmin’, ‘db_owner’ and ‘public’.

9. Restart both RS Server services on the RS Server box.

10. Verify that RS Server service was able to start successfully according to Altiris Recovery Solution custom event log (available via Windows Event Viewer)

Hope this helps. 
Regards,

Mike Pikkov

AttachmentSize
Steps to move the RS database 7.1.docx 15.68 KB
SK's picture

Do you still need help Gareth?

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

GarethNZ's picture

Thanks for you help, sorry I've been busy, I'll have a closer look at the replies and get back to you early next week.

GarethNZ's picture

That all looks easy enough, I've passed the info onto our DBA, hopefully we'll get it moved in the new few weeks. Not sure how I didn't find that article. Thanks Mike.

GarethNZ's picture

So we just moved our Recovery Solution DB.

There was no AeXCRDatabaseDSN in the Data Sources (ODBC) applet, I found in registry and changed SQL server name there: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\AeXRecoveryServerDatabaseDSN, server

It didn't connect at first when services were restarted, my DBA had to reenter the password for AeXRSDatabaseUser

I then saw 6 warnings in the recovery solution even log:

Failed to set security attributes for the 'D:\Altiris\Recovery Solution\Server\Agent\Web' folder.
Local Event Code: 0x80090005
System Event Code: 0x80070005: Access is denied.
SbsName: , SbsKey: 0, 0
And also Server\WBFR\, Server\\Agent\AsmExt, Server\\HttpVault, Server\\HttpPing, Server\Agent\Package. They repeated 3 seconds later, then nothing. The permissions on these folders are all greyed out, they seem to be managed by System.

I've done a successfull snapshot, so I'm assuming it all went ok, thanks for your help.