Video Screencast Help

MP1 broke imaging, anyone else?

Created: 09 Oct 2012 • Updated: 06 Nov 2012 | 11 comments
This issue has been solved. See solution.

I don't know if it's something local to our environment, but ever since I installed MP1, imaging is totally broke.  Reboot to PXE, ghost completes it's process to 100%, and then the console reports failed. This is all of my images (backup and disk images, deploy anywhere or not) that worked ok prior to MP1.

Just wanted to post here to see if others are imaging successfully after MP1, and to warn others if you can test in a test environment before upgrading, it may be worth it.

I'm working with support on it actively hoping they can find a fix or workaround ASAP.

Comments 11 CommentsJump to latest comment

Indrek_K's picture

Hello Sall

Have you tried recratingthe WinPE environement so it ould contain alo the new agent?

Best regards

Sally5432's picture

Yup, with support we confirmed winPE is correct version.  I wish that was it...

Also, after I had PXE issues after the upgrade, I did a repair on all DS related items in SIM.

Don't forget to mark posts as helpful if they are, and mark answers as solutions.

Indrek_K's picture

Try cleaning out the SBSStore, updat configration and restart servies.

Then try again if it fails again check on that mahine following log ClientImageDeploy.log scroll do te bottom and confirm me if you have following line there:

ExecuteClass::Commandline =  copy "X:\Program Files\Altiris\Altiris Agent\PECTAgent.ini" "PROD:\boot\altiris\iso\@inject@\Program Files\Altiris\Altiris Agent\PECTAgent.ini"

Sally5432's picture

Where would I clean out the SBSStore?  

This is the end of my file

[2012/10/09 08:04:32.981 1820:1956 1] ****** ExecuteClass:: In ExecuteCommandNoUser ******
[2012/10/09 08:04:32.981 1820:1956 1] ExecuteClass::Module Name = \\server\Deployment\Task Handler\firm.exe
[2012/10/09 08:04:32.981 1820:1956 1] ExecuteClass::Commandline =  copy "X:\Program Files\Altiris\Altiris Agent\PECTAgent.ini" "PROD:\boot\altiris\iso\@inject@\Program Files\Altiris\Altiris Agent\PECTAgent.ini"
[2012/10/09 08:04:32.981 1820:1956 2] ExecuteCommand.cpp@128 calling ExecuteClass::ExecuteCommandNoUser(). 
[2012/10/09 08:04:32.981 1820:1956 2] ExecuteClass::@161 Application Name is NOT NULL.
[2012/10/09 08:04:32.981 1820:1956 2] ExecuteClass::@174 Command line is NOT NULL.
[2012/10/09 08:04:32.981 1820:1956 2] ExecuteClass::@194 nResult =0 ,dwExitCode=0 
[2012/10/09 08:04:32.981 1820:1956 1] ExecuteCommand.cpp@217 - ExecuteClass Exception -Reason=Unable to create new process value=4, error=6
[2012/10/09 08:04:32.981 1820:1956 0] apps\DeploymentClient\ClientImageDeploy\Tcube_ClientImageDeploy.cpp@134 Child Process returned an error value=6, error=183
[2012/10/09 08:04:32.981 1820:1956 2] apps\DeploymentClient\ClientImageDeploy\Tcube_ClientImageDeploy.cpp@1105 Output @errorMessage=Child Process returned an error
[2012/10/09 08:04:32.981 1820:1956 2] apps\DeploymentClient\ClientImageDeploy\Tcube_ClientImageDeploy.cpp@1114 Imaging completed. Failure return!!

Don't forget to mark posts as helpful if they are, and mark answers as solutions.

md investigate's picture


sbsstore: \altirisdir\altiris agent\agents\deployment\task handler\sbs\sbsstore

Did you had a look on this post:

The errors are similar, but I guess before upgrade all worked well?


Sally5432's picture

Cleared out sbsstore, created another new preboot envinronment, still same problem 

That post does look very similar but no idea what the user did

Yes, prior to upgrade we could image/deploy

Don't forget to mark posts as helpful if they are, and mark answers as solutions.

md investigate's picture

okay, so far he did this:

To run the integrity check from Windows (Symantec Ghost 8.x and later)

1.Run Ghost32.exe. By default this is Located at:

"c:\program files\altiris\altiris agents\agents\deployment\task handler\ghost\Ghost32.exe"

2.Choose Local > Check > Image File.
3.Browse to the image file and click Open.
4.Choose Yes to proceed with the integrity check

Just follow the procedere he described. It's worth a try.


Sally5432's picture

Good news, support was able to get me on the right track.  There seems to be a file or 2 missing (firm) for those using 32 bit preboot configs.  I don't know if it's just me (don't think so), but the fix of just using a 64 bit preboot config got me up and running.  Thanks everyone for the suggestions, as always.

Don't forget to mark posts as helpful if they are, and mark answers as solutions.

Cory Grant's picture

This looks to be an issue of a missing file in the "\Altiris\Altiris Agent\Agents\Deployment\Task Handler" directory.

The "firm.exe" file that should be in that directory is called at the end of the image deployment process to inject a few files (including the unattend file) into the newly-deployed image. This is only true, however, for the deployment in an x86 WinPE environment; the x64 pulls it from another location.

Proposed workarounds:

-Use x64 WinPE preboot when deploying the image.

-Copy/paste the "firm.exe" from "\Altiris\Altiris Agent\Agents\Deployment\Task Handler\rdeploy" into the "\Altiris\Altiris Agent\Agents\Deployment\Task Handler" directory. This should allow the image task to access it and successfully inject the needed files.

Sally5432's picture

Thanks to Cory and everyone at Symantec who worked to get me a quick working solution.  Totally saved me in a tough spot.

Don't forget to mark posts as helpful if they are, and mark answers as solutions.

DanSpidell's picture

Just wanted to confirm that this IS a problem with 7.1 MP1.  I just followed Cory's instructions from above and it resolved my failed deploys.  Thanks so much Cory!