Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

MS SharePoint Backups

Created: 31 May 2012 | 8 comments

I am trying to backup Microsoft SharePoint Resources and \AllWebs but am getting the errors lsited below.  I am able to run Windows File Systems backup sucessfully but not these two policies.  I tried to configure everything the same as the procedures show in the Symantec Netbackup for Microsoft SharePoint Server Administrator's Guide, but without sucess.  There are two servers in my Sharepont server file. Databases are located on another server are are being backed up.  I am using Netbackup 7.0.1 on a Windows 2008 R2 server.  SharePoint 2007 is on a Windows 2003 server.  Any assistance with this isssue would be greatly appreciated.

MS SharePoint Policy

1.) Microsoft SharePoint Resources:\

5/31/2012 4:36:07 PM - requesting resource sharp008-hcart-robot-tld-0
5/31/2012 4:36:07 PM - requesting resource sharp008.NBU_CLIENT.MAXJOBS.sharpc2004
5/31/2012 4:36:07 PM - requesting resource sharp008.NBU_POLICY.MAXJOBS.sharp_Sharepoint
5/31/2012 4:36:08 PM - granted resource sharp008.NBU_CLIENT.MAXJOBS.sharpc2004
5/31/2012 4:36:08 PM - granted resource sharp008.NBU_POLICY.MAXJOBS.sharp_Sharepoint
5/31/2012 4:36:08 PM - granted resource ECL986
5/31/2012 4:36:08 PM - granted resource HP.ULTRIUM4-SCSI.001
5/31/2012 4:36:08 PM - granted resource sharp008-hcart-robot-tld-0
5/31/2012 4:36:08 PM - estimated 0 Kbytes needed
5/31/2012 4:36:08 PM - begin Parent Job
5/31/2012 4:36:08 PM - begin SharePoint, Start Notify Script
5/31/2012 4:36:08 PM - started process RUNCMD (7548)
5/31/2012 4:36:08 PM - ended process 0 (7548)
Status 0
5/31/2012 4:36:08 PM - end SharePoint, Start Notify Script; elapsed time: 00:00:00
5/31/2012 4:36:08 PM - begin SharePoint, Step By Condition
Status 0
5/31/2012 4:36:08 PM - end SharePoint, Step By Condition; elapsed time: 00:00:00
5/31/2012 4:36:08 PM - begin SharePoint, Read File List
Status 0
5/31/2012 4:36:08 PM - end SharePoint, Read File List; elapsed time: 00:00:00
5/31/2012 4:36:08 PM - begin SharePoint, Resolver Discovery
5/31/2012 4:36:08 PM - started process bpbrm (7152)
Status 2
5/31/2012 4:36:29 PM - end SharePoint, Resolver Discovery; elapsed time: 00:00:21
5/31/2012 4:36:29 PM - begin SharePoint, Stop On Error
Status 0
5/31/2012 4:36:29 PM - end SharePoint, Stop On Error; elapsed time: 00:00:00
5/31/2012 4:36:29 PM - begin SharePoint, End Notify Script
5/31/2012 4:36:29 PM - started process RUNCMD (7604)
5/31/2012 4:36:29 PM - ended process 0 (7604)
Status 0
5/31/2012 4:36:29 PM - end SharePoint, End Notify Script; elapsed time: 00:00:00
Status 2
5/31/2012 4:36:29 PM - end Parent Job; elapsed time: 00:00:21
none of the requested files were backed up(2)

2.) Microsoft SharePoint Resources:\AllWebs

5/31/2012 4:03:06 PM - requesting resource sharp008-hcart-robot-tld-0
5/31/2012 4:03:06 PM - requesting resource sharp008.NBU_CLIENT.MAXJOBS.sharpc2004
5/31/2012 4:03:06 PM - requesting resource sharp008.NBU_POLICY.MAXJOBS.sharp_Sharepoint_AllWebs
5/31/2012 4:03:06 PM - awaiting resource sharp008-hcart-robot-tld-0 - No drives are available
5/31/2012 4:19:09 PM - awaiting resource sharp008-hcart-robot-tld-0 Reason: Drives are in use, Media Server: sharp008,
  Robot Number: 0, Robot Type: TLD, Media ID: N/A, Drive Name: N/A,
  Volume Pool: SharePoint, Storage Unit: sharp008-hcart-robot-tld-0, Drive Scan Host: N/A
 
5/31/2012 4:19:09 PM - awaiting resource sharp008-hcart-robot-tld-0 - No drives are available
5/31/2012 4:34:48 PM - granted resource sharp008.NBU_CLIENT.MAXJOBS.sharpc2004
5/31/2012 4:34:48 PM - granted resource sharp008.NBU_POLICY.MAXJOBS.sharp_Sharepoint_AllWebs
5/31/2012 4:34:48 PM - granted resource ECL986
5/31/2012 4:34:48 PM - granted resource HP.ULTRIUM4-SCSI.001
5/31/2012 4:34:48 PM - granted resource sharp008-hcart-robot-tld-0
5/31/2012 4:34:48 PM - estimated 0 Kbytes needed
5/31/2012 4:34:48 PM - begin Parent Job
5/31/2012 4:34:48 PM - begin SharePoint, Start Notify Script
5/31/2012 4:34:49 PM - started process RUNCMD (7408)
5/31/2012 4:34:49 PM - ended process 0 (7408)
Status 0
5/31/2012 4:34:49 PM - end SharePoint, Start Notify Script; elapsed time: 00:00:01
5/31/2012 4:34:49 PM - begin SharePoint, Step By Condition
Status 0
5/31/2012 4:34:49 PM - end SharePoint, Step By Condition; elapsed time: 00:00:00
5/31/2012 4:34:49 PM - begin SharePoint, Read File List
Status 0
5/31/2012 4:34:49 PM - end SharePoint, Read File List; elapsed time: 00:00:00
5/31/2012 4:34:49 PM - begin SharePoint, Resolver Discovery
5/31/2012 4:34:49 PM - started process bpbrm (7036)
Status 2
5/31/2012 4:35:09 PM - end SharePoint, Resolver Discovery; elapsed time: 00:00:20
5/31/2012 4:35:09 PM - begin SharePoint, Stop On Error
Status 0
5/31/2012 4:35:09 PM - end SharePoint, Stop On Error; elapsed time: 00:00:00
5/31/2012 4:35:09 PM - begin SharePoint, End Notify Script
5/31/2012 4:35:09 PM - started process RUNCMD (6748)
5/31/2012 4:35:10 PM - ended process 0 (6748)
Status 0
5/31/2012 4:35:10 PM - end SharePoint, End Notify Script; elapsed time: 00:00:01
Status 2
5/31/2012 4:35:10 PM - end Parent Job; elapsed time: 00:00:22
none of the requested files were backed up(2)

Comments 8 CommentsJump to latest comment

jklems99's picture

I am getting the same error. I see that no one has responded to your post. Did you figure out the problem or did you call suppor on the problem? If so, do you have a solution?

captain jack sparrow's picture

Does sharePoint have any user data ??? If not then upload something , NBU won't backup fresh MOSS. it should  get some data within sharepoint

Can you increase client's verbosity to General 2, verbose 5

Create below log directories and post it

bpbkar

beds

also from front end server if you open BAR gui are you able to see and expand SharePoint contents. If not then there is permission issue to look at

 Cheers !!!

CJS

Gaurav Kaushal's picture

I see that your backups are failing with status 2. There is something missing in your configuration settings.

Can you please upload bpresolver.log? Also I think you would not be able to see Microsoft SharePoint Resources (MSR) node in BAR GUI for backup.

Do check does the spswrapperV3.exe gets invoked in TaskManager when you initiate a backup or try to browse the MSR node in BAR GUI.

Also In 7.0.1 you needs to have BEDS folder created in logs directory for successful enumeration.

Please feel free to write back for further questions.

You can also refer to the blog post for resolution of status 2.

http://infogig.wordpress.com/2013/01/05/sharepoint-backup-using-netbackup-fails-with-status-2/

Thanks and Regards.
~gk

CRZ's picture

Hi Gaurav,

Original posts are from May and June - quite likely they've resolved their issue by now.  ;-)


bit.ly/76LBN | APPLBN | 75LBN

Marianne's picture

Seems Gaurav is searching for all unresolved Sharepoint posts in order to advertise his private blog...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Gaurav Kaushal's picture

The honest idea here is not to advertise anything but to reach out to customer with a solution via different channels. :-)

Thanks and Regards.
~gk

Doug Braden's picture

In the spirit of NBU Sharepoint and 2013 is there any roadmap info for NBU Sharepoint Agent support for 7.5.0.X??? Thanks, Doug