Video Screencast Help

MSDP - Adding credentials failed

Created: 09 May 2013 | 10 comments
wan2live's picture

 I do have a case open with support.

Anyhow when trying to create MSDP again (Original MSDP was blown away by our Unix Admins when resizing the disk, there were no images yet)

I get the error:

Adding credentials for server xxxx  failed (Server is Shutdown)

I have reinstalled NBU 7.5 and patched to 7.5.0.5 and all services are up, the Mount is present and the root pasword is the same that was used in the previous MSDP configuration and also the same password that is being used on another MSDP.

OS

2.6.18-348.3.1.el5 #1 SMP Tue Mar 5 13:19:32 EST 2013 x86_64 x86_64 x86_64 GNU/Linux

Configuration:
 
Storage server type: Media Server Deduplication Pool
Storage server name: prod-nbu-pdm01.uson.usoncology.int
User name: root
Storage path: /msdp
Database path: /var/msdp_db
Network interface: Use Default
Deduplication load balancing 
media servers: prod-nbu-pdm02. (FQDN)
Operating Systems:
Discussion Filed Under:

Comments 10 CommentsJump to latest comment

Yasuhisa Ishikawa's picture

Have you tried to delete deduplication storage server before you start reconfiguring MSDP? If not, try to delete storage server and its configuration before reconfiguring MSDP by following the steps described in NetBackup 7.5 Deduplication Guide page 158 & 159.

http://www.symantec.com/docs/DOC5187

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

wan2live's picture

Hi,

Yes I have decomissioned the Media Server and I removed the dsp with the nbcmd commands, I have ensured that the storage media server was gone, the only thing I have not done after a decom was to uninstall the media server, I guess I can give that a shot? 

PeteWall's picture

I would also run the MSDP cleanup script:

/usr/openv/pdde/pdconfigure/scripts/installers/PDDE_deleteConfig.sh

That should remove any lingering configuration that could prevent you from configuring a second time.

 

Since this is going to be a fresh configuration, you should make sure that the storage and database paths (/msdp and /var/msdp_db) don't have any files that were created from the previous configuration.

wan2live's picture

Hi Pete,

 

I ran the script as you pointed out.

Neither SppolD or Spad are running

[root@prod-nbu-pdm01 msdp]# ps -ef |grep spad
root     16634  9585  0 15:17 pts/0    00:00:00 grep spad
[root@prod-nbu-pdm01 msdp]# ps -ef |grep spoold
root     16642  9585  0 15:18 pts/0    00:00:00 grep spoold
 

 

[root@prod-nbu-pdm01 installers]# ./PDDE_deleteConfig.sh
Logging to: /var/log/puredisk/2013-05-14_15:09-pdde-delete.log
Tue May 14 15:09:17 CDT 2013 **** Starting PDDE_deleteConfig.sh ***
You need to stop the spad, spoold, and postgres daemons to proceed
This script will delete the PDDE configuration on this system
Would you want to continue? [ y | n ]
y
[Symantec/PureDisk/Install]
found it
path=/usr/openv/pdde
path line is path=/usr/openv/pdde
Tue May 14 15:09:23 CDT 2013 PureDisk Root is /usr/openv/pdde
Tue May 14 15:09:23 CDT 2013 **** Checking for PDDE services ***
Tue May 14 15:09:23 CDT 2013 **** Done checking for PDDE services ***
Tue May 14 15:09:23 CDT 2013 **** Resetting the /etc/pdregistry.cfg ***
Tue May 14 15:09:23 CDT 2013 **** Done resetting /etc/pdregistry.cfg ***
Tue May 14 15:09:23 CDT 2013 **** Removing hostname.cfg ***
Tue May 14 15:09:23 CDT 2013    * Copying a backup of prod-nbu-pdm01.uson.usoncology.int.cfg to 201305141509prod-nbu-pdm01.uson.usoncology.int.cfg *
cp: cannot stat `prod-nbu-pdm01.uson.usoncology.int.cfg': No such file or directory
Tue May 14 15:09:23 CDT 2013    * Removing prod-nbu-pdm01.uson.usoncology.int.cfg *
Tue May 14 15:09:23 CDT 2013 **** Done removing hostname.cfg ***
Tue May 14 15:09:23 CDT 2013 **** Removing pddb links ***
Tue May 14 15:09:23 CDT 2013 **** Done removing pddb links ***
[root@prod-nbu-pdm01 installers]# cd /var/msdp_db
[root@prod-nbu-pdm01 msdp_db]# ls -la
total 12
drwxrwxrwx  2 root root 4096 May  2 11:18 .
drwxr-xr-x 28 root root 4096 May  2 11:18 ..
[root@prod-nbu-pdm01 msdp_db]# cd /msdp
[root@prod-nbu-pdm01 msdp]# ls -la
total 8
drwxr-xr-x  2 root root    6 May  9 20:30 .
drwxr-xr-x 26 root root 4096 May  2 12:34 ..
[root@prod-nbu-pdm01 msdp]# 
 
I re ran the configuration for MSDP through the GUI and this is what I was presented with again:
 
Creating Storage  Server Prod-NBU-PDM01
(This is the error) Adding Credentials for server prod-nbu-pdm01 (Server Is Shutdown)
Rolling back storage server creation for Prod-NBU-PDM01
 
I have decomissioned the media server a few times and reinstalled so I am not certain if there is something lingering in the Master server but we have anothe MSDP setup that works on the Master so I am hesitant to run any removal commands on it for fear of breaking the working msdp.
 
 
Thanks for your help everyone.
 
 
 

 

huanglao2002's picture

Can you post the error record and the MSDP create logs.

Marianne's picture

Have you seen this TN?

http://www.symantec.com/docs/TECH197511

Extract:

This error is caused by invalid characters used in the password for the MSDP username. While the password may work successfully with Windows media servers, it will fail when attempting to add credentials to Linux media servers (other platforms may be affected as well.)

The characters allowed in the MSDP user's password are documented in TECH178038.

 
 
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

cds171612's picture

Hey guys, we happned to have the exact same situation. The only thing we have not tried is rebooting the master server..will try that soon but tough to find a window.

Wan2Live didyou happen to find a solution?

 

wan2live's picture

@cds171612

 

 

no luck yet sir

wan2live's picture

Look in:

 

/usr/openv/lib/ost-plugins

Delete the .CFG for the server in which you want to create the MSDP. In my case there was a config file left behind for "prod-nbu-pdm01.uson.usoncology.int.cfg" and I believe I saw some notes somewhere to look for this file but it just slipped my mind.

 

My issue has been resolved.

 

 

 

cds171612's picture

That sounds somewhat familiar to me as well...but didn't see it in the nbdecommision notes.

Will try it out..thanks!