Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

MSVCR72.dll is missing after deploy SEP v12.1.2015

Created: 27 Jun 2013 | 6 comments

Hi all,

I got a problem after deploy the SEP client to pc , after restart , when running some application popup the MSVCR72.dll is missing.

Can I set to filtering or expection of building the SEP client package ?

Or what soloution can be avoid of this problem ?

Thanks so much all of your help.

SEP_ERROR.png

Operating Systems:

Comments 6 CommentsJump to latest comment

Rafeeq's picture

Follow this document

msvcp71.dll and msvcr71.dll files deleted from system32 on SEP 11 uninstall or upgrade

jackykw's picture

Thanks Rafeeq for solution

Solution

If the SharedDLLs value for msvcp71.dll and msvcr71.dll is not set correctly, there are two options:

  • Increment the registry value (manually or via a script) before upgrading from SEP 11.
  • Copy the msvcp71.dll and msvcr71.dll files back to the machine after the upgrade.

May I ask how can I deploy the SEP to client but skip deleted the DLL ?

Or Can I build a SEP packages can pre-set the rule can skip deleted the DLL ?

Because we are now deploy SEP over 500 pc its not effectivy to cant be manually copy the DLL files to system32.

Thanks so much all of your help.

Rafeeq's picture

are you trying to do an upgraded from 11.x  version or from 12.1 to 12.1.3? whats the complete version of your 11.x?

one any one machine try installing the latest version 12.1.3 whic h is available in fileconnect.

check if the error persists.

Chetan Savade's picture

Hi,

Thank you for posting in Symantec community.

Give an attempt with the help of this article

How to create a client install setting to remove previous logs, policies and reset the client-server communication settings.
 

Chetan Savade
Sr.Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Mithun Sanghavi's picture

Hello,

This problem is fixed in Symantec Endpoint Protection 12.1 Release Update 2 (12.1 RU2). For information on how to obtain the latest build of Symantec Endpoint Protection, read ‘Obtaining the latest version of Symantec Endpoint Protection or Symantec Network Access Control

http://www.symantec.com/docs/TECH103088

Upgrade from Symantec Endpoint Protection 11.x deletes shared DLLs.
Fix ID: 2839333
Symptom: Upgrade from Symantec Endpoint 11.x to 12.1 on a 64-bit operating system deletes shared DLLs.
Solution: Changed lookup mechanism for SharedDLLs during the upgrade process.E92
 

I would recommend you to Migrate to the Latest version of SEP 12.1 RU3.

Check these Articles:

Best practices for upgrading to Symantec Endpoint Protection 12.1.3

Latest Symantec Endpoint Protection Released - SEP 12.1.RU3

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

jgrab's picture

am having the problem when upgrading clients from 11.0.7 to 12.1.4

seems its not fully fixed