Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

My Backup exec 2010 r2 does not seem to be able to recover separate mails from exchange

Created: 07 Sep 2012 • Updated: 13 Sep 2012 | 14 comments
This issue has been solved. See solution.

Hello,

We have Backupexec 2010 r2 and the exchange 2003 agent installed, i see that the complete store is backed up to disc but when i try to restore a certain mail,

i cannot grab it from the store.  In a previous version of Backupexec i could do that.

Can anyone help me with the correct settings for this ?

Thanks in advance

Eddy

Comments 14 CommentsJump to latest comment

CraigV's picture

Hi Eddy,

2 things:

1. If you use AOFO in your job, turn it off and try running a backup and then a restore and see if you can see the individual files.

2. Duplicate the backup set to disk using my article below, and then try the restore:

https://www-secure.symantec.com/connect/articles/r...

Also, BE 2010 R3 should be on your radar for a free upgrade. You can use your existing licenses so there is no need to upgrade them. Just grab copies of your Data/Catalogs folders before doing the upgrade, and then after the upgrade, run LiveUpdate to install SP2 and any additional patches. Then push-install them to any remote sites.

Grab the ISO from here:

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

E. Gruben's picture

Hello Craig,

I did not get a chance yet to go to the R3 yet, i've downloaded it but i need the time to implement this.

I was focussing on getting my data back, i could get most of it back :-)

i made a full backup yesterday and it stopped on the exchange.

Craig these are my current settings, but i want to do a full backup with the possibility to restore single mails.

after the full backup i want to switch to incremental to save space on the nas.

kind regards,

Eddy

CraigV's picture

Eddy: Those settings are fine, but check the Advanced Open File section and see if AOFO is selected.

If so...

1. Either turn it off for the whole job;

2. Split your Exchange backup and data backup from each other.

https://www-secure.symantec.com/connect/articles/backing-databases-and-files-same-tape-separate-jobs-using-backup-exec

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

E. Gruben's picture

Thanks Craig,

I will do so, a seperate backup of exchange with AOFO off and the files backup with AOFO on.

Thanks, i will let you know the result.

Eddy

E. Gruben's picture

Hello Craig,

Can you have a look at my setting please, am i not missing something ?

Is Microsoft Information Store the only thing to select ?

Thanks in advance,

Eddy

CraigV's picture

...that is perfect.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

E. Gruben's picture

ok, cause i was looking at a restore command and i see 2 more options there

Microsoft Exchange Mailboxes and Microsoft Public Folders.

Thats what i was expecting to find in the backupsettings aswell.

Why am i confused ?

Eddy

CraigV's picture

...by design.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION
E. Gruben's picture

ok, i set it up for this evening.

I'll inform you of the result :-)

Thanks and have a nice weekend.

Eddy

E. Gruben's picture

Craig,

I checked the backed up files and was able to restore them one by one.

Perfect.

I will go to R3 :-) to complete the exercise.

Thanks

Eddy Gruben

E. Gruben's picture

Craig,

I was able to install and update the R3, thanks or that.

every time i make a backup now it gives me an exeption, the remote agent on my W2000 machine is not installed, when i install this, it gives this ( ending part ) of the log:

Symantec Backup Exec Remote Agent (TM) 13 Installation Log

09-18-2012,08:41:20 : EnumProcesses Counts: 34
09-18-2012,08:41:20 : Windows Operating System Version: 5.0
09-18-2012,08:41:20 : Checking for .Net Framework 2.0 SP 2.
09-18-2012,08:41:20 : Executing managed _Setup:
09-18-2012,08:41:20 : C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\install\_Setup.exe
09-18-2012,08:41:25 : Loading XML from:
09-18-2012,08:41:25 : C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\install\IFProducts.xml
09-18-2012,08:41:25 : ArgsDataParser::InitDictionary
09-18-2012,08:41:25 : AgentSeqDlgs::RawsDlgSequence
09-18-2012,08:41:25 : Set RAWS Media path: C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\install\media\
09-18-2012,08:41:25 : RawsDlgSequence::CheckInstMode
09-18-2012,08:41:26 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,08:41:26 : Found 13.0.4164 RAWS32 Product.
09-18-2012,08:41:26 : RawsDlgSequence::CheckUpgrade
09-18-2012,08:41:26 : RawsDlgSequence::ValidateCmdLine.
09-18-2012,08:41:28 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,08:41:28 : Found 13.0.4164 RAWS32 Product.
09-18-2012,08:41:28 : Launching Silent Install
09-18-2012,08:41:28 : Running in Upgrade mode
09-18-2012,08:41:28 : AgentSeqDlgs::ADlgWelcome
09-18-2012,08:41:28 : AgentSeqDlgs::ADlgInstallType
09-18-2012,08:41:28 : RawsDlgSequence::CheckInstalledProducts
09-18-2012,08:41:28 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,08:41:28 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,08:41:28 : AgentSeqDlgs::DlgChooseCustom
09-18-2012,08:41:28 : AgentSeqDlgs::ADlgPublishRemoteSrv
09-18-2012,08:41:29 : AgentSeqDlgs::AdlgInstallComplete
09-18-2012,08:41:29 : AgentSeqDlgs::Misc_BE_CommonOps
09-18-2012,08:41:29 : A previous installation of Symantec Backup Exec Remote Agent for Windows Systems version 13.0.4164 has been detected on the local computer. The Symantec Backup Exec Remote Agent for Windows Systems will be upgraded to the version 13.0.5204. After it is upgraded, the previous installation of Remote Agent will not be available. To continue, click Next.
09-18-2012,08:41:29 : Local Install Agent
09-18-2012,08:41:29 : AgentSeqDlgs::ReadAdvertiseListKey
09-18-2012,08:41:29 : AgentSeqDlgs::ReadAdvertiseListKey
09-18-2012,08:41:29 : ;
09-18-2012,08:41:29 : AgentSeqDlgs::AgentInstaller
09-18-2012,08:41:29 : Starting Install
09-18-2012,08:41:29 : In GetVMWareGuest().
09-18-2012,08:41:29 : RAWS MSI Command Line: EXE_ENVOKED=1 ALLUSERS=1 REBOOT=ReallySuppress INSTALLDIR="C:\Program Files\Symantec\Backup Exec\RAWS" INSTALLLEVEL=200 ADDLOCAL=ALL TRANSFORMS="C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\install\Media\1033.MST" RAWSADVRTISENAMELIST=; ENABLEADVRT=1 PATCH="C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RHF144101.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RHF147674.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RHF148347.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RHF155520.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RHF159293.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS324164RSP1.msp;C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\Updates\RAWS325204RHF158028.msp;" VMWAREGUEST = 0 INSTALLUIMODE=0 CERT_BLOB=BLOB
09-18-2012,08:41:29 : Running Upgrade Mode
09-18-2012,08:41:29 : AgentInstaller::Install_Product_Thread
09-18-2012,08:41:29 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,08:41:29 : Found 13.0.4164 RAWS32 Product.
09-18-2012,08:41:29 : BEOps::BE_PrepareCachedRawsMSIForUpgrade
09-18-2012,08:41:29 : In silent mode so not starting Install Progress Thread.
09-18-2012,08:41:29 : Updated RAWS cache for PDVFS functionality
09-18-2012,08:41:30 : Updated malta RAWS cache MSI
09-18-2012,08:41:32 : Launching MSI: C:\BEW-c42439be6a6e4956ba9059b2681401fd\VxPushRA\RAWS32\install\media\Symantec Backup Exec Remote Agent for Windows Systems.msi
09-18-2012,08:42:02 : Discovered Total Actions: 124
09-18-2012,08:42:32 : The return code from the MSI is: 1601
09-18-2012,08:42:32 : AgentSeqDlgs::PostInstallActions
09-18-2012,08:42:32 : The return value for Symantec Backup Exec Remote Agent for Windows Systems returned error code: 1601
09-18-2012,08:42:32 : Clean up Symantec installer keys.
09-18-2012,08:42:33 : AgentSeqDlgs::Misc_BE_CommonOps
09-18-2012,08:42:33 : Dialog Sequence Returning errorlevel 1601
09-18-2012,08:42:33 : The Installation Failed!
09-18-2012,08:42:33 : The return code is: 1601
09-18-2012,08:42:33 : ERROR: Installation failed with error 1601. GetLastError = :0

Can i also install that agent on the server ittself or would that make no difference ?

What should i do next ?

Thanks in advance,

Eddy

CraigV's picture

Server 2000 is supported for a RAWS installation, so install that (you might need to buy a license if you don't have enough) manually via the TN below or via a push-install:

http://www.symantec.com/business/support/index?page=content&id=TECH23411

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

E. Gruben's picture

Symantec Backup Exec Remote Agent (TM) 13 Installation Log

09-18-2012,10:07:56 : EnumProcesses Counts: 35
09-18-2012,10:07:56 : Windows Operating System Version: 5.0
09-18-2012,10:07:58 : Checking for .Net Framework 2.0 SP 2.
09-18-2012,10:07:58 : Executing managed _Setup:
09-18-2012,10:07:58 : E:\RAWS32\install\_Setup.exe
09-18-2012,10:07:58 : Loading XML from:
09-18-2012,10:07:58 : E:\RAWS32\install\IFProducts.xml
09-18-2012,10:07:58 : ArgsDataParser::InitDictionary
09-18-2012,10:07:59 : AgentSeqDlgs::RawsDlgSequence
09-18-2012,10:07:59 : Set RAWS Media path: E:\RAWS32\install\media\
09-18-2012,10:07:59 : RawsDlgSequence::CheckInstMode
09-18-2012,10:07:59 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,10:07:59 : Found 13.0.4164 RAWS32 Product.
09-18-2012,10:07:59 : RawsDlgSequence::CheckUpgrade
09-18-2012,10:07:59 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,10:07:59 : Found 13.0.4164 RAWS32 Product.
09-18-2012,10:07:59 : Launching UI Install
09-18-2012,10:07:59 : Running in Upgrade mode
09-18-2012,10:07:59 : AgentSeqDlgs::ADlgWelcome
09-18-2012,10:07:59 : AgentSeqDlgs::ADlgInstallType
09-18-2012,10:07:59 : RawsDlgSequence::CheckInstalledProducts
09-18-2012,10:07:59 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,10:07:59 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,10:07:59 : AgentSeqDlgs::DlgChooseCustom
09-18-2012,10:07:59 : AgentSeqDlgs::ADlgPublishRemoteSrv
09-18-2012,10:07:59 : AgentSeqDlgs::AdlgInstallComplete
09-18-2012,10:07:59 : AgentSeqDlgs::Misc_BE_CommonOps
09-18-2012,10:07:59 : A previous installation of Symantec Backup Exec Remote Agent for Windows Systems version 13.0.4164 has been detected on the local computer. The Symantec Backup Exec Remote Agent for Windows Systems will be upgraded to the version 13.0.5204. After it is upgraded, the previous installation of Remote Agent will not be available. To continue, click Next.
09-18-2012,10:08:34 : Local Install Agent
09-18-2012,10:08:36 : AgentSeqDlgs::ReadAdvertiseListKey
09-18-2012,10:08:38 : AgentSeqDlgs::ReadAdvertiseListKey
09-18-2012,10:08:38 : ;
09-18-2012,10:08:40 : AgentSeqDlgs::AgentInstaller
09-18-2012,10:08:40 : Starting Install
09-18-2012,10:08:40 : In GetVMWareGuest().
09-18-2012,10:08:40 : RAWS MSI Command Line: EXE_ENVOKED=1 ALLUSERS=1 REBOOT=ReallySuppress INSTALLDIR="C:\Program Files\Symantec\Backup Exec\RAWS" INSTALLLEVEL=100 ADDLOCAL=VFF,VSSPROV,RANT TRANSFORMS="E:\RAWS32\install\Media\1033.MST" RAWSADVRTISENAMELIST=; ENABLEADVRT=1 PATCH="E:\RAWS32\Updates\RAWS324164RHF144101.msp;E:\RAWS32\Updates\RAWS324164RHF147674.msp;E:\RAWS32\Updates\RAWS324164RHF148347.msp;E:\RAWS32\Updates\RAWS324164RHF155520.msp;E:\RAWS32\Updates\RAWS324164RHF159293.msp;E:\RAWS32\Updates\RAWS324164RSP1.msp;E:\RAWS32\Updates\RAWS325204RHF158028.msp;" VMWAREGUEST = 0 INSTALLUIMODE=1
09-18-2012,10:08:40 : Running Upgrade Mode
09-18-2012,10:08:41 : AgentInstaller::Install_Product_Thread
09-18-2012,10:08:41 : BEOperations::BE_GetInstalledProdCodeVersion()
09-18-2012,10:08:41 : Found 13.0.4164 RAWS32 Product.
09-18-2012,10:08:41 : BEOps::BE_PrepareCachedRawsMSIForUpgrade
09-18-2012,10:08:41 : Updated RAWS cache for PDVFS functionality
09-18-2012,10:08:41 : Updated malta RAWS cache MSI
09-18-2012,10:08:43 : Launching MSI: E:\RAWS32\install\media\Symantec Backup Exec Remote Agent for Windows Systems.msi
09-18-2012,10:09:13 : Discovered Total Actions: 124
09-18-2012,10:09:43 : The return code from the MSI is: 1601
09-18-2012,10:09:43 : AgentSeqDlgs::PostInstallActions
09-18-2012,10:09:43 : Cleaning up the symc status key
09-18-2012,10:09:43 : The return value for Symantec Backup Exec Remote Agent for Windows Systems returned error code: 1601
09-18-2012,10:09:43 : Clean up Symantec installer keys.
09-18-2012,10:09:47 : AgentSeqDlgs::Misc_BE_CommonOps
09-18-2012,10:09:47 : Dialog Sequence Returning errorlevel 1601
09-18-2012,10:09:47 : The Installation Failed!

CraigV's picture

...moved your new query to the thread below:

https://www-secure.symantec.com/connect/forums/raws-windows-2000

But consider stopping any AV running on that server, and make sure it is up to SP4 for Windows 2000 Server with Roll Up 1.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...