Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

My Backup Exec 2010 R3 Backup Job Fails with Error 0x5 - Access is denied.

Created: 07 Dec 2011 | 2 comments

I really would appreciate any help on this, as at present my backups are failiing intermittently, or basically not working.

My Environment:

  • Windows 2008 Server Enterprise R2 (64-bit)
  • Symantec Backup Exec 2010 R3 (Version 13.0 Rev 5204)
  • Running a host (GNHost) three virtual servers (GNMain, GNWeb, GNExchange) on the machine.
  • The host and all virtuals have Symantec Endpoint Protection Version 12.1.1000.157 RU1 running.
  • The virtual server on which the error is occuring is GNWeb, which has IIS 7.5 and SQL Server 2008 R2 running.
  • The problem seems to be related to backing up the SQL instance (and its databases).
  • I have only had Backup Exec 2010 R3 running on this new system for a couple of weeks.

My Problem:

When I run a full backup I get the following error:

Final Error: 0x5 - Access is denied. 

Final Error Category: Other Errors 5

The specific error is:

Backup- VRTSRV::\\GNHost.goodnewsjail.org\Hyper-V?Virtual?Machine\GNWeb - Error. Cannot backup directory \zzzVirtApp000zzz and its subdirectories. 

However, I can run the same test backup job (which just has GNWeb selected under Hyper-V) and have it fail once, run again and not fail.  When it fails, everything but the SQL instance (and its databases) get backed up.  When it runs successfully, everything, including the SQL instance (and its databases) get backed up fine.  I just ran the job at 10:00 AM and again at 11:00 AM.  The first failed.  The second "completed with exceptions."

The "exception" I get that might be related follows.  This exception comes up every time I run the backup whether it fails or succeeds:

V-79-57344-38728 - The SQL database 'OneDay' on virtual machine 'GNWeb' is configured to maintain transaction logs, but transaction log backups are not being performed. Not backing up the transaction log results in the log growing in size until it fills all available disk space. You should either schedule regular log backups or change the database to the simple recovery mode.

 Please note:  When I modify the selection to include "User-Defined Selections" and check the SQL instance under GNWeb, even when the Hyper-V backup (snapshot) of the SQL instance fails per the above, the User-Defined Selections backup of the instance completes without the error.

I have included an attachment of the job log as a .txt file
 

Comments 2 CommentsJump to latest comment

pkh's picture

To clear the SQL log problem, you need to run a separate job to backup and truncate the transaction log.  See this document

http://www.symantec.com/docs/TECH126063

Chaplain Doug's picture

Thank you.  I have cleared the SQL log issue.  I need to see if the other issue is still a problem.