Video Screencast Help

NBPEM is spawning many process

Created: 20 Feb 2014 • Updated: 16 May 2014 | 8 comments

Hi All,

many nbpem process running in a environment.......tried to restarted the services....but after a while nbpem start spawning child nbpem processes....rename pempersist2 and restarted the service but no luch...check with bpclntcmd -p giving right output..also check using bptestbpcd giving right output...also validated nbdb it was sucessful.

Netbackup is 7.5.0.7 none of the backups are runiing in a environment...any help would be appreciated..

Many thanks..

Operating Systems:
Discussion Filed Under:

Comments 8 CommentsJump to latest comment

Marianne's picture

How many active backup jobs when you see this?

Have you had a look at nbpem log?

vxlogview -o 116 -t 00:10:00

This command will show nbpem logs for the last 10 minutes. Adjust time to cover start time. Send output to a file if lots of output.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

techie007's picture

Thanks Marianne for the reply...no schedule jobs are running also i tried to run the manual backup it is also not intiating....I did not check the nbpem log yet...

SymTerry's picture

Just to make sure when you run nbpemreq -jobs, what do you see? This will show jobs the state of current jobs and jobs that have run in the previous 30 minutes.

Also try running nbpemreq -persisted as this will give information about the contents of the nbpem persistence database file, which contains information about the jobs that are currently running. If nbpem is interrupted, like then restarting services, NetBackup knows which jobs to run when nbpem restarts.

The vxlogview log Marianne requested will also be very usefull in seeing what pem is tring to do.

techie007's picture

I tried to run nbpemreq -updatepolicies and it was giving corba exception error

mph999's picture

Can you check PBX is running, should be seen in the output of bpps -x

If manual backups aren't working, the issue is outside nbpem.  Did the upgrade complete successfully.

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Brian Costello's picture

Does the master server have more than one IP address? I have seen nbpem start to freak out when there was a second IP address that referenced another name in DNS.

techie007's picture

Hi All,

Apologies for the late reply.

It was due to change in hosts file , after editing the hosts file issue got resolved

Marianne's picture

It was due to change in hosts file 

Please tell us what exactly was wrong with hosts file?

I will gladly mark your post as Solution if we know what was wrong and how it affected NBU.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links