Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NBS - PXEPreZero: Invalid PXE Server list format

Created: 21 Mar 2014 • Updated: 25 Mar 2014 | 6 comments
This issue has been solved. See solution.

Hi all,


I have problem with new installation of Network Boot Service (SMP 7.5).


My server is WinServer 2008 R2.

Installed Altiris Client Management Suite 7.5


If the clients want to booting to the PXE environment, it shows error PXEPreZero: Invalid PXE Server list format.


On server I created  one preboot configuration (WinPE) and assoc to Network Boot Service Configuration  in NBS General Configuration.

180px_NBS Gen Set.PNG


On DHCP I use Scope Option 66 with server IP and 67 with BStrap\X86PC\BStrap.0 and it appears that is ok, because when I delete BStrap.0 on server then it shows error PXE-T01: No such file.


In Preboot Configurations I Recreated Preboot Environment and without resolving.

When I clicked to Recreate Preboot Envoronment, I saw Bootwiz as process about 15minutes.


I don't know why I have problem with Invalid PXE Server list format...


Any ideas?




Operating Systems:

Comments 6 CommentsJump to latest comment

Pagrossman's picture

Server with DHCP is another that site server with NBS plugin, but both are on same subnet.

Subnet for clients is another...


On Site Server I set two subnets...


Klim_Belchev's picture

Maybe try to to reconfigure DHCP Option 67 - try without, x86 and x64

Should be something like this below depending on your architecture:

067 Bootfile Name, value: BStrap\X86pc\BStrap.0


067 Bootfile Name, value: BStrap\X64\BStrap.0


This article might be of help:



Klim_Belchev's picture

On a second thought you could use WireShark or similar to capture traffic between PXE Server and a client. That might give you a clue on whats going on...

Klim_Belchev's picture

Have you tried to configure DHCP Option 43 - PXE in Forced mode?

You can use the article above to configure.

Pagrossman's picture

It seems that it's resolved...

Problem is in IPHelper. PXE has problem with more subnets. These links help me...

When I moved PXE server to same subnet as clients, PXE worked...