Video Screencast Help

nbu 6.0 installing clients without "pushing" them

Created: 18 Oct 2013 • Updated: 18 Oct 2013 | 8 comments

*** Moved to new discussion from https://www-secure.symantec.com/connect/forums/suse10-client-required-nbu-60 ***

 

Hi,

I have one further question! It's fustrating to get ftp configured on differnet linux versions in order to push the client out. Is it possible to manually copy over the client software?

I was thinking of pushing all of my clients, four in total, to one server. Next tar up each client directory and then I can just copy that onto any new client servers without having to fiddle around with ftp. Would this work or is each "pushed" client specific to that client server, i.e hostname is hardcoded into the client software etc.

 

Regards,

 

Ed

Operating Systems:

Comments 8 CommentsJump to latest comment

Marianne's picture

Best to install all required Linux/Unix binaries on the master server.

Use Unix/Linux Clients install media to install client software on the master server. Reinstall NBU client patch on the master server with '-p' option to force-install the patch. 
You will now have updated client binaries on the master from where client software can be pushed to Unix/Linux clients.

Use update_clients to patch existing clients or one of the push-install methods listed in NBU 6.0 Installation Guide: http://www.symantec.com/docs/TECH43924

See Installing UNIX Client Software Remotely 

Unfortunately push-install options are limited with NBU 6.0. As from NBU 6.5, ssh and sftp can be used as well. You REALLY need to upgrade!!!

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Nagalla's picture

what are the steps that you are following to push the netbackup software..?

is that the base installtion or the upgrade ?

 

other way that i can suggest is..

keep NBU software on one of the server and configure it as NFS server.. and them start mounting the NFS on each server and go with the installation..

but this requiries to login each server and do the NFS mounts.. 

aherned's picture

Hi Marianne / Nagalla,

Currently I push clients via the command line(master is running on solaris 10):

/usr/openv/netbackup/bin/install_client_files ftp foo bar

But ftp must work on the client in order for the "push" to work. We have several versions of linux here and ftp is not installed/enabled and is blocked some cases.

To avoid all this churn with ftp, I'm looking for a way to bypass it.

So as I mentioned earlier, I pushed the clients to a working server, tar'd them up. Next I created a backup policy for a new linux client. Then I untar'd the RedHat2.4 client on RH5.8 client server and it successfully installed. But when I try to execute a backup I get an error 59, see below. I'm currently trying to debug this with the aid of the nbu troubleshooting guide.

From a client installation pov can you see anything wrong with this method? Does the install_client_files script do something extra that I'm missing by untar'ing and running the install command, ie:

sh /tmp/bp.8234/client_config -L

 

Regards,

Ed

 

 

10/18/2013 11:20:28 - Error bpbrm (pid=21018) bpcd on shdev1 exited with status 59: access to the client was not allowed

10/18/2013 11:20:25 - requesting resource Any

10/18/2013 11:20:25 - requesting resource setanta.NBU_CLIENT.MAXJOBS.shdev1

10/18/2013 11:20:25 - requesting resource setanta.NBU_POLICY.MAXJOBS.UNIXFile-A

10/18/2013 11:20:25 - granted resource setanta.NBU_CLIENT.MAXJOBS.shdev1

10/18/2013 11:20:25 - granted resource setanta.NBU_POLICY.MAXJOBS.UNIXFile-A

10/18/2013 11:20:25 - granted resource SNN165

10/18/2013 11:20:25 - granted resource HP.ULTRIUM3-SCSI.000

10/18/2013 11:20:25 - granted resource setanta-hcart3-robot-tld-0

10/18/2013 11:20:26 - started process bpbrm (pid=21018)

10/18/2013 11:20:28 - end writing

access to the client was not allowed (59)

 

 

 

 

Nagalla's picture

access to the client was not allowed (59)

indicates that the client bp.conf does not have the Media server entries.. or its not able to resolve the media server names that is trying to take the backups..

make sure bp.conf has media server entries and the name/IP resolutions are fine..

Marianne's picture

Nothing wrong with your method.

Status 59 is simply a matter of reverse lookup and SERVER entries...

Ensure that client can resolve master and/or media server IP address to a hostname that appears in bp.conf as SERVER entry. 
Resolved hostname and SERVER entry must match exactly:
Master != master != master.fqdn

Create bpcd log folder on client under /usr/openv/netbackup/logs to see server IP address in connection attempt and how client is resolving IP address to hostname. 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

aherned's picture

Hi Marianne / Nagalla,

That worked, as you said it was a name/IP resolutions.bp.conf issue. I also had to change CLIENT_NAME in bp.conf.

Excellent, the backups are running now, it spares me a lot of time messing with ftp on each client.

Thanks for the help, thats the best support I've ever received for any application :-)

 

Regards,

 

Ed

 

Marianne's picture

Good thing you spotted CLIENT_NAME, although it is only used when restores are started on the client.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Stumpr2's picture

from my jotted down notes:

1. Identify client similar to the client being upgraded/installed with NetBackup

2. create tarball of /usr/openv directory from similar server

2. scp tarball and extract on server to be installed/upgraded

3a. For Solaris/AIX/HP servers add service entries vnetd bpcd veritas_pbx to /etc/services inetd.conf

4. edit /usr/openv/netbackup/bp.conf  CLIENT_NAME =

5. restart inetd

 

yeah it is little tricky on Linux servers under  /etc/xinetd.d we need to confirm if there are files bpcd & vnetd

these files have the script for the path for bpcd and vnetd 

# Service bpcd for NetBackup
service bpcd
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/openv/netbackup/bin/bpcd
        disable = no

}
 

service vnetd
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/openv/bin/vnetd
        disable = no
        instances = UNLIMITED
        cps = 1000 1

}
 

check above whether server=/usr/openv .... path is correct or not

VERITAS ain't it the truth?