Video Screencast Help

NBU App Cluster - NBU not following app

Created: 14 Sep 2012 • Updated: 25 Sep 2012 | 3 comments
This issue has been solved. See solution.

Hi All,

I have created an NBU app cluster for non failover media servers.

I ran the first backup and it worked fine, i failed over the cluster and then re-ran the backup, now netbackup is trying to use the same media server as the first backup, when this is no longer the active node. NBU isnt following the app cluster.

Ive configured as per the high availablity guide, and the cluster config looks ok also.

Any idea's? I am using the app_cluster name as a client and as the media server in storage units. Job fails with status 10, and thats because its not followed the app cluster to the now active node.


Comments 3 CommentsJump to latest comment

Marianne's picture

You never mentioned your NBU version?

As from NBU 7.0.1, the product keeps a host cache that is refreshed once per hour.

So, if you have kicked off a manual backup within one hour of failover, you need to clear host cache first:

bpclntcmd -clear_host_cache
Do this on master server, followed by 'nbemmcmd -listhosts -verbose' to confirm that active node name has been updated.



Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Jaykullar's picture

Hi Marianne,

Thanks. Yes its NBU 7.1. Is there any way to change the host cache refresh rate? To say 30 minutes?

CRZ's picture

It is possible, but it isn't something we talk about publicly.  You'd need to open a support case and talk to a TSE about it.

(If you don't want to do call us, a quick and dirty workaround might be to throw Marianne's bpclntcmd into a cron job to clear the cache at some regular interval - oh, like, every thirty minutes...but you didn't hear that from me!) | APPLBN | 761LBN